Contribute
Register

YOSEMITE RECOVERY HD WON'T BOOT (clover install)...panic CPU

Joined
Mar 26, 2013
Messages
68
Motherboard
GA-Z77X-UD5H
CPU
i7-3770K OC 4.6GHz
Graphics
GTX 660 Ti
Mac
iMac
Mobile Phone
Android, iOS
Hi,

yesterday, i've messed up with my clover "config file" and BIOS settings so i reinstalled clover.
Yosemite boot is fine now but i've got a "PANIC CPU" when i try booting from the "RECOVERY HD" partition.
I can only boot from it (the RECOVERY HD) in "safe mode"

How can i repair it? (or recreate it)
Should i try reinstall yosemite from the RECOVERY HD booted in "safe mode"?

If you have an advice :confused:

Thanks
 
Joined
Mar 26, 2013
Messages
68
Motherboard
GA-Z77X-UD5H
CPU
i7-3770K OC 4.6GHz
Graphics
GTX 660 Ti
Mac
iMac
Mobile Phone
Android, iOS
OK I've found the solution, my recovery HD was corrupt

The following did fix my issue:

  • downloaded the yosemite installer (again)
  • created a bootable installation (8GB USB) drive with yosemite (USB drive volume name is Untitled).
sudo /Applications/Install\ OS\ X\ Yosemite.app/Contents/Resources/createinstallmedia --volume /Volumes/Untitled --applicationpath /Applications/Install\ OS\ X\ Yosemite.app --nointeraction
  • Removing the not working recovery partition
diskutil eraseVolume HFS+ ErasedDisk /dev/disk0s3
  • merging the free space with the Macintosh HD partition
diskutil mergePartitions HFS+ MacHD disk0s2 disk0s3
  • Install (like you upgrade) Yosemite over your existing (Yosemite) installation and complete the installation procedure (I used the installer from the fresh created USB).
After the installation was completed I rebooted the machine and I was able to use the find my Mac option again (error related to the recovery partition was gone).
This worked for me, a small (typing) error might result in loosing your installation + data. Please be sure you have a good working backup before you start!
 
Top