Contribute
Register

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,467
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
I know nothing about startup daemon, can you link me where I can learn what it is and how to use it?

Read about /Library/LaunchDaemons.
 
Joined
Aug 30, 2015
Messages
96
Motherboard
MSI B85m Gaming
CPU
i3-4170
Graphics
GTX 970
Mac
  1. iMac
  2. MacBook Pro
Classic Mac
  1. iMac
Mobile Phone
  1. iOS
You can set all trackpad settings using 'ioio' from a startup daemon.
How would I configure this launchdaemon with 'ioio'? Screen Shot 2016-09-23 at 3.47.14 PM.png
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,467
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
How would I configure this launchdaemon with 'ioio'? View attachment 211776

Create a shell script with the desired 'ioio' commands. Install the shell script where it can be reached by your daemon plist. Install ioio where it can be reached from your script.
 
Joined
Aug 30, 2015
Messages
96
Motherboard
MSI B85m Gaming
CPU
i3-4170
Graphics
GTX 970
Mac
  1. iMac
  2. MacBook Pro
Classic Mac
  1. iMac
Mobile Phone
  1. iOS
@RehabMan sorry to bother, but I realized that my battery drains very fast by just watching youtube. I bought a new battery but the issue remains. I used coconutbattery and the battery life is at 100%... Is this something to do with CPU power management?I've uploaded some files for problem reporting on the previous page. Thanks for helping!
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,467
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
@RehabMan sorry to bother, but I realized that my battery drains very fast by just watching youtube. I bought a new battery but the issue remains. I used coconutbattery and the battery life is at 100%... Is this something to do with CPU power management?I've uploaded some files for problem reporting on the previous page. Thanks for helping!

You did not implement power management. And your SMBIOS is not what is recommended by the guide.
 
Joined
Aug 30, 2015
Messages
96
Motherboard
MSI B85m Gaming
CPU
i3-4170
Graphics
GTX 970
Mac
  1. iMac
  2. MacBook Pro
Classic Mac
  1. iMac
Mobile Phone
  1. iOS
@RehabMan Thanks for replying! May you tell me how to tell if my power management is implemented? Also, I ran the following lines again, supposedly this is the code for power management (I got it from the guide)?
Code:
cd ~/Projects/y50.git
curl -o ./ssdtPRGen.sh https://raw.githubusercontent.com/Piker-Alpha/ssdtPRGen.sh/master/ssdtPRGen.sh
chmod +x ./ssdtPRGen.sh

./ssdtPRGen.sh -p 'i7-4710HQ' -f 2600 -turbo 3600
If this isn't the way, how would I implement power management? I have a i7 4710HQ.

On a side note, what can I do to make the touchpad settings stick...? It resets every time I reboot.
 
Last edited:

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,467
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
@RehabMan Thanks for replying! May you tell me how to tell if my power management is implemented? Also, I ran the following lines again, supposedly this is the code for power management (I got it from the guide)?
Code:
cd ~/Projects/y50.git
curl -o ./ssdtPRGen.sh https://raw.githubusercontent.com/Piker-Alpha/ssdtPRGen.sh/master/ssdtPRGen.sh
chmod +x ./ssdtPRGen.sh

./ssdtPRGen.sh -p 'i7-4710HQ' -f 2600 -turbo 3600
If this isn't the way, how would I implement power management? I have a i7 4710HQ.

Read Y50 guide, post #1, "Problem Reporting".

On a side note, what can I do to make the touchpad settings stick...? It resets every time I reboot.

Known problem in Sierra.
 
Joined
Aug 30, 2015
Messages
96
Motherboard
MSI B85m Gaming
CPU
i3-4170
Graphics
GTX 970
Mac
  1. iMac
  2. MacBook Pro
Classic Mac
  1. iMac
Mobile Phone
  1. iOS
Read Y50 guide, post #1, "Problem Reporting".
I don't think I'm quoting correctly... so @RehabMan
Hi RehabMan, I got all the files needed right now for problem reporting. I think the power management seems ok right now, but I don't seem to get 5G WiFi working, and also for some reason I can't boot into windows right now from clover... Can you please help me take a look? Thanks.
Code:
Erics-MacBook-Pro:~ eric$ kextstat|grep -y acpiplat
   13    2 0xffffff7f830ae000 0x60000    0x60000    com.apple.driver.AppleACPIPlatform (5.0) D748FA50-380C-3F0D-BAD9-EB7A15848EA8 <12 11 7 6 5 4 3 1>
Erics-MacBook-Pro:~ eric$ kextstat|grep -y appleintelcpu
Erics-MacBook-Pro:~ eric$ kextstat|grep -y applelpc
   84    0 0xffffff7f82c04000 0x3000     0x3000     com.apple.driver.AppleLPC (3.1) F51595F0-F9B1-3B85-A1C3-F984DAD4107E <78 12 5 4 3>
Erics-MacBook-Pro:~ eric$ kextstat|grep -y applehda
   88    1 0xffffff7f811fe000 0x1d000    0x1d000    com.apple.driver.AppleHDAController (276.26) D0953002-6091-376F-8E0F-33B65F42CEF9 <87 86 71 12 7 6 5 4 3 1>
  111    0 0xffffff7f813a0000 0xb4000    0xb4000    com.apple.driver.AppleHDA (9274.7) 7611D43E-12FE-3228-A6D3-9C99A5D030CC <110 89 88 87 86 71 12 11 6 5 4 3 1>

Code:
kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext VoodooPS2Trackpad.kext
kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext VoodooPS2Mouse.kext
kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext VoodooPS2Keyboard.kext
kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext VoodooPS2Controller.kext
kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext USBInjectAll.kext
kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext RealtekRTL8111.kext
kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext IntelBacklight.kext
kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext FakeSMC.kext
kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext FakePCIID_Intel_HDMI_Audio.kext
kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext FakePCIID_Intel_HD_Graphics.kext
kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext FakePCIID_Broadcom_WiFi.kext
kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext FakePCIID.kext
kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext CodecCommander.kext
kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext BrcmPatchRAM2.kext
kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext BrcmFirmwareRepo.kext
kext-dev-mode allowing invalid signature -67030 0xFFFFFFFFFFFEFA2A for kext AppleHDA_ALC283.kext
kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext ACPIBatteryManager.kext
 

Attachments

  • RehabMan.zip
    32.6 KB · Views: 51
  • Eric’s MacBook Pro.ioreg
    3.4 MB · Views: 113
  • CLOVER.zip
    8.2 MB · Views: 61
  • Microsoft.zip
    11.7 MB · Views: 49

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,467
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
I don't think I'm quoting correctly... so @RehabMan
Hi RehabMan, I got all the files needed right now for problem reporting. I think the power management seems ok right now, but I don't seem to get 5G WiFi working, and also for some reason I can't boot into windows right now from clover... Can you please help me take a look? Thanks.
Code:
Erics-MacBook-Pro:~ eric$ kextstat|grep -y acpiplat
   13    2 0xffffff7f830ae000 0x60000    0x60000    com.apple.driver.AppleACPIPlatform (5.0) D748FA50-380C-3F0D-BAD9-EB7A15848EA8 <12 11 7 6 5 4 3 1>
Erics-MacBook-Pro:~ eric$ kextstat|grep -y appleintelcpu
Erics-MacBook-Pro:~ eric$ kextstat|grep -y applelpc
   84    0 0xffffff7f82c04000 0x3000     0x3000     com.apple.driver.AppleLPC (3.1) F51595F0-F9B1-3B85-A1C3-F984DAD4107E <78 12 5 4 3>
Erics-MacBook-Pro:~ eric$ kextstat|grep -y applehda
   88    1 0xffffff7f811fe000 0x1d000    0x1d000    com.apple.driver.AppleHDAController (276.26) D0953002-6091-376F-8E0F-33B65F42CEF9 <87 86 71 12 7 6 5 4 3 1>
  111    0 0xffffff7f813a0000 0xb4000    0xb4000    com.apple.driver.AppleHDA (9274.7) 7611D43E-12FE-3228-A6D3-9C99A5D030CC <110 89 88 87 86 71 12 11 6 5 4 3 1>

Code:
kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext VoodooPS2Trackpad.kext
kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext VoodooPS2Mouse.kext
kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext VoodooPS2Keyboard.kext
kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext VoodooPS2Controller.kext
kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext USBInjectAll.kext
kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext RealtekRTL8111.kext
kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext IntelBacklight.kext
kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext FakeSMC.kext
kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext FakePCIID_Intel_HDMI_Audio.kext
kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext FakePCIID_Intel_HD_Graphics.kext
kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext FakePCIID_Broadcom_WiFi.kext
kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext FakePCIID.kext
kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext CodecCommander.kext
kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext BrcmPatchRAM2.kext
kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext BrcmFirmwareRepo.kext
kext-dev-mode allowing invalid signature -67030 0xFFFFFFFFFFFEFA2A for kext AppleHDA_ALC283.kext
kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext ACPIBatteryManager.kext

The guide recommends MacBookPro11,1 not MacBookPro11,2.
You did not implement power management (read the guide).
The ioreg shows WiFi working. If your issue is with 5ghz only, make sure you have the correct patch for your region. Your config.plist currently using US FCC.
 
Joined
Aug 30, 2015
Messages
96
Motherboard
MSI B85m Gaming
CPU
i3-4170
Graphics
GTX 970
Mac
  1. iMac
  2. MacBook Pro
Classic Mac
  1. iMac
Mobile Phone
  1. iOS
The guide recommends MacBookPro11,1 not MacBookPro11,2.
You did not implement power management (read the guide).
The ioreg shows WiFi working. If your issue is with 5ghz only, make sure you have the correct patch for your region. Your config.plist currently using US FCC.
Hi! I did some work to run the power management commands, and also I changed the SMBIOS, can you help me take a quick look? I live in the US, so I don't think it has something to do with the region, maybe its because Time Warner changed something...

This time I think I quoted correctly...
 

Attachments

  • CLOVER.zip
    8.2 MB · Views: 64
Top