Contribute
Register

XPS13 9350 Audio problems

Joined
Oct 11, 2016
Messages
5
CPU
i7-6560M
Graphics
Intel Iris 540
Hi, everyone,

I have a Dell XPS 13 9350(ALC256) on El Capitan but fail to use the audio. I have setup AppleHDA_ALC256.kext and CodecCommander.kext and it says that No Input(Output) Devices Found and I have no idea about it...

Is there any advice? Thanks so much!
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,691
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Hi, everyone,

I have a Dell XPS 13 9350 on El Capitan but fail to use the audio. I have setup AppleHDA_ALC256.kext and CodecCommander.kext and it says that No Input(Output) Devices Found and I have no idea about it...

Is there any advice? Thanks so much!
Did you patch ACPI as required for AppleHDA_ALC256.kext?
Did you add the required patches for AppleHDA to config.plist?
Did you boot without caches and rebuild cache as required when using an AppleHDA injector as detailed in the FAQ?
 
Joined
Oct 11, 2016
Messages
5
CPU
i7-6560M
Graphics
Intel Iris 540
Did you patch ACPI as required for AppleHDA_ALC256.kext?
Did you add the required patches for AppleHDA to config.plist?
Did you boot without caches and rebuild cache as required when using an AppleHDA injector as detailed in the FAQ?
Hi, sorry i reply so late because of the exams these days.
I injected the AppleHDA as you said and set the config.plist and now I get my speaker working, but the headphone is not.
I've tried the cloverHDA(https://github.com/insanelydeepak/cloverHDA-for-Mac-OS-Sierra-10.12) though it seems not to fit 10.11 and of course I failed....
Now my headphone jack is still not working... Would you please give me some advice at your convenience? Thank you very much!
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,691
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Hi, sorry i reply so late because of the exams these days.
I injected the AppleHDA as you said and set the config.plist and now I get my speaker working, but the headphone is not.
I've tried the cloverHDA(https://github.com/insanelydeepak/cloverHDA-for-Mac-OS-Sierra-10.12) though it seems not to fit 10.11 and of course I failed....
Now my headphone jack is still not working... Would you please give me some advice at your convenience? Thank you very much!
Headphone issue is probably due to incorrect XML in the AppleHDA components you have chosen.
 
Joined
Oct 11, 2016
Messages
5
CPU
i7-6560M
Graphics
Intel Iris 540
Headphone issue is probably due to incorrect XML in the AppleHDA components you have chosen.
Thanks for your reply, but I find that I didn't heard about this thing...
Could you tell me more about how to get a correct one? Thanks again.
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,691
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Thanks for your reply, but I find that I didn't heard about this thing...
Could you tell me more about how to get a correct one? Thanks again.
You can read about AppleHDA patching, Intel HDA spec, etc...
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,691
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Seems really complex...
You are correct. AppleHDA patching is complex, and it takes a fair bit of reading to understand the HDA spec.
 
Joined
Feb 1, 2019
Messages
4
@Kirspencil have you fixed the problem man? im in mojave and still dont know how to fix this.
 
Top