Contribute
Register

XPS 9700 - dGPU won't go off/sleep

Joined
Dec 20, 2018
Messages
744
Motherboard
Gigabyte Z370 AORUS Gaming 7
CPU
i7-8700K OC 5GHz
Graphics
GTX 1080 Ti & UHD 630
Mac
  1. iMac
  2. MacBook Pro
  3. Mac Pro
Mobile Phone
  1. iOS
Appears to be a variant of UHD 630, I'm using platform id 0500A53E + SMBIOS iMac19,1 with a bunch of framebuffer patches to get my internal screen working + dual 4k monitors @60 Hz over display port.
I think may be causing you issue. this is a laptop? if so, don't think you should be using an iMac smbios. start with changing the smbios and finding something that fits the hardware you have
 
Joined
Apr 30, 2020
Messages
33
Motherboard
Dell XPS 9700 (OpenCore)
CPU
i7-10875H
Graphics
UHD 630, 1980x1200
I think may be causing you issue. this is a laptop? if so, don't think you should be using an iMac smbios. start with changing the smbios and finding something that fits the hardware you have
That's not the issue, thanks though.
 
Joined
Dec 20, 2018
Messages
744
Motherboard
Gigabyte Z370 AORUS Gaming 7
CPU
i7-8700K OC 5GHz
Graphics
GTX 1080 Ti & UHD 630
Mac
  1. iMac
  2. MacBook Pro
  3. Mac Pro
Mobile Phone
  1. iOS
That's not the issue, thanks though.
post your efi I wanna have a look. something isn't right with your setup. something simple I believe
 
Joined
Dec 20, 2018
Messages
744
Motherboard
Gigabyte Z370 AORUS Gaming 7
CPU
i7-8700K OC 5GHz
Graphics
GTX 1080 Ti & UHD 630
Mac
  1. iMac
  2. MacBook Pro
  3. Mac Pro
Mobile Phone
  1. iOS
That's not the issue, thanks though.
this may provide something useful
 
Joined
Apr 30, 2020
Messages
33
Motherboard
Dell XPS 9700 (OpenCore)
CPU
i7-10875H
Graphics
UHD 630, 1980x1200
I think I got it to turn off. If someone wants to use my SSDT (it's modified, not the exact version on Dortania) and see how it works for you, please report back. If anyone has any improvements to build on this, I'm all ears.
 

Attachments

  • SSDT-dGPU-Off.aml
    167 bytes · Views: 43
Joined
Dec 18, 2013
Messages
485
Motherboard
Lenovo Yoga C740
CPU
i7-10510U
Graphics
Intel UHD Graphics
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. Android
Strange, I have an 9700 as well, at least here, no special SSDT needed. Sleep is working fine.

It's a powerful, loud machine, with a stunning display but the sound is not working here neither.
 
Joined
Apr 30, 2020
Messages
33
Motherboard
Dell XPS 9700 (OpenCore)
CPU
i7-10875H
Graphics
UHD 630, 1980x1200
Strange, I have an 9700 as well, at least here, no special SSDT needed. Sleep is working fine.

It's a powerful, loud machine, with a stunning display but the sound is not working here neither.
Are you saying you are getting the dGPU to shut off with the regular SSDT? It's not loud when I'm using it for basic tasks - are your fans running a lot? Mine are generally off.

Sleep is broken for me, did you do anything to get it working?
 
Joined
Jul 21, 2011
Messages
370
Motherboard
Zbook G5 17"
CPU
i7
Graphics
AMD WX-4170
Mac
  1. MacBook Pro
  2. Mac mini
  3. Mac Pro
Sleep is broken for me, did you do anything to get it working?
Very likely you need to turn dGPU ON before sleep and then again OFF after wake. Search for DGPU OFF Rehabman in this forum for ideas.
 
Joined
Dec 18, 2013
Messages
485
Motherboard
Lenovo Yoga C740
CPU
i7-10510U
Graphics
Intel UHD Graphics
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. Android
Here's my EFI, try it out. If it works just replace the serial placeholders. I would actually need to clean it up a little but it works OK, so I don't care.

Actually Bluetooth is broken.

Back to topic, Whatevergreen deactivates the DGPU, there is a simple parameter you need: disable-external-gpu / Data / 01000000.

That's it.
 

Attachments

  • XPS17-9700_Monterey-EFI.zip
    74.7 MB · Views: 43
Joined
Apr 30, 2020
Messages
33
Motherboard
Dell XPS 9700 (OpenCore)
CPU
i7-10875H
Graphics
UHD 630, 1980x1200
Here's my EFI, try it out. If it works just replace the serial placeholders. I would actually need to clean it up a little but it works OK, so I don't care.

Actually Bluetooth is broken.

Back to topic, Whatevergreen deactivates the DGPU, there is a simple parameter you need: disable-external-gpu / Data / 01000000.

That's it.
Hey, thanks for uploading. The WEG flag doesn't seem to effectively disable the dGPU as I'm seeing much higher power draw if I only use that flag and not my SSDT. Are you running on AC power so you haven't noticed that?

Which sleep/hibernation mode do you have set up? You're able to sleep for 5+ minutes and wake up properly?
Did you change any BIOS variables?
 
Top