Contribute
Register

XPS 9360 Installation stalling at 2 minutes left

Status
Not open for further replies.
Joined
Mar 22, 2011
Messages
93
Motherboard
ASUS Prime Z390-A bios 1402
CPU
8700K
Graphics
5700 XT
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. iMac
Mobile Phone
  1. Android
Dell XPS 9360
i7-8550U
QHD+ Screen
Intel 620 Graphics
16GB RAM
512GB SSD - Samsung PM961 / 68V6F
Dell bios 2.6.2

I've configured my BIOS settings as recommended, and made extra changes for DVMT as such:
CFG Lock - Disabled 0x4de - 0x00
DVMT Pre-allocation - 0x785 - 0x03 (64M. 96 and 128 were not options when I extracted my bios)
DVMT Total Gfx Memory - 0x786 - 0x03 (MAX)

I do not have any NVME kexts in place, it's not clear to me that I need any with this part #? From what I have read, I would have needed a kext just to reach the installer in the first place if it was required.

High Sierra installer loads and allows me to get through to installation of files screen. Works for about 5 minutes and then either freezes or reboots with "2 minutes remaining" on the screen.

I have used RehabMan's 620 config.plist from the repo. I have done the same steps with an invalid ig-platform, and although the screen resolution is high and everything is tiny (as expected), the same freeze/reboot occurs.
 

Attachments

  • config.plist
    10.1 KB · Views: 143
  • CLOVER.zip
    4.1 MB · Views: 50
Last edited:

RehabMan

Moderator
Joined
May 3, 2012
Messages
186,689
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Dell XPS 9360
i7-8550U
QHD+ Screen
Intel 620 Graphics
16GB RAM
512GB SSD - Samsung PM961 / 68V6F
Dell bios 2.6.2

I've configured my BIOS settings as recommended, and made extra changes for DVMT as such:
CFG Lock - Disabled 0x4de - 0x00
DVMT Pre-allocation - 0x785 - 0x03 (64M. 96 and 128 were not options when I extracted my bios)
DVMT Total Gfx Memory - 0x786 - 0x03 (MAX)

I do not have any NVME kexts in place, it's not clear to me that I need any with this part #? From what I have read, I would have needed a kext just to reach the installer in the first place if it was required.

High Sierra installer loads and allows me to get through to installation of files screen. Works for about 5 minutes and then either freezes or reboots with "2 minutes remaining" on the screen.

I have used RehabMan's 620 config.plist from the repo. I have done the same steps with an invalid ig-platform, and although the screen resolution is high and everything is tiny (as expected), the same freeze/reboot occurs.

Problems:
- SATA-100-series-unsupported.kext is missing from Clover/kexts/Other
- AptioMemoryFix.efi should be used instead of OsxAptioFixDrv-64.efi+EmuVariableUefi-64.efi (and you forgot EmuVariableUefi-64.efi anyway)
- FakePCIID_Intel_HD_Graphics.kext is required, but missing from Clover/kexts/Other (might help you with booting with valid ig-platform-id)
- DVMT-prealloc 32mb patch should be removed or disabled (since you claim to have set DVMT-prealloc to 64mb).
 
Joined
Mar 22, 2011
Messages
93
Motherboard
ASUS Prime Z390-A bios 1402
CPU
8700K
Graphics
5700 XT
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. iMac
Mobile Phone
  1. Android
Problems:
- SATA-100-series-unsupported.kext is missing from Clover/kexts/Other
- AptioMemoryFix.efi should be used instead of OsxAptioFixDrv-64.efi+EmuVariableUefi-64.efi (and you forgot EmuVariableUefi-64.efi anyway)
- FakePCIID_Intel_HD_Graphics.kext is required, but missing from Clover/kexts/Other (might help you with booting with valid ig-platform-id)
- DVMT-prealloc 32mb patch should be removed or disabled (since you claim to have set DVMT-prealloc to 64mb).

Ok, done the following:
- Added the SATA-100-serires-unsupported.kext and FakePCIID_Intel_HD_Graphics.kext
- Added AptioMemoryFix.efi and removed OsxAptioFixDrv-64.efi+EmuVariableUefi-64.efi

I wasn't aware I had a DVMT-prealloc 32mb patch though, so I don't know where to remove it?

The latest installation attempt gives me the same reboot at 2mins left.
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
186,689
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
I wasn't aware I had a DVMT-prealloc 32mb patch though, so I don't know where to remove it?

Look in config.plist/KernelAndKextPatches/KextsToPatch.
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
186,689
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Thank you, still having the same reboot as a result though. Latest files attached.

Reboot might be normal. Are you sure it isn't installed?

Note: FakePCIID_Intel_HD_Graphics.kext does nothing without FakePCIID.kext. FakePCIID.kext is missing.
 
Joined
Mar 22, 2011
Messages
93
Motherboard
ASUS Prime Z390-A bios 1402
CPU
8700K
Graphics
5700 XT
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. iMac
Mobile Phone
  1. Android
Reboot might be normal. Are you sure it isn't installed?

After reboot, the hard drive does not appear on the clover screen selection list - only the USB drive (install_osx). When I boot into the USB installer again, the disk still looks empty (as in, <2gb used on disk when looking in disk utility).

I'm booting via UEFI. I've tried installing on both HFS+ and APFS file systems with the same results
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
186,689
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
After reboot, the hard drive does not appear on the clover screen selection list - only the USB drive (install_osx). When I boot into the USB installer again, the disk still looks empty (as in, only ~500mb used on disk when looking in disk utility).

I'm booting via UEFI. I've tried installing on both HFS+ and APFS file systems with the same results

You should analyze your Clover bootlog (press F2 to generate in misc/preboot.log).

Also:
From where did you download macOS?
On what hardware did you create your USB installer?
 
Joined
Mar 22, 2011
Messages
93
Motherboard
ASUS Prime Z390-A bios 1402
CPU
8700K
Graphics
5700 XT
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. iMac
Mobile Phone
  1. Android
You should analyze your Clover bootlog (press F2 to generate in misc/preboot.log).

Also:
From where did you download macOS?
On what hardware did you create your USB installer?

I'll grab the log. macOS downloaded from App Store, and I created the USB installer using the ASUS system listed under my profile picture. I created the installer using your guide (not unibeast).
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
186,689
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
I'll grab the log.

It should have been in your PR files already, but I think you missed that part of FAQ, "Problem Reporting".

Note that in certain scenarios, the installer is multiphase. First phase just copies from USB to HDD/SSD, then reboot, then you choose to boot the installer from the HDD.

You should notice the difference in the selections offered up by Clover. The misc/preboot.log should show Clover finding the copied-to-HDD/SSD installer.
 
Status
Not open for further replies.
Top