Contribute
Register

XPS 15 9560 MacOS Catalina 15.1 Full Install Guide

Joined
Jul 7, 2013
Messages
15
Motherboard
ASUS B85-PLUS
CPU
i3-4130
Graphics
GTX1050
Mac
iMac
Mobile Phone
iOS
I wonder if you guys got continuity features(sidecar, airdrop, hand off, etc.) work correctly with dw1560? My 9560 with dw1560 can only receive files via airdrop but cannot make it vice versa. Also, although iPad is detected, sidecar wirelessly is not work(timeout).
 
Joined
Jan 10, 2015
Messages
10
Motherboard
Dell XPS 15 9560
CPU
i7-7700HQ
Graphics
HD 630 / GTX 1050
Mac
MacBook Pro
Hi. Everything is working great on my XP’s 15 9560 Catalina hackintosh, except for my Dell WD19TB dock. The wired internet connection is working. However, none of the devices connected to any of the USB-3 or USB-C devices get recognized in Catalina. I tried changing to MacBookPro9,1 in the SYMBIOS as suggested by the OP, but that didn’t work AND it disabled the mouse transmitter that is plugged directly into one of the USB ports on the laptop. Any suggestions on getting the Thunderbolt 3 connections working on the dock? They all work correctly if I boot the 9560 in Windows 10 or Ubuntu 19.10.
 
Joined
Jan 10, 2015
Messages
10
Motherboard
Dell XPS 15 9560
CPU
i7-7700HQ
Graphics
HD 630 / GTX 1050
Mac
MacBook Pro
I have the same issue. Apparently, same mode works fine.
I fixed the slow behavior by starting with the original posted clover folder from the OP, reinstall it into the EFI folder of your boot drive, then update the Kexts only once using the Clover configurator.
 
Joined
Jan 3, 2020
Messages
2
Motherboard
Dell XPS 15 7590
CPU
i7-9750H
Graphics
GTX 1650
Can't make it to the installer; gets stuck on Apple logo. In verbose mode, getting this kernel panic message:

 
Joined
Jan 10, 2015
Messages
10
Motherboard
Dell XPS 15 9560
CPU
i7-7700HQ
Graphics
HD 630 / GTX 1050
Mac
MacBook Pro
Good news. The latest bios update for the xps 9560 fixes the ability of the Dell wd19tb dock to work with this Catalina hackintosh
 
Joined
Apr 20, 2014
Messages
63
Motherboard
XPS 15 9560
CPU
i5 7300HQ
Graphics
GTX 1050, Intel HD630, 1080p
Mac
MacBook Pro
Mobile Phone
iOS
Can't make it to the installer; gets stuck on Apple logo. In verbose mode, getting this kernel panic message:


Hey there, I'm sorry you're having trouble with my guide. Recently I tried to update my kexts + Clover install and my hackintosh started kernel panicking as well. After I replaced them with my previous clover backup it worked again. Can you try to install it with the kexts in my download without updating them and then try installing with Clover version 5099? See if that helps.
 
Joined
Jan 10, 2015
Messages
10
Motherboard
Dell XPS 15 9560
CPU
i7-7700HQ
Graphics
HD 630 / GTX 1050
Mac
MacBook Pro
Hey there, I'm sorry you're having trouble with my guide. Recently I tried to update my kexts + Clover install and my hackintosh started kernel panicking as well. After I replaced them with my previous clover backup it worked again. Can you try to install it with the kexts in my download without updating them and then try installing with Clover version 5099? See if that helps.
Which version of Clover is causing the problem? I'm on 5102 without issue. I see that 5103 has just been released, but I have not updated to that one yet.
 
Joined
Apr 20, 2014
Messages
63
Motherboard
XPS 15 9560
CPU
i5 7300HQ
Graphics
GTX 1050, Intel HD630, 1080p
Mac
MacBook Pro
Mobile Phone
iOS
Which version of Clover is causing the problem? I'm on 5102 without issue. I see that 5103 has just been released, but I have not updated to that one yet.
I think it was 5101 but I’m not sure. I havent had time to test new clover builds with school starting back up.
 
Joined
Dec 5, 2019
Messages
9
After pulling the trigger on the DW1560 and following this guide I have the system running 100% without issue or any 3 minute to get wifi working restriction. Sidecar doesn't work but that's alright.
 
Joined
Dec 5, 2019
Messages
9
Strange, this thread seems to be linking to the old guide which has the name updated from Mojave to Catalina?
 
Top