Contribute
Register

XFX Rx 590 not working on Mojave

Joined
May 15, 2016
Messages
3,980
Motherboard
GIGABYTE Z170M D3H
CPU
i5-6500
Graphics
RX 480
Mac
iMac
From the screenshot you provided at the start of the thread, this is not GPU related. But there has been no evidence showing any specific manufacturer of any RX series GPU not working. It has all been misconfiguration of the user. Upload your entire EFI folder and if you have used MultiBeast to install 3rd party Kext move those into the EFI/Clover/Kexts/other folder before upload.
XFX RX 590 has a custom vbios. I tested one alongside the Powercolor model. Powercolor works it logged right in but XFX was a no go. Someone flashed their Fat Boy with Sapphire Niro bios and it worked.
 
Joined
Jul 23, 2012
Messages
339
Motherboard
Asus Z390-A
CPU
i9-9900K
Graphics
UHD 630
Mac
iMac, MacBook Air, MacBook Pro, Mac mini
Mobile Phone
Android, iOS
Someone flashed their Fat Boy with Sapphire Niro bios and it worked.
Googled it and couldn't find it. could you send link by PM?
I found someone who flashed BIOS from Powercolor rx 590 and said it worked in mojave then.

What would you recommend?

BIOS _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ Core/Mem/Boost
XFX_______rx 590 8GB Fatboy__________1580 / 2000
Powercolor_rx 590 8GB Red Devil________1576 / 2000
Sapphire___rx 590 8GB Nitro+ Special____1545 / 2000
Sapphire___rx 590 8GB Nitro+ Special (2)_1560 / 2100

Is it possible to revert to the original vBIOS by flashing again? For instance if there are future driver updates supporting the XFX rx 590 in mojave coming up...

Tx,
-a-
 
Joined
May 15, 2016
Messages
3,980
Motherboard
GIGABYTE Z170M D3H
CPU
i5-6500
Graphics
RX 480
Mac
iMac
Googled it and couldn't find it. could you send link by PM?
I found someone who flashed BIOS from Powercolor rx 590 and said it worked in mojave then.

What would you recommend?

BIOS _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ Core/Mem/Boost
XFX_______rx 590 8GB Fatboy__________1580 / 2000
Powercolor_rx 590 8GB Red Devil________1576 / 2000
Sapphire___rx 590 8GB Nitro+ Special____1545 / 2000
Sapphire___rx 590 8GB Nitro+ Special (2)_1560 / 2100

Is it possible to revert to the original vBIOS by flashing again? For instance if there are future driver updates supporting the XFX rx 590 in mojave coming up...

Tx,
-a-
Yes, you could flash it back later. I posted the Powercolor bios on the RX 590 thread. Go to Techpowerup.com site for the official bios and the tools.
 
Joined
Jul 23, 2012
Messages
339
Motherboard
Asus Z390-A
CPU
i9-9900K
Graphics
UHD 630
Mac
iMac, MacBook Air, MacBook Pro, Mac mini
Mobile Phone
Android, iOS
Yes, you could flash it back later. I posted the Powercolor bios on the RX 590 thread. Go to Techpowerup.com site for the official bios and the tools.
I tried to flash the vBIOS of the XFX Fatboy with this one of Powercolor Red Devil using AtiFlash2.84 (on Win10x64 1809) but I ended up SubsystemIDs mismatch error message
It's a first for me... so I probably missed something obvious.
Any advice?
 
Joined
Jul 23, 2012
Messages
339
Motherboard
Asus Z390-A
CPU
i9-9900K
Graphics
UHD 630
Mac
iMac, MacBook Air, MacBook Pro, Mac mini
Mobile Phone
Android, iOS
Last edited:
Top