Contribute
Register

XFX 6850 Not working? Wth?

Status
Not open for further replies.
Joined
Jan 6, 2011
Messages
23
Motherboard
GA-Z97X-UD7-TH
CPU
i7 4790K
Graphics
Gigabyte GTX 970 Gaming 1
Mac
Classic Mac
Mobile Phone
Hello!

I bought today a XFX Ati Radeon 6850 tried to install Lion but it wont load.

If I boot with GE=No I get a white screen with artifacts.

If I boot with GE=Yes It will start loading..screen will flicker and the circle will continue spinning.

I have another computer with a 6870 which works perfectly. I swapped the cards and same situation, it will load, flicker, and "continue loading" meaning circle spinning.
The system is continuing loading because after a while I can see my desktop in the network (screen will be "loading").

I have tried several AtiConfig's like duckweed, 6850 and others.

Any clue? Oh, I tried DVI, HDMI and DP->VGA.

Thanks
 
Joined
Jun 7, 2011
Messages
26
Mac
Classic Mac
Mobile Phone
Joined
Jun 7, 2011
Messages
26
Mac
Classic Mac
Mobile Phone
These are all 6850 cards, supported by latest Chameleon, (ati.c source code)

619 { 0x6739,0xAA881002, CHIP_FAMILY_BARTS,"AMD Radeon HD 6850",kDuckweed},
620 { 0x6739,0x03B41043, CHIP_FAMILY_BARTS,"AMD Radeon HD 6850",kDuckweed},
621 { 0x6739,0x21F81458, CHIP_FAMILY_BARTS,"AMD Radeon HD 6850",kBulrushes},
622 { 0x6739,0x24411462, CHIP_FAMILY_BARTS,"AMD Radeon HD 6850",kDuckweed},
623 { 0x6739,0x31101682, CHIP_FAMILY_BARTS,"AMD Radeon HD 6850",kDuckweed},
624 { 0x6739,0x67391002, CHIP_FAMILY_BARTS,"AMD Radeon HD 6850",kDuckweed},
625 { 0x6739,0xE177174B, CHIP_FAMILY_BARTS,"AMD Radeon HD 6850",kDuckweed},

XFX 6850 ZNFC is inside :623 { 0x6739,0x31101682, ...}
XFX 6850 ZCFC is not, it should be something like ---
NNN { 0x6739,0x31171682, CHIP_FAMILY_BARTS,"AMD Radeon HD 6850",kDuckweed},

Hope it will be added and supported in near future.
 
Joined
Jan 6, 2011
Messages
23
Motherboard
GA-Z97X-UD7-TH
CPU
i7 4790K
Graphics
Gigabyte GTX 970 Gaming 1
Mac
Classic Mac
Mobile Phone
Its a shame, but do you really think its just a Chameleon Issue?

Have you tried using injectors?
 
Joined
Dec 18, 2011
Messages
33
Motherboard
MSI B85-G43 Gaming
CPU
i5-4690
Graphics
MSI GTX 760
Mac
  1. Mac mini
  2. Mac Pro
Mobile Phone
  1. Android
I have the same xfx card and it did not work under Lion or Snowleopard.Dont waste your time.Buy another card ..
 

SG-

Joined
Dec 26, 2010
Messages
416
Motherboard
Z68X-UD3H-B3
CPU
2500K @4.4Ghz
Graphics
Nvidia 570 GTX
Mac
Classic Mac
Mobile Phone
some cards aren't using a reference design, any idea if that XFX model is reference? it's interesting that the ID isn't in bootloader, have you thought about adding it or modifying the file and rebuilding it?
 
Joined
Jun 7, 2011
Messages
26
Mac
Classic Mac
Mobile Phone
Yes, I downloaded Chimera 1.9.1 source code, adding
SubsystemVendorID: 0x1682 SubsystemID: 0x3117 into ati.c as this line
{ 0x6739,0x31171682, CHIP_FAMILY_BARTS,"AMD Radeon HD 6850",kDuckweed},
Recompiled Chimera, make pkg , install it on my machine. still no lock.
Tried a lot of framebuffer settings, no luck.
Tried DVI-I, DVI-D, HDMI (HDMI ->DVI Adapter), both miniDisplay (Active Adapter and Passive Adapter). still no luck.

What could be wrong with XFX 5850 ZCFC?

I decode both ZNFC and ZCFC bios as following, I notice the GPUs are different
ZNFC -- BARTS PRO
ZCFC -- BARTS PROH

Could that be the only reason? ATI6000Controller.kext seems supporting all Barts family. (it mentions Barts Pro and Barts XT, not Barts ProH)

ZCFC connectors are more like 6870. it should be better.

XFX 6850 ZNFC Bios decoding information (working with Lion for both GE=No|Yes):

ATOM BIOS Rom:
SubsystemVendorID: 0x1682 SubsystemID: 0x3110
IOBaseAddress: 0x0000
Filename: 685ZNF63.SB
BIOS Bootup Message:
BARTS PRO HYNIX GDDR5 32Mx32 BIOS

PCI ID: 1002:6739
Connector at index 0
Type [@offset 44250]: DisplayPort (10)
Encoder [@offset 44254]: INTERNAL_UNIPHY2 (0x21)
i2cid [@offset 44360]: 0x90, OSX senseid: 0x1
Connector at index 1
Type [@offset 44260]: HDMI-A (11)
Encoder [@offset 44264]: INTERNAL_UNIPHY2 (0x21)
i2cid [@offset 44387]: 0x93, OSX senseid: 0x4
Connector at index 2
Type [@offset 44270]: DVI-I (2)
Encoder [@offset 44274]: INTERNAL_UNIPHY (0x1e)
i2cid [@offset 44424]: 0x94, OSX senseid: 0x5
Connector at index 3
Type [@offset 44280]: DVI-I (2)
Encoder [@offset 44284]: INTERNAL_KLDSCP_DAC1 (0x15)
i2cid [@offset 44424]: 0x94, OSX senseid: 0x5
Connector at index 4
Type [@offset 44290]: DVI-D (3)
Encoder [@offset 44294]: INTERNAL_UNIPHY1 (0x20)
i2cid [@offset 44451]: 0x95, OSX senseid: 0x6

XFX 6850 ZCFC Bios decoding information(no working at all):

ATOM BIOS Rom:
SubsystemVendorID: 0x1682 SubsystemID: 0x3117
IOBaseAddress: 0x0000
Filename: 685XZCF4
BIOS Bootup Message:
BARTS PROH ELIPDA GDDR5 32Mx32 BIOS

PCI ID: 1002:6739
Connector at index 0
Type [@offset 44350]: DisplayPort (10)
Encoder [@offset 44354]: INTERNAL_UNIPHY2 (0x21)
i2cid [@offset 44478]: 0x90, OSX senseid: 0x1
Connector at index 1
Type [@offset 44360]: DisplayPort (10)
Encoder [@offset 44364]: INTERNAL_UNIPHY2 (0x21)
i2cid [@offset 44505]: 0x91, OSX senseid: 0x2
Connector at index 2
Type [@offset 44370]: HDMI-A (11)
Encoder [@offset 44374]: INTERNAL_UNIPHY1 (0x20)
i2cid [@offset 44532]: 0x93, OSX senseid: 0x4
Connector at index 3
Type [@offset 44380]: DVI-D (3)
Encoder [@offset 44384]: INTERNAL_UNIPHY1 (0x20)
i2cid [@offset 44559]: 0x95, OSX senseid: 0x6
Connector at index 4
Type [@offset 44390]: DVI-I (2)
Encoder [@offset 44394]: INTERNAL_UNIPHY (0x1e)
i2cid [@offset 44596]: 0x94, OSX senseid: 0x5
Connector at index 5
Type [@offset 44400]: DVI-I (2)
Encoder [@offset 44404]: INTERNAL_KLDSCP_DAC1 (0x15)
i2cid [@offset 44596]: 0x94, OSX senseid: 0x5
 
Joined
Jan 6, 2011
Messages
23
Motherboard
GA-Z97X-UD7-TH
CPU
i7 4790K
Graphics
Gigabyte GTX 970 Gaming 1
Mac
Classic Mac
Mobile Phone
We could try with mountain lion kexts?...Its a shame lol

edit:

Sorry to ask, because I hadnt research it, does our 6850 and the 6870 are practically the same hardware? We could flash 6870 bios.
 
Joined
Dec 10, 2011
Messages
5
Motherboard
Gigabyte GA-Z68MA-D2H
CPU
i5-2500K
Graphics
GTX 550 Ti
Mac
  1. MacBook
Mobile Phone
  1. iOS
Flashing the bios seems to be the only solution.
I' m just about to give it a shot.
 
Status
Not open for further replies.
Top