Contribute
Register

X58 can't shut down

Joined
Sep 29, 2015
Messages
78
Motherboard
GA EX58-UD5
CPU
i7 930
Graphics
GTX 670
Mac
Classic Mac
Mobile Phone
edit: fixed for me (well, almost, Clover or El Cap definitely have some bugs for this old mobo)
see Post #73
http://www.tonymacx86.com/el-capitan-desktop-support/174222-x58-cant-shut-down-8.html#post1117108


I love Clover and i love El Capitan, but worst upgrade so far...

There seem to be some intermittent problems which i can't figure out what causes them, but i think they could be related to USB.

Board: EX58 UD5

What my main problem is, shutdown only works once out of 10 tries, with 3 times it is doing a reboot, and 6 times it just shutting down the signal to the monitors and the PC just stays on indefinitely.

I tried just about every combination of the 4 or 5 shutdown fixes that Clover has, nothing works.


When i said it could be related to USB is that once out of every 10 boots my original USB keyboard works at the clover boot loader, when it usually does not. I think the time when the USB keyboard works at startup the shutdown command works as well.
 
Joined
Aug 21, 2014
Messages
97
Motherboard
DFI X58-T3eH8
CPU
i7 920 @ 4ghz
Graphics
ASUS 760 GTX
Mac
Classic Mac
Mobile Phone
Hello, i am on a DFI x58 and i have the same exact issue

I found out that booting with the flag cpus=1 fixes it, but it decreased the performance dramatically
 
Joined
Sep 29, 2015
Messages
78
Motherboard
GA EX58-UD5
CPU
i7 930
Graphics
GTX 670
Mac
Classic Mac
Mobile Phone
I've tried to fix this problem for 2 days now, and got nothing.

An hour ago, i've copied over the EFI folder from the USB stick to the EFI partition on the HDD, and it worked for about 5 tries. Made me think that there was a setting in my Clover setup that borked everything. Then it stopped working. argh.

Previously, on the EvOreboot.kext could shut things down properly for me, now it's incompatible with El Cap and causes kernel panics.
 
Joined
Aug 21, 2014
Messages
97
Motherboard
DFI X58-T3eH8
CPU
i7 920 @ 4ghz
Graphics
ASUS 760 GTX
Mac
Classic Mac
Mobile Phone
I've sent a ticket to the Clover team

Hopefully that'll work
 
Joined
Sep 29, 2015
Messages
78
Motherboard
GA EX58-UD5
CPU
i7 930
Graphics
GTX 670
Mac
Classic Mac
Mobile Phone
I'll try these

You in the meantime try FixShutdown + dark mode 0 8 or 10

I've tried them just now, FixShutdown + darkwake 0, 8, 10

and any combination earlier today of the first screen of the Clover cons app, on the ACPI page, and the fix ownership settings on the later pages.

same effect, sporadic shutdowns, PC mostly stays on.

what i find interesting is that the random shutdowns behave differently, sometimes the monitors shut off and the pc shuts off after 1 minute, sometimes the pc shuts off instantly the moment the GUI goes away, sometimes the PC shuts down after 5 minutes after the monitor went off, sometimes the PC shuts down and immediately boots again (not a reboot, the lights were out for a second)
but 90% of the time only the monitor goes off and the PC stays on.
 
Joined
Aug 21, 2014
Messages
97
Motherboard
DFI X58-T3eH8
CPU
i7 920 @ 4ghz
Graphics
ASUS 760 GTX
Mac
Classic Mac
Mobile Phone
I've tried them just now, FixShutdown + darkwake 0, 8, 10

and any combination earlier today of the first screen of the Clover cons app, on the ACPI page, and the fix ownership settings on the later pages.

same effect, sporadic shutdowns, PC mostly stays on.

what i find interesting is that the random shutdowns behave differently, sometimes the monitors shut off and the pc shuts off after 1 minute, sometimes the pc shuts off instantly the moment the GUI goes away, sometimes the PC shuts down after 5 minutes after the monitor went off, sometimes the PC shuts down and immediately boots again (not a reboot, the lights were out for a second)
but 90% of the time only the monitor goes off and the PC stays on.

Same here

Tried the other settings too but no luck.

Are you familiar with DSDT patching? wasn't able to try this

https://github.com/R...m_Shutdown2.txt
 
Joined
Sep 29, 2015
Messages
78
Motherboard
GA EX58-UD5
CPU
i7 930
Graphics
GTX 670
Mac
Classic Mac
Mobile Phone
I've never used a DSDT or SSDT until now, and i have no idea how to use them, even though i've read through dozens of 'tutorials' on them on insanelymac. This stuff's too high for me, i don't get it.
I could get my own DSDT from clover yesterday while pressing F4, but that's about it.

I've used 10.5.x up to 10.10.5 without a DSDT on this mac, everything worked except the speedstep was always at max and the PC used about 40 Watt more than in windows while idle, which didn't matter since it's a power hog anyway.
 
Joined
Aug 21, 2014
Messages
97
Motherboard
DFI X58-T3eH8
CPU
i7 920 @ 4ghz
Graphics
ASUS 760 GTX
Mac
Classic Mac
Mobile Phone
Can you confirm cpus=1 makes shutdown working for you too?
 
Top