Contribute
Register

X58 and OS X El Capitan? (X58A-UD3r)

Status
Not open for further replies.
Joined
Jan 25, 2011
Messages
727
Motherboard
GA-X58A-UD3R
CPU
X5650
Graphics
R9 290
Mac
  1. MacBook
Mobile Phone
  1. Android
  2. iOS
Someone who has the fully working system should really post a step-by-step guide if they have a chance. Appreciation would be immense.

As it is now, it seems a few folks have used a few different methods, drawing on piecemeal information from here and there (and some using methods we can't discuss here I believe), but we don't have all the information in a single, easy to follow place.
 
Joined
Aug 21, 2014
Messages
93
Motherboard
DFI X58-T3eH8
CPU
i7 920 @ 4ghz
Graphics
ASUS 760 GTX
Mac
Classic Mac
Mobile Phone
Still not able to get the shutdown to work here, it works 1 time out of 5
 
Joined
Sep 18, 2012
Messages
24
Motherboard
Gigabyte EX58-Extreme
CPU
Intel Xeon X5660 @4.2GHz (6-core)
Graphics
NVIDIA GTX 970
Mac
Classic Mac
Mobile Phone
  1. iOS
I have the EX58-Extreme and it's working perfectly, except for the sound, which I can't install because of this error.

AgreementThe audio_cloverALC-110 script is for personal use only. Do not distribute
the patch, any or all of the files or the resulting patched AppleHDA.kext
for any reason without permission. The audio_cloverALC-110 script is
provided as is and without any kind of warranty.

File: audio_cloverALC-110.command_v1.0g
Password:
EFI partition is not mounted
Confirm Clover Legacy Install (y/n): y
El Capitan/EFI folder found
System Integrity Protection status: enabled (Custom Configuration).


Configuration:
Apple Internal: disabled
Kext Signing: disabled
Filesystem Protections: disabled
Debugging Restrictions: disabled
DTrace Restrictions: disabled
NVRAM Protections: disabled


This is an unsupported configuration, likely to break in the future and leave your machine in an unknown state.
OK to patch
cp: /Volumes/El Capitan/EFI/CLOVER//config-backup.plist: Permission denied
Error: no IOReg/HDEF; BIOS/audio/disabled or ACPI problem
No system files were changed
To save a Copy of this Terminal session: Terminal/Shell/Export Text As ...
logout
Saving session...
...copying shared history...
...saving history...truncating history files...
...completed.


[Process completed]

Shutdown, reboot are all working fine.
 
Joined
Apr 12, 2010
Messages
43
Motherboard
Gigabyte GA-X58A-OC
CPU
i7-950
Graphics
RX 580
Mac
  1. iMac
Mobile Phone
  1. iOS
Update I upgraded my cloned drive to El Cap, and had a little trouble booting it. Clover hadn't installed correctly (or maybe i didn't install it correctly :)) So I mounted the EFI on my El Cap drive and placed a copy of Unibeasts USB EFI folder on it. It then booted.

I've now got a couple of issues
1) USB not always working for keyboard/mouse etc(Power Issue?) cause unplugging my mouse from the mac keyboard and trying the same usb slot, it works for the mouse.
2) CPU not showing the correct Bus Freq (cosmetic I think)
3) GPU reporting the wrong slot (Cosmetic, but my dsdt is saying Slot-1 and System Overview is saying slot-0)
4) Memory slots showing as Dimm1 to Dimm6. Yosemite shows these as Banks0/1/A0 to Banks10/11/A5 (Don't know which is correct but they work so Cosmetic again) I used Clover Configurator and selected XMPDetection=Yes this now shows the correct memory Freq/DDR3 etc.
5) Restart hangs sometimes, possibly the same for shutdown.

As long as my external harddrives are plugged in before boot, then they work. I use a USB3 card which shows as USB 3.0 SuperSpeed Bus in Yosemite but under EL Cap its just USB3 it doesn't run at USB 3 speeds either. The drivers used are different.
ElCap uses Host Controller Driver: AppleUSBXHCIFL1100 and Yosemite uses Host Controller Driver: AppleUSBXHCI.

My dsdt only contains two extra settings 1) The GPU has been added 2) The Processor has also been added. Otherwise its the standard ga-x58a-oc from this site.

What has surprised me is that my Geekbench score has went up 400 points under El Cap to 10646. Yosemite was around 10200.

If I can get usb working correctly then I will upgrade my Yosemite drive but for now this was just a test to see how far I'm off from having a fully working system.
 
Joined
Sep 18, 2012
Messages
24
Motherboard
Gigabyte EX58-Extreme
CPU
Intel Xeon X5660 @4.2GHz (6-core)
Graphics
NVIDIA GTX 970
Mac
Classic Mac
Mobile Phone
  1. iOS

UA3

Joined
May 22, 2013
Messages
13
Motherboard
Asus z97 Deluxe
CPU
i7 4790K
Graphics
GTX 780
Mac
  1. MacBook
  2. MacBook Pro
  3. Mac mini
Mobile Phone
  1. Android
  2. iOS
I got it:

Download Clover Configurator on yosemite, then select the USB -> EFI -> CLOVER -> config.plist file
under ACPI, select these settings.

Running El Cap now almost perfectly with these settings.
I'm pretty new with Clover, so no doubt i'll have to reinstall it a couple of times more after i'm done playing around with some kexts and settings.


Board: EX58-UD5
CPU: i7 930
GPU: GTX670

thanks to audioguyjosh for the original settings

View attachment 153414
Thanks man, worked like magic with my P45-UD3R !!
 
Joined
Sep 18, 2012
Messages
24
Motherboard
Gigabyte EX58-Extreme
CPU
Intel Xeon X5660 @4.2GHz (6-core)
Graphics
NVIDIA GTX 970
Mac
Classic Mac
Mobile Phone
  1. iOS
How did you get the audio working?
 
Joined
Feb 17, 2014
Messages
38
Motherboard
GA-H170-Gaming 3
CPU
i7 7700K
Graphics
GTX 780
Mac
  1. iMac
Mobile Phone
  1. iOS
No. All my ports are functioning as USB 2.0. I'm okay with that. As long as the system is up and running, I don't mind. I did order the USB 3.0 card so will test it out once it arrives.

Hi CyCloBoT. what was the card that you ordered? I have a 4 port USB 3.0 PCI Express VIA VL805. but it just works with Yosemite.


Sorry i read the answer "Inatek KT4006 (FL1100)" Thanks anyway :) Where do you bought it?

Thanks in Advance!
 
Status
Not open for further replies.
Top