Contribute
Register

X299 - Open Core support

Joined
Apr 18, 2011
Messages
1,329
Motherboard
ASUS ROG Z690 Extreme
CPU
Intel i9-12900k
Graphics
Radeon Pro W5500
Mac
  1. MacBook Air
  2. Mac Pro
Mobile Phone
  1. iOS
I've updated post 1 with important sections of my github so hopefully it's clearer on where to start with OpenCore or fix issues with booting on newer boards/BIOS. Also has suggestions on connecting internal usb devices when none are available.
 
Joined
Dec 28, 2011
Messages
87
Motherboard
Asus WS X299 SAGE / Asus P9X79 WS / HP Probook
CPU
i9 7900x oc 4mhz / i7 4930k oc 4.25mhz
Graphics
Radeon RX580 / GTX 970
Mac
  1. iMac
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Classic
Mobile Phone
  1. Android
  2. iOS
It just reboot after the first 2 paragraphs in verbose. Yes i had the SSDT-AWAC.aml in my acpi folder and enabled in config.plist.

I fixed my other issues with pcie cards by dumping windows to another computer. I tried every combination of slots/cards and nothing worked, I had too many issue when having both system in the same machine which is a pity, everything was just fine on my p9x79 but now i can’t even connect my VR headset in windows with a loosy 3m DP cable, it works only ones when i reflash the bios but as soon as i boot on macos, it breaks something in windows. Also the performance in games are terrible, seems like the board handles very poorly the RX580 in windows with the bios settings for macos. Even with different bios profiles for each OS, its bad. I wasted a week on this, i decided that it was easier to setup my old system for windows only.


Does it hang or just reboot? Do you have SSDT-AWAC.aml copied to your EFI folder and enabled in your config.plist?

As for your other issue how are your slots populated. I've noticed that the Sage is a little picky with how the slots are populated. I'm not sure if this is a macOS issue or not since the computer boots fine. It's just when it loads macOS it reboots instantly. I haven't looked at the kp logs but just moved my cards to different slots.
 
Joined
Apr 18, 2011
Messages
1,329
Motherboard
ASUS ROG Z690 Extreme
CPU
Intel i9-12900k
Graphics
Radeon Pro W5500
Mac
  1. MacBook Air
  2. Mac Pro
Mobile Phone
  1. iOS
It just reboot after the first 2 paragraphs in verbose. Yes i had the SSDT-AWAC.aml in my acpi folder and enabled in config.plist.

I fixed my other issues with pcie cards by dumping windows to another computer. I tried every combination of slots/cards and nothing worked, I had too many issue when having both system in the same machine which is a pity, everything was just fine on my p9x79 but now i can’t even connect my VR headset in windows with a loosy 3m DP cable, it works only ones when i reflash the bios but as soon as i boot on macos, it breaks something in windows. Also the performance in games are terrible, seems like the board handles very poorly the RX580 in windows with the bios settings for macos. Even with different bios profiles for each OS, its bad. I wasted a week on this, i decided that it was easier to setup my old system for windows only.

Sorry it didn’t work out for you. You can also try the ndk fork of OpenCore as it seems to work better with dual boot systems.
 
Joined
Jan 29, 2020
Messages
64
Motherboard
WS X299 Sage/10G -3001 - OpenCore
CPU
i9-7980XE
Graphics
Pro WX 8200
Mac
  1. iMac
  2. MacBook Pro
  3. Mac Pro
Mobile Phone
  1. iOS
I've updated post 1 with important sections of my github so hopefully it's clearer on where to start with OpenCore or fix issues with booting on newer boards/BIOS. Also has suggestions on connecting internal usb devices when none are available.
The 3101 BIOS in your Github is already patched, correct? So should just need to add SSDT-AWAC to ACPI folder and config.plist? It's panicking on me.
Also should MSR Lock be still disabled in 3101? The Github is looking good!
 
Joined
Apr 18, 2011
Messages
1,329
Motherboard
ASUS ROG Z690 Extreme
CPU
Intel i9-12900k
Graphics
Radeon Pro W5500
Mac
  1. MacBook Air
  2. Mac Pro
Mobile Phone
  1. iOS
The 3101 BIOS in your Github is already patched, correct? So should just need to add SSDT-AWAC to ACPI folder and config.plist? It's panicking on me.
Also should MSR Lock be still disabled in 3101? The Github is looking good!

Yes, the one in the custom BIOS collection. Note that it replaces the Asus logo with the apple logo on the splash screen. I need to add a picture of it on github. Yes without AWAC it will not boot. The MSR lock toggle doesn't work in 3101 so if you run a patched BIOS you don't have to worry about the toggle.
Thanks! any suggestions are welcome. :)
 
Joined
Mar 6, 2013
Messages
30
Motherboard
Gigabyte GA-Z170MX
CPU
i5-6600K
Graphics
HD 530
Mac
  1. iMac
  2. MacBook
  3. MacBook Pro
  4. Mac mini
  5. Mac Pro
Classic Mac
  1. eMac
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. Android
Hi friends there! Hope you all are fine and healthy!

Is anyone of you tried to install old MacOS like Sierra, ElCapitan or Yosemite with OpenCore?
The reason I started this topic is because I have a lot of projects in Final Cut Pro 7 that I would like to open it.
At the moment I have my Hack running Catalina fine and stable with OpenCore 0.5.8.

Thanks in advance!
Hey friend can you upload your open core efi! I have the same config and havent been able to make it work, thanks!
 
Joined
Dec 28, 2011
Messages
87
Motherboard
Asus WS X299 SAGE / Asus P9X79 WS / HP Probook
CPU
i9 7900x oc 4mhz / i7 4930k oc 4.25mhz
Graphics
Radeon RX580 / GTX 970
Mac
  1. iMac
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Classic
Mobile Phone
  1. Android
  2. iOS
Hello, I'm still having some difficulties with USB, mostly my usb 3 sata dock keeps disconnecting, i tried to follow the instructions from the usb map guide at Dortania but it doesn't seem to work for me, after rebooting i still have all the USB ports listed by the tool and the same disconnection on my dock. Is this post using hackintools still relevant with opencore ?
 
Joined
Jul 14, 2019
Messages
103
Motherboard
ASUS WS SAGE/10G
CPU
i9-10940X
Graphics
Radeon VII
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Hi
I finally received all the material to make my build.

a. Motherboard: ASUS WS SAGE / 10G
b. Processor: INTEL i9-10940X
c. Cooling: AIO CORSAIR H150i PRO RGB
d. RAM: CORSAIR VENGEANCE LPX 3200 C16 4X32GB
d. MacOS SSD: Sabrent Rocket 1TB NVMe
f. Windows 10 SSD: Sabrent Rocket 1TB NVMe
g. Graphics card: SAPPHIRE RADEON VII
h. WiFi / BT card: MQUPIN FENVI T919 BCM94360CD
h. TB3 Sheet: GIGABYTE TITAN RIDGE
i. NVMe to PCIe SSD Adapter Card: 2 x EZDIY-FAB PCI Express M.2 SSD NGFF PCIe Card to PCIe 3.0 x4 Adapter (storage solution with 2 x Sabrent Rocket Q 4TB SSD to put in RAID 0 configuration)
l. Power supply: LEADEX II 80 Plus Gold 1200 W
m. case: COOLER MASTER c700p

In the last few weeks I have done a full immersion in OpenCore but before that I have to concentrate on the correct assembly of all the hardware.
If you agree and you will have a little patience with me, I will try to proceed as autonomously as possible, highlighting here all the steps and from time to time my doubts.
The first doubt concerns the order of the cards in the PCIe slots. TB3 mandatory in the 2nd but I'm not sure about the others ...

P.S. Preventive advice will be greatly appreciated:):):)
 
Joined
Dec 28, 2011
Messages
87
Motherboard
Asus WS X299 SAGE / Asus P9X79 WS / HP Probook
CPU
i9 7900x oc 4mhz / i7 4930k oc 4.25mhz
Graphics
Radeon RX580 / GTX 970
Mac
  1. iMac
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Classic
Mobile Phone
  1. Android
  2. iOS
can't wait to see if the ram works with you. good luck with the assembly. It shouldn't tale too long.

Hi
I finally received all the material to make my build.

a. Motherboard: ASUS WS SAGE / 10G
b. Processor: INTEL i9-10940X
c. Cooling: AIO CORSAIR H150i PRO RGB
d. RAM: CORSAIR VENGEANCE LPX 3200 C16 4X32GB
d. MacOS SSD: Sabrent Rocket 1TB NVMe
f. Windows 10 SSD: Sabrent Rocket 1TB NVMe
g. Graphics card: SAPPHIRE RADEON VII
h. WiFi / BT card: MQUPIN FENVI T919 BCM94360CD
h. TB3 Sheet: GIGABYTE TITAN RIDGE
i. NVMe to PCIe SSD Adapter Card: 2 x EZDIY-FAB PCI Express M.2 SSD NGFF PCIe Card to PCIe 3.0 x4 Adapter (storage solution with 2 x Sabrent Rocket Q 4TB SSD to put in RAID 0 configuration)
l. Power supply: LEADEX II 80 Plus Gold 1200 W
m. case: COOLER MASTER c700p

In the last few weeks I have done a full immersion in OpenCore but before that I have to concentrate on the correct assembly of all the hardware.
If you agree and you will have a little patience with me, I will try to proceed as autonomously as possible, highlighting here all the steps and from time to time my doubts.
The first doubt concerns the order of the cards in the PCIe slots. TB3 mandatory in the 2nd but I'm not sure about the others ...

P.S. Preventive advice will be greatly appreciated:):):)
 
Top