Contribute
Register

X299 Big Sur Support

Joined
Apr 17, 2012
Messages
207
Motherboard
Asus X299 Prime Deluxe
CPU
i9-7960x
Graphics
Vega 56
Hi - I'm in the process of converting my 7900x/X299 PrimeDeluxe to OC. I've lost TB3 hot plug even though I have an ssdt for it. I built my OC from scratch as I wanted to learn it properly.

I have a system up and running but hoping to take a peek at the X299 Deluxe OC 0.6.0 EFI to see if I'm missing something that is messing with my TB3 hot plug. Let me know how I might be able to find this as the git is now empty.

Thank you!
@ycbr would you mind posting your EFI so I can take a look? I have the same platform but can't boot from OC
 
Joined
Apr 18, 2011
Messages
1,329
Motherboard
ASUS ROG Z690 Extreme
CPU
Intel i9-12900k
Graphics
Radeon Pro W5500
Mac
  1. MacBook Air
  2. Mac Pro
Mobile Phone
  1. iOS
Hi - I'm in the process of converting my 7900x/X299 PrimeDeluxe to OC. I've lost TB3 hot plug even though I have an ssdt for it. I built my OC from scratch as I wanted to learn it properly.

I have a system up and running but hoping to take a peek at the X299 Deluxe OC 0.6.0 EFI to see if I'm missing something that is messing with my TB3 hot plug. Let me know how I might be able to find this as the git is now empty.

Thank you!

You most likely have to change from PCI0 to PC00 in your SSDT file. We removed the ACPI rename patches from kgp's Clover EFIs since they are mostly cosmetic to match more like an iMacPro.
 
Joined
Apr 18, 2011
Messages
1,329
Motherboard
ASUS ROG Z690 Extreme
CPU
Intel i9-12900k
Graphics
Radeon Pro W5500
Mac
  1. MacBook Air
  2. Mac Pro
Mobile Phone
  1. iOS
A stupid question probably. Is it currently possible update to big sur from catalina?

Yes, you'll need SSDT-RTC0.aml instead of SSDT-AWAC and OpenCore 0.6.0. Make sure to create a backup of Catalina and your EFI in case something happens.
 
Joined
Apr 17, 2012
Messages
207
Motherboard
Asus X299 Prime Deluxe
CPU
i9-7960x
Graphics
Vega 56
You most likely have to change from PCI0 to PC00 in your SSDT file. We removed the ACPI rename patches from kgp's Clover EFIs since they are mostly cosmetic to match more like an iMacPro.
That's great to know! Any other tips on porting a working Clover (KGP based, but updated) to OC? I am still unable to boot.

I am also noticing the USB kext I made with the KGP guide doesn't have a 'Contents' folder which doesn't register in OC Config. Do you know if it's safe to just Show Package Content and add the folder and mode the .plist?
 
Joined
Apr 18, 2011
Messages
1,329
Motherboard
ASUS ROG Z690 Extreme
CPU
Intel i9-12900k
Graphics
Radeon Pro W5500
Mac
  1. MacBook Air
  2. Mac Pro
Mobile Phone
  1. iOS
That's great to know! Any other tips on porting a working Clover (KGP based, but updated) to OC? I am still unable to boot.

I am also noticing the USB kext I made with the KGP guide doesn't have a 'Contents' folder which doesn't register in OC Config. Do you know if it's safe to just Show Package Content and add the folder and mode the .plist?

It's recommended to start from here: https://www.tonymacx86.com/threads/x299-support.302143/post-2161002
I'm retired and no longer have my hack or github repo so can't help as much as I used to but that Base EFI should get you booting if you follow the Configuration instructions.

Looks like BIOS 3105/3203 (WS boards) is out to fix the MSR lock functionality so we should no longer have to use UEFITool. I'm not sure if the rtc regions are fixed tho.

Yeah you can have just the plist file in the config file for the usb kext. Make sure you use a plist editor and not OpenCore Configurator. Idk if it's improved lately but in the past it's caused issues with messing with the config.plist file. IMO a plist editor is easier anyway :lol:
 
Joined
Apr 17, 2012
Messages
207
Motherboard
Asus X299 Prime Deluxe
CPU
i9-7960x
Graphics
Vega 56
It's recommended to start from here: https://www.tonymacx86.com/threads/x299-support.302143/post-2161002
I'm retired and no longer have my hack or github repo so can't help as much as I used to but that Base EFI should get you booting if you follow the Configuration instructions.

Looks like BIOS 3105/3203 (WS boards) is out to fix the MSR lock functionality so we should no longer have to use UEFITool. I'm not sure if the rtc regions are fixed tho.

Yeah you can have just the plist file in the config file for the usb kext. Make sure you use a plist editor and not OpenCore Configurator. Idk if it's improved lately but in the past it's caused issues with messing with the config.plist file. IMO a plist editor is easier anyway :lol:
Thank you and I very much appreciate you coming out of retirement to answer some questions. I did start with that Base EFI that's why I am a bit at a loss with OC. I'll keep trucking along but if anyone has a working Prime Deluxe EFI, I would love to take a peek!

Thank you!
 
Joined
Mar 18, 2017
Messages
1,034
Motherboard
ASUS ROG Rampage VI Extreme
CPU
i9-7940X
Graphics
2 X VEGA 56
Mac
  1. iMac
  2. Mac mini
Mobile Phone
  1. iOS
@egroys and X299 Prime Deluxe owners :

Here I share my EFI OC 6.0.1 X299 Prime Deluxe : I am still with the old BIOS.

So see post #3 for new BIOS

SSDTs / ACPI :
- must be adapted according to your system
Removed :
- MLB, Rom, Serial and SMUUID : you must GenSMBIOS and edit the config.plist

Capture d’écran 2020-08-19 à 19.56.42.png
 

Attachments

  • EFI OC 0.6.1 X299 Prime Deluxe .zip
    58 MB · Views: 255
Joined
Jul 15, 2012
Messages
77
Motherboard
Asus WS X299 SAGE/10G
CPU
i9-7980XE
Graphics
AMD Radeon™ RX 6900 XT
Mac
  1. iMac
Mobile Phone
  1. iOS
Yes, you'll need SSDT-RTC0.aml instead of SSDT-AWAC and OpenCore 0.6.0. Make sure to create a backup of Catalina and your EFI in case something happens.

Thank you, always great support.
I am currently using OC 0.6.0 and your base EFI. But i am with the 2002 bios version because i tested the new Asus bios 3203 and i have a problem: my ram, both with and without XMP, are unstable: at the moment i was unable to configure them at 3200 MHz and therefore i went back to bios 2002. With this bios i replace SSDT-RTC0.aml with SSDT-RTC0-NOAWAC.aml and rename to SSDT-RTC0.aml. Possible to update to Big Sur with these settings?
 
Last edited:
Joined
Dec 7, 2013
Messages
40
Motherboard
ASUS x299 Prime Deluxe
CPU
i9-7900x
Graphics
GIGABYTE RX 580 8GB
Mac
  1. iMac
@ycbr would you mind posting your EFI so I can take a look? I have the same platform but can't boot from OC

Don't know if this will help you much, but it gets me to install. It's pretty bare as I built this off Dortania Guide. There's a share below that I'm looking at now, and is much more sophisticated
 

Attachments

  • oc060_x299deluxe.zip
    2.2 MB · Views: 60
Joined
Dec 7, 2013
Messages
40
Motherboard
ASUS x299 Prime Deluxe
CPU
i9-7900x
Graphics
GIGABYTE RX 580 8GB
Mac
  1. iMac
Yes, you'll need SSDT-RTC0.aml instead of SSDT-AWAC and OpenCore 0.6.0. Make sure to create a backup of Catalina and your EFI in case something happens.

Thanks for the heads up! Used to be more active here working out kinks with x299 in early-KGP days. I say that because 1. understand burnout, 2. really appreciate you coming out for it for a moment to help!
 
Top