Contribute
Register

X299 Big Sur Support

Joined
Feb 26, 2011
Messages
127
Motherboard
ASUS PRIME X299-A II
CPU
i9 10940X
Graphics
AMD Radeon RX 6800 XT
Mac
  1. MacBook
  2. MacBook Pro
Mobile Phone
  1. iOS
Do you see any MSR settings in your bios? On my MSI X299 Carbon I have to disable MSR lock, but seems to work after that. If you have something like that, maybe disable, then change your config list to set AppleXcpmCfgLock to False? if you don't have that, then also set AppleCpuPmCfgLock to True as well? Might affect the NVRAM questions one way or the other.

Thanks - I've double checked those and I definitely have CFG lock disabled in bios, AppleXcpmCFGLock set to False - I tried the AppleCpuCfgLock both ways but its still the same every time.

Im going to upgrade to Opencore 0.6.4 latest on a separate USB and see how that fairs...

(actually I tried that already but just get "OCB Image failed to load!" so I don't think it set up properly, I'll rebuild a new clean EFI based on OC 0.6.4 and make sure it works fine with Catalina before trying it on the Big Sur installer)

Still suspecting no NVRAM is messing with secure boot or something, so may need to revisit that.
 
Joined
Sep 30, 2020
Messages
186
Motherboard
Asus Prime X299-DELUXE
CPU
i9-7980XE
Graphics
RX 6900XT
My build seems to be up and working pretty well.

Build Specifications:
  • ASUS Rampage VI Extreme Encore (BIOS 0702)
  • Intel i9-10980XE
  • 2x16 Corsair Dominator Platinum RGB (3200) (Will upgrade to 4x16)
  • AMD Sapphire Pulse RX 580
  • Nvidia Geforce RTX 3090 Strix OC
  • Samsung 970 EVO 1 TB (macOS)
  • Samsung 970 EVO Plus 2 TB (Windows 10)
  • BCM94360NG Wifi/BT (Replaced on board since intel drivers are still in beta)
  • Corsair HX1000i
  • Lian Li PC011 Dynamic XL
PCIe Layout
  • x16 - RTX 3090
  • x4 - N/A (Disabled since M.2 is in higher slot)
  • x16 - N/A
  • x4 - RX 580 (Running at x4 since M.2 is in right slot on DIMM.2)
Issues:
  • Sleep causes instant wake (assume due to RTX 3090)
  • SideCar does not work (since no T2 chip using Duet Display instead)
OpenCore Specifics:
  • Version 0.6.3
  • MacPro7,1 SMBIOS
    • ACPI​
    • SSDT-SBUS-MCHC.aml​
    • SSDT-PLUG.aml​
    • SSDT-EC-USBX.aml​
    • SSDT-RTC0.aml​
    • SSDT-GPU-DISABLE.aml (Disables RTX 3090 in macOS)​
    • Kernel Kexts​
    • Lilu.kext​
    • VirtualSMC.kext​
    • SMCProcessor.kext​
    • SMCSuperIO.kext​
    • AppleALC.kext​
    • WhateverGreen.kext (Seems to hep when running dual GPUs)​
    • IntelMausi.kext​
    • TSCAdjustReset.kext​
    • USBMap.kext (think mapped everything except internal USB 2.0 header)​
    • Kernel Patch​
    • ACQ107 10G patch for macOS Big Sur​
    • Kernel Quirks​
    • CustomSBIOSGuid - YES (Enabled since setting to 'No' seems to mess with ASUS Aura in Windows)​
    • PlatformInfo​
    • UpdateSMBIOSMode - Custom (Enabled since seems to mess with ASUS Aura in Windows)​
Yes I still have plastic on side panels :lol:
View attachment 497199
It's too bad that you can't use that amazing nVidia GPU, but at least you can use the AMD one with macOS X. Nice system!
 
Last edited:
Joined
Jul 20, 2014
Messages
960
Motherboard
AsRock X299 Creator-1.50
CPU
i9-10900X
Graphics
RX 6800 XT
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Thanks - I've double checked those and I definitely have CFG lock disabled in bios, AppleXcpmCFGLock set to False - I tried the AppleCpuCfgLock both ways but its still the same every time.

Im going to upgrade to Opencore 0.6.4 latest on a separate USB and see how that fairs...

(actually I tried that already but just get "OCB Image failed to load!" so I don't think it set up properly, I'll rebuild a new clean EFI based on OC 0.6.4 and make sure it works fine with Catalina before trying it on the Big Sur installer)

Still suspecting no NVRAM is messing with secure boot or something, so may need to revisit that.
I think I'm having the same issue as yours ....
i did many many try .. always failed
I know that I never succeed to make the NVRAM work ....
 
Joined
Feb 24, 2013
Messages
2,659
Motherboard
N/A
CPU
N/A
Graphics
N/A
Mac
  1. MacBook Air
  2. Mac Pro
Mobile Phone
  1. iOS
After looking at some M1 benchmarks on low end Mac's, I think we are nearing the end of the line for Hackintoshes.

The 13" MacBook Pro is even beating the $4,000 MacBook Pro 16" with 8 cores in many benchmarks, including x86 JIT translated apps that are not for ARM running via Rosetta 2.

A Mx (whatever they will call it) Mac Pro or an iMac is going to kill Intel on-sight.

This is actually really embarrassing for Intel, if I were them I would just quit the industry.

I'm actually looking forward to a redesigned iMac (which most likely will look like an XDR display chassis)
 
Joined
Jun 13, 2018
Messages
736
Motherboard
Prime X299-A II
CPU
i9 9980XE
Graphics
RX 6800 XT
Mac
  1. iMac
  2. MacBook Pro
Classic Mac
  1. iMac
  2. Power Mac
Mobile Phone
  1. Android
  2. iOS
After looking at some M1 benchmarks on low end Mac's, I think we are nearing the end of the line for Hackintoshes.

The 13" MacBook Pro is even beating the $4,000 MacBook Pro 16" with 8 cores in many benchmarks, including x86 JIT translated apps that are not for ARM running via Rosetta 2.

A Mx (whatever they will call it) Mac Pro or an iMac is going to kill Intel on-sight.

This is actually really embarrassing for Intel, if I were them I would just quit the industry.

I'm actually looking forward to a redesigned iMac (which most likely will look like an XDR display chassis)
I totally agree mate, it's not just the power vs Intel's (Zen 3 are pretty good), it's tha capability at 10W TDP!! put the architecture at 50W TDP (still very low for desktops) and imagine what's possible. It's also worth considering all the harware/software optimization they can deliver (think about the Afterburner card). I'd have already switched to an M1 mac mini if it had at least 2 thunderbolt controllers on 4 port like the older, but they will introduce an M1X space gray mac mini and iMac in 2021 and that's the right time for a lot of us to dump hacks.
 
Joined
Apr 22, 2012
Messages
41
Motherboard
Asus Rog Rampage VI Extreme Omega X299
CPU
i9-10920X
Graphics
Radeon VII
I followed every single step of Dortania Guide , and repeated this several times ... however no luck. Still the installer shows progress of 15min and stuck on this for hours.
Any help would be much appreciated, please.
 

Attachments

  • config.plist
    15 KB · Views: 27
  • opencore-2020-11-19-221021.txt
    256 KB · Views: 32
Joined
Apr 1, 2011
Messages
141
Motherboard
Asus X299 Prime Deluxe
CPU
i9-7980XE
Graphics
Radeon VII
Mac
  1. Mac Pro
Mobile Phone
  1. iOS
I'm getting this panic on and off.... some time it boot ok, but some time have to reboot or clear the Nvram to boot..... can any one help?
 

Attachments

  • Screenshot 2020-11-20 at 9.21.55 AM.jpg
    Screenshot 2020-11-20 at 9.21.55 AM.jpg
    2 MB · Views: 40
Joined
May 26, 2013
Messages
168
Motherboard
GA-Z390 AORUS PRO WIFI
CPU
i9-9900K
Graphics
RX 5700 XT
Mac
  1. MacBook
  2. MacBook Pro
Mobile Phone
  1. iOS
I'm getting this panic on and off.... some time it boot ok, but some time have to reboot or clear the Nvram to boot..... can any one help?
Hi! As per the logs seems that macos is having issues to mount a ntfs partition/disk. Try to boot in Windows and do a disk scan/chkdsk on it.

Cheers.
 
Joined
Apr 1, 2011
Messages
141
Motherboard
Asus X299 Prime Deluxe
CPU
i9-7980XE
Graphics
Radeon VII
Mac
  1. Mac Pro
Mobile Phone
  1. iOS
Hi! As per the logs seems that macos is having issues to mount a ntfs partition/disk. Try to boot in Windows and do a disk scan/chkdsk on it.

Cheers.
Thanks, will do it!
 
Joined
Nov 13, 2020
Messages
34
Motherboard
Asrock X299 Creator
CPU
10980XE
Graphics
5700XT
I finally got around to try another Big Sur install onto a newly formatted APFS nvme drive... but I am still stuck at the endless rebooting with this error message: "device is write lock":( Other people have commented that "stuck" after this message is normal, but I am not stuck but kept rebooting without making any progress on the status bar -- don't think I truly finish the second reboot... Anyone else experiences the same problem? Thanks!
 

Attachments

  • tempImageoUrGvm.png
    tempImageoUrGvm.png
    13.4 MB · Views: 32
Top