Contribute
Register

X299 Big Sur Support

Joined
Jul 26, 2012
Messages
39
Motherboard
Asus Prime Deluxe 2 x299
CPU
10980XE
Graphics
VII
Mac
  1. iMac
  2. MacBook Pro
There is nothing 'dreaded' about it.
A simple problem with a usually simple solution : SSDT-EC.aml
Yeah put that in just now and stuck on "tx_flush:1028"

Edit - took an old working 0.6.1 EFI and updated it to 0.6.4 now finally going to try again to upgrade this.

UGH so trying update from Catalina, fails saying ABORTED , then trying to install by USB image with EFI loaded from here on to it- black screen nothing else cant install, so darn frustrating. (edit- fix was to turn off monitor and then back on again. pretty stupid but ok)

Bios 3105 - can boot into catalina on 0.6.4 but cant upgrade or install clean.

After install bootup just takes its sweet time on tx_flush and its not going past that.

Edit # 5 - Ok got it installed finally - but have that issue out of 3 monitors only 1 works! lol Radeon VII worked perfectly in Catalina - but not here.
 
Last edited:
Joined
Jul 24, 2010
Messages
49
Motherboard
<< need manufacturer >> See Forum Rules !!
CPU
3930k
Graphics
GTX570
Mobile Phone
  1. Android
or install clean

@holmstockd - I'm also strugling to get OC0.6.3 to boot Big Sur on Asus X299 Prime Deluxe. Willing to give v0.6.4 ago, can you share your EFI folder that got you to boot into the installer, please?
 
Joined
Jul 26, 2012
Messages
39
Motherboard
Asus Prime Deluxe 2 x299
CPU
10980XE
Graphics
VII
Mac
  1. iMac
  2. MacBook Pro
@holmstockd - I'm also strugling to get OC0.6.3 to boot Big Sur on Asus X299 Prime Deluxe. Willing to give v0.6.4 ago, can you share your EFI folder that got you to boot into the installer, please
Sure set it as MAC PRO 7.1 and wala all monitors work - hope this works for you -

Edit- after running it for about 30 minutes - performance sucks compared to windows side. System crashed and when booting back up goes through the constant TX_FLUSH:1074 - ugh this OS is very annoying!
 

Attachments

  • EFI copy.zip
    2.7 MB · Views: 38
Last edited:
Joined
May 24, 2011
Messages
337
Motherboard
Gigabyte X299 AORUS Ultra Gaming
CPU
i9-7920X
Graphics
Sapphire Nitro+ RX 5700 XT
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
First of all -- thanks to everyone who has contributed to this thread! I successfully brought my X299 build up to Big Sur (11.0.1) .

My first attempt was an upgrade from Catalina (10.5.7) using Clover r5126, but I experienced non-stop issues with Clover and the volume selection always showing Preboot volume even after following the suggested workarounds that I just decided to make the move to OpenCore.

I migrated that upgrade install to use OpenCore 0.6.3, but still found I had random issues with my ASMedia AS2142 XHC2 / XHC3 devices disappearing if I rebooted my machine. I tried so many variations of USBMap.kext, USBPorts.kext, AppleXHCIUSB.kext, SSDTs, etc. -- all the great fixes I could find online in the guides and posts didn't work. It was very annoying to have to shutdown my machine in order to get these two devices to show along with the USB devices attached to them. There is one other user who reported the exact symptoms I was facing in this post, but even after following all suggestions I couldn't get it to go.

I decided to clean install Big Sur (11.0.1) using OpenCore 0.6.4 on my USB Install -- no upgrade, no clover--all good. This was a success and again am thankful for all the great discussions in this post that helped make things run so smooth. Although I pieced everything together all the credit goes to the amazing individuals who write such detailed guides, open source software/tools, and help the n00bs of this world :). Thank you!

I'm attaching my EFI for those who might like to see what I have pieced together.

Build Model: iMacPro1,1
Motherboard: Gigabyte X299 AORUS Ultra Gaming
CPU: Intel i9-7920X (12-core)
RAM: 128GB Corsair Vengeance LPX DDR4-2666 (8 x 16GB)
GPU: Sapphire Nitro+ RX 5700 XT 8 GB
10GbE: ASUS XG-C100C Aquantia AQC107 10-Gigabit Ethernet


EFI:
Inmike09 X299 Ultra Gaming-Big-Sur-11.0.1-OpenCore-0.6.4.zip

One Remaining Item Of Annoyance -- I have followed the well written apfs snapshot fix procedure from POST #1 repeatedly and no matter what I do I cannot delete the system snapshots. I always get the same error about insufficient privileges. If that is the worst thing I have to deal with that I'm a lucky man.

% csrutil status
System Integrity Protection status: disabled (Apple Internal).

% csrutil authenticated-root status
Authenticated Root status: disabled

% diskutil apfs listSnapshots /Volumes/macOS/

Snapshot for disk2s5 (1 found)
|
+-- 7CDBA2AB-1A3A-49B3-88F1-AF392BD9A74F
Name: com.apple.os.update-779BDF1556C6F688504E24FB29C75AFFABFCB91E701806FFFF35235E19914F1E
XID: 214
Purgeable: No

% diskutil apfs deleteSnapshot /Volumes/macOS/ -uuid 7CDBA2AB-1A3A-49B3-88F1-AF392BD9A74F

Deleting APFS Snapshot 7CDBA2AB-1A3A-49B3-88F1-AF392BD9A74F "com.apple.os.update-779BDF1556C6F688504E24FB29C75AFFABFCB91E701806FFFF35235E19914F1E" from APFS Volume disk2s5
Started APFS operation
Error: -69863: Insufficient privileges

% sudo diskutil apfs deleteSnapshot /Volumes/macOS/ -uuid 7CDBA2AB-1A3A-49B3-88F1-AF392BD9A74F

Deleting APFS Snapshot 7CDBA2AB-1A3A-49B3-88F1-AF392BD9A74F "com.apple.os.update-779BDF1556C6F688504E24FB29C75AFFABFCB91E701806FFFF35235E19914F1E" from APFS Volume disk2s5
Started APFS operation
Error: -69863: Insufficient privileges


% diskutil apfs deleteSnapshot /Volumes/macOS/ -xid 214

Deleting APFS Snapshot 7CDBA2AB-1A3A-49B3-88F1-AF392BD9A74F "com.apple.os.update-779BDF1556C6F688504E24FB29C75AFFABFCB91E701806FFFF35235E19914F1E" from APFS Volume disk2s5
Started APFS operation
Error: -69863: Insufficient privileges

Best of luck!


AboutThisMac.png


System4.png


System1.png


System2.png



System3.png
 

Attachments

  • System1.png
    System1.png
    376.8 KB · Views: 30
  • EFI.zip
    5 MB · Views: 94
Last edited:
Joined
Jul 17, 2011
Messages
25
Motherboard
Asus X299 Prime Deluxe (1.0)
CPU
i9-10940X
Graphics
Vega 56
Mobile Phone
  1. iOS
@holmstockd - I'm also strugling to get OC0.6.3 to boot Big Sur on Asus X299 Prime Deluxe. Willing to give v0.6.4 ago, can you share your EFI folder that got you to boot into the installer, please?
Hi, if you are using the dortania opencore install guide for Intel HEDT everything is working like a charme - you only need 4 ssdt: PLUG, USBX, RTC0, AWAC for a first setup... took me about 30 minutes to make a efi. read, learn and install. you do not need efi from other guys, cause if you do it for yourselves it is easy for you to understand how it works and you will have no problems with further updates (opencore & system):thumbup:
 

Ellybz

Retired
Joined
Apr 16, 2017
Messages
414
Motherboard
Gigabyte X299 WU-8
CPU
I9-7980Xe
Graphics
RX 580
Mobile Phone
  1. Android
Although I was able to find it, I wanted to thank you for supplying this. Still Apple's Big Sur seems to be able (for now), to circumvent your efforts to block them. They even know how to get around the VPN thing. So this is not good. I look forward to seeing how VPN companies, LuLu and Little Snitch's coders will overcome and write their software to protect us from prying eyes.
I read about this issue with Big Sur. My router has a built-in VPN & Firewall (DD-WRT), so I'm not really concerned about it. The branch cannot circumcise it's root :lol:.

There are still a few other options available to block Apple from bypassing your filter in Big Sur.
- Disabling SIP partially should allow you ( in theory ) to install previous version of Little Snitch or Lulu that work with kernel extension.
- Modifying an Info.plist in Big Sur system extension: Process is described below: ( a bit tedious :confused:)
-Approving the loading of particular kernel extensions ( requires booting in Recovery + Terminal commands )
- Hoping that Apple will modify their future releases ( I doubt it )
- Hoping that Little Snitch, lulu or TripMode will find a way around this.

Hope this helps. I'm using Router VPN + Lulu 2.0. for now.
 
Last edited:
Joined
Jul 14, 2019
Messages
103
Motherboard
ASUS WS SAGE/10G
CPU
i9-10940X
Graphics
Radeon VII
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
This is the KP that sometimes occurs...

Panic(CPU 0, time 3453995288839): NMIPI for spinlock acquisition timeout, spinlock: 0xffffff878c6d1220, spinlock owner: 0xffffff8788c0f9b0, current_thread: 0xffffff8788c0f9b0, spinlock_owner_cpu: 0x0
RAX: 0x0000000000000000, RBX: 0x0000000000000004, RCX: 0xffffff80066d3f53, RDX: 0xffffff80066d425c
RSP: 0xffffffa1fb154dd0, RBP: 0xffffffa1fb154e50, RSI: 0x0000000000000004, RDI: 0xffffffe282e8f024
R8: 0x0000000000000000, R9: 0x0000000000000024, R10: 0x0000000000000001, R11: 0x0000000000000000
R12: 0x0000000000000000, R13: 0x0000000000000000, R14: 0x0000000080000001, R15: 0xffffffe282e8f024
RFL: 0x0000000000000097, RIP: 0xffffff80066d3f56, CS: 0x0000000000000008, SS: 0x0000000000000010
Backtrace (CPU 0), Frame : Return Address
0xffffffa1fb154c80 : 0xffffff80067eee4b mach_kernel : _interrupt + 0x12b
0xffffffa1fb154cd0 : 0xffffff8006661d39 mach_kernel : _return_to_iret + 0x159
0xffffffa1fb154e50 : 0xffffff7fa4787832 com.apple.driver.AppleGFXHDA : __ZN21AppleGFXHDAController12pollRegisterEiijj + 0x2ca
0xffffffa1fb154e80 : 0xffffff7fa478c737 com.apple.driver.AppleGFXHDA : __ZN21AppleGFXHDAController15interruptFilterEP28IOFilterInterruptEventSource + 0x19f
0xffffffa1fb154ed0 : 0xffffff8006e1bfd1 mach_kernel : __ZN28IOFilterInterruptEventSource23normalInterruptOccurredEPvP9IOServicei + 0x81
0xffffffa1fb154f00 : 0xffffff8009038beb com.apple.iokit.IOPCIFamily : __ZN32IOPCIMessagedInterruptController15handleInterruptEPvP9IOServicei + 0x12b
0xffffffa1fb154f50 : 0xffffff8007695510 com.apple.driver.AppleACPIPlatform : __ZN23AppleACPIPlatformExpert23dispatchGlobalInterruptEi + 0x2e
0xffffffa1fb154f60 : 0xffffff800769e24f com.apple.driver.AppleACPIPlatform : __ZN31AppleACPICPUInterruptController15handleInterruptEPvP9IOServicei + 0x6b
0xffffffa1fb154f80 : 0xffffff80067eee9d mach_kernel : _interrupt + 0x17d
0xffffffa1fb154fd0 : 0xffffff8006661bdd mach_kernel : _hndl_allintrs + 0x11d
0xffffffe28c35baf0 : 0xffffff8006c2373a mach_kernel : _kevt_getstat + 0x16fa
0xffffffe28c35bb90 : 0xffffff8006c2274e mach_kernel : _kevt_getstat + 0x70e
0xffffffe28c35bbd0 : 0xffffff8006c27617 mach_kernel : _kevent_register + 0x997
0xffffffe28c35bcc0 : 0xffffff8006c2a70d mach_kernel : _kevent_id + 0x38d
0xffffffe28c35bdd0 : 0xffffff8006c2aaa8 mach_kernel : _kevent_workq_internal + 0xb8
0xffffffe28c35be00 : 0xffffff8009891a61 com.apple.kec.pthread : _workq_handle_stack_events + 0x9d
0xffffffe28c35be90 : 0xffffff8006bfb6e8 mach_kernel : _workq_kernreturn + 0x748
0xffffffe28c35bf40 : 0xffffff8006d69ceb mach_kernel : _unix_syscall64 + 0x27b
0xffffffe28c35bfa0 : 0xffffff80066621f6 mach_kernel : _hndl_unix_scall64 + 0x16
Kernel Extensions in backtrace:
com.apple.kec.pthread(1.0)[370B9FFE-4A14-3CA7-8908-FD392BC4613E]@0xffffff8009890000->0xffffff8009897fff
com.apple.iokit.IOPCIFamily(2.9)[A18ACD60-A811-3624-B50D-4F929836EE79]@0xffffff8009017000->0xffffff800903efff
com.apple.driver.AppleACPIPlatform(6.1)[D5E73559-87FF-3A4D-A884-3C734F0BB103]@0xffffff800768e000->0xffffff8007704fff
dependency: com.apple.driver.AppleSMC(3.1.9)[30ACBB00-67A3-36BD-AF95-1E6F0CB38447]@0xffffff8007c90000->0xffffff8007ca8fff
dependency: com.apple.iokit.IOACPIFamily(1.4)[65A1D60D-F9AF-37E7-B854-4127FBB3172A]@0xffffff8008ad2000->0xffffff8008ad3fff
dependency: com.apple.iokit.IOPCIFamily(2.9)[A18ACD60-A811-3624-B50D-4F929836EE79]@0xffffff8009017000->0xffffff800903efff
com.apple.driver.AppleGFXHDA(100.1.431)[A45C4893-81FD-3D81-91B5-0C4DC912874F]@0xffffff7fa4784000->0xffffff7fa47e1fff
dependency: com.apple.iokit.IOAudioFamily(300.6.1)[8A293724-D2EF-3EF2-B6D0-245BB15A33DE]@0xffffff8008b35000->0xffffff8008b52fff
dependency: com.apple.iokit.IOGraphicsFamily(585)[BCCD5611-3116-3255-ADBF-C5521D3B39C6]@0xffffff7fa60b3000->0xffffff7fa60e1fff
dependency: com.apple.iokit.IONDRVSupport(585)[81DC638B-EE31-3C9B-98D1-9BC8414D97E9]@0xffffff7fa60f8000->0xffffff7fa6100fff
dependency: com.apple.iokit.IOPCIFamily(2.9)[A18ACD60-A811-3624-B50D-4F929836EE79]@0xffffff8009017000->0xffffff800903efff
 
Last edited:
Joined
Apr 22, 2012
Messages
40
Motherboard
Asus Rog Rampage VI Extreme Omega X299
CPU
i9-10920X
Graphics
Radeon VII
Many thanks guys. I finally managed to get to the installer but it’s very slow and every time it stuck at 15 minutes progress.
 
Joined
Apr 1, 2011
Messages
141
Motherboard
Asus X-299 Prime deluxe,Asus X-99 Deluxe II
CPU
i9-7980XE, Xeon E5-2696 v4
Graphics
XFX Radeon VII, Sapphire Nitro+ Radeon RX Vega 64 8GB
Mac
  1. Mac Pro
Mobile Phone
  1. iOS
Asus X299 Prime Deluxe - i9-7980XE - XFX Radeon VII 16GB - Asus ThunderbolyEX 3 worked.

During the installation or update, There was twice it will hang will a cursor hanging on top left side of the screen, I had to switch off the computer manually and boot into the installer disk. I have tried a few time, every time same behaviour. but the third time will boot into Big Sur.

My EFI is base on what @Loloflatsix has shared. I update tp OC 6.3 and it worked. Asus Hyper M.2 X16 seems to have some issue though.
 

Attachments

  • Screenshot 2020-11-19 at 10.48.13 PM.png
    Screenshot 2020-11-19 at 10.48.13 PM.png
    200.4 KB · Views: 39
Joined
Nov 15, 2020
Messages
10
Motherboard
MSI X299 Gaming Carbon AC
CPU
Intel 7900x
Graphics
Radeon RX580
In your case, I think there are just a few details to adjust : download different EFI files posted in posts above ( OC 0.6.3) and then you have to compare ACPI file, Kext file and config.plist by side with yours.
Have looked at many, mixed and matched, can't seem to find the right combo and would love some advice. EFI attached (with ROM/MLB/etc removed as well as Resources to keep size down). My MSI AC Carbon has MSR lock disabled in BIOS and NVRAM has always appeared to be working. Above 4G is on. Have a 7900x and Sapphire RX580.

Catalina runs great, so I feel like I'm missing something that's obvious. Can also upload my SysReport from OC if anyone is interested. Using 0.6.4 snapshots with editing in ProperTree. The USB reset SSDT is to disable USB controllers that I don't use in my rig.

FWIW, tried moving to MacPro7,1 (and removed WEG) and could no longer boot from the BigSur USB drive. Suppose it's just not compatible, or again, I'm missing something.
 

Attachments

  • EFI-MSI-CARBON-X299.zip
    2.2 MB · Views: 20
Top