Contribute
Register

X299 Big Sur Support

Joined
Jul 17, 2011
Messages
15
Motherboard
Asus X299 Prime Deluxe (1.0)
CPU
i9-10940X
Graphics
Vega 56
Mobile Phone
  1. iOS
Exactly the same problem i've had since installing big sur
yes, it is a common problem (see also in other boards). I also have the fault 97 (most of the time). If you look around, it looks like a problem with the Graphics... But fault comes only on reboot for me. If shut down and start there is no problem for me.
 
Joined
Dec 13, 2018
Messages
45
Motherboard
Asus X299-A Prime
CPU
i7-7800x
Graphics
RX 5700XT
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
@pieropontra after the update to build 20C5048k (11.1 Dev Beta 1) iPhone calls seems to work again.
I just tried a couple of calls and they worked as should.
I had got also one kp after sleep on official Big Sur build, but was not able to reproduce and I will definitively report if this new beta has the same bug.

As a side note, is very strange how beta (and even dev beta) builds are more stable than official releases... also on iOS 14.2 beta 1 we saw less problems than on official 14.0.1
 
Joined
Jun 13, 2018
Messages
632
Motherboard
Prime X299-A
CPU
i9-9980XE
Graphics
RX 5700 XT
Mac
  1. iMac
  2. MacBook Pro
Classic Mac
  1. iMac
  2. Power Mac
Mobile Phone
  1. Android
  2. iOS
@pieropontra after the update to build 20C5048k (11.1 Dev Beta 1) iPhone calls seems to work again.
I just tried a couple of calls and they worked as should.
I had got also one kp after sleep on official Big Sur build, but was not able to reproduce and I will definitively report if this new beta has the same bug.

As a side note, is very strange how beta (and even dev beta) builds are more stable than official releases... also on iOS 14.2 beta 1 we saw less problems than on official 14.0.1
Glad to know mate, this confirms that's an OS bug probably and not an AppleALC specific problem (at least I think). Anyway I use an external card via usb most of the time and ti works. Since we share the same board, could you please tell me how your RX 5700XT performs? Stability, problems, I'm seriously considering swapping my Radeon VII. Do you use WEG with MacPro7,1 and agdpmod=pikera boot arg? multi-monitor? DRMs in Netflix/Prime?
 
Joined
Dec 13, 2018
Messages
45
Motherboard
Asus X299-A Prime
CPU
i7-7800x
Graphics
RX 5700XT
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Glad to know mate, this confirms that's an OS bug probably and not an AppleALC specific problem (at least I think). Anyway I use an external card via usb most of the time and ti works. Since we share the same board, could you please tell me how your RX 5700XT performs? Stability, problems, I'm seriously considering swapping my Radeon VII. Do you use WEG with MacPro7,1 and agdpmod=pikera boot arg? multi-monitor? DRMs in Netflix/Prime?

I have nothing to complain about the 5700XT (aside from its cost ahah). I use it in a dual monitor setup, with my main being a 4k@60 connected via DP and my tv being a 1080p@60 connected via HDMI. Sometime I also use the tv as audio device output and I had to say that the audio quality on macOS is great, on windows 10 I get sometime a cracking noise but on macOS is clear all the time!
I cannot tell much about performance since I generally do cpu intensive tasks rather than gpu intensive (I mainly use Xcode for work), but I think that they will be inferior to your Radeon VII. At the time I wanted a 5500xt to save ~200€ but in the end I thought that better gpu can last longer and the 5700CT is pretty popular on Hackintosh community..

About DRM I haven't tested. I have an AppleTV subscription and I was able to watch a full movie (on Beta 10) without issue, I also opened PrimeVideo and I can reproduce a movie in its highest res (6.5 gb per hour). (noted that if I turn off the tv prime video complains about the lack of HDCP)

I use MacPro7,1 smbios without weg and without any gpu related boot arg.
 
Joined
Jan 28, 2012
Messages
59
Motherboard
Asus Rampage VI Extreme Omega
CPU
Core i9 10980XE
Graphics
AMD Vega 64 XTX
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
So one more question. I just tried to update to Bios 3105 from 0802 and the machine now just shuts down after it hits the Apple logo after the OpenCore menu. Was there something that changed drastically in the Bios? I know that the one after 0802 had issues with the MSR lock, but didn't see anything about 3105.
I think you have to disable SetupVirtualMap in the Booter Quirks. It's one of those:
1605700595657.png
 
Joined
Jul 14, 2019
Messages
103
Motherboard
ASUS WS SAGE/10G
CPU
i9-10940X
Graphics
Radeon VII
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Hi,
I succeeded to install BS (20B29). All work fine but sometimes I have a reboot reported as a problem with GFX0 kext. That happened with Catalina too and a Google search allowed me to discover that this seems to be an issue related to Radeon VII audio. Studying the KGP posts and his guide about "how to create or modify a simple System SSDT.aml by means of DSDT and IOREG ACPI information" I concluded that it is necessary - for me but maybe for other people - to start again from ACPI properties to correctly implement every device (no matter if onboard or PCI) on every mobo. Taking account of the fact that he worked with Clover, I noticed that he used a lot of SSDT, one for each device and, in particular, one for the VII (there is two versions of VII one ...).
At the moment, I'm not able to compile myself an SSDT but I'm studying to do that. So far, I gathered the following related materials and sources:
1. latest version of UEFI specifications
2. Introduction to I/O kit fundamentals
3. the earlier mentioned KGP guide.
Has someone tried to go deeper into this matter?
Maybe we can start to co-operate to better understand how to let function our hacks ...

Thank you all in advance
Miki from Italy
 
Joined
Jul 26, 2012
Messages
35
Motherboard
Asus Prime Deluxe 2 x299
CPU
10980XE
Graphics
VII
Mac
  1. iMac
  2. MacBook Pro
you are very welcome back to the scene my friend. Even though you are still retired i suppose, i hope to see you around from now on :thumbup:
what SDST's do i need i keep getting teh dreaded STUCK at "apfs_module_start 1689 load com.apple.filesystems.apfs" only have PC to edit.
 

P1LGRIM

Moderator
Joined
Mar 2, 2012
Messages
24,600
Motherboard
Lenovo ThinkStation p300 ⌘
CPU
i7-4790K
Graphics
HD 4600
Mac
  1. MacBook Pro
  2. Mac mini
Classic Mac
  1. Power Mac
Mobile Phone
  1. iOS
what SDST's do i need i keep getting teh dreaded STUCK at "apfs_module_start 1689
There is nothing 'dreaded' about it.
A simple problem with a usually simple solution : SSDT-EC.aml
 
Top