Contribute
Register

X299 Big Sur Support

Joined
Apr 13, 2012
Messages
223
Motherboard
Asus WS X299 Sage/10g
CPU
i9-7940X
Graphics
Vega 64
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Mobile Phone
  1. iOS
Thanks @Loloflatsix! It was late where I am too, but the workday here is about begin shortly. I’ll check it in a couple of hours and get back to you with an IOREG. Thanks for your efforts!
I tried to boot with your modified EFI from a USB stick and the boot hung — stuck on the Apple with a progress bar. It moves slow and never finished after giving it over an hour. I wish I could tell you before, but my EFI is set to not run a verbose boot. And I actually can’t find where to change it on opencore. Would it help do you know any information from a verbose boot? Do you have any ideas why it won’t boot now? Thanks!
 
Joined
Mar 18, 2017
Messages
1,008
Motherboard
ASUS ROG Rampage VI Extreme
CPU
i9-7940X
Graphics
2 X VEGA 56
Mac
  1. iMac
  2. Mac mini
Mobile Phone
  1. iOS
I tried to boot with your modified EFI from a USB stick and the boot hung — stuck on the Apple with a progress bar. It moves slow and never finished for over an hour. I wish I could tell you before, but my EFI is set to not run a verbose boot. And I actually can’t find where to change it on opencore. Would it help do you know any information from a verbose boot? Do you have any ideas why it won’t boot now? Thanks!
I checked the config.plist just now , seems to be ok but in case of problems at booting : can you add under NVRAM section: -v at boot-args and perhaps we'll see what's is wrong , maybe the new SSTD-RTC0 , sorry if it takes a few time ;)
 
Joined
Apr 13, 2012
Messages
223
Motherboard
Asus WS X299 Sage/10g
CPU
i9-7940X
Graphics
Vega 64
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Mobile Phone
  1. iOS
I checked the config.plist just now , seems to be ok but in case of problems at booting : can you add under NVRAM section: -v at boot-args and perhaps we'll see what's is wrong , maybe the new SSTD-RTC0 , sorry if it takes a few time ;)
No problem on this taking up my time...I’m just grateful to have the help!! The photo shows where it is hanging. Something like DK: Driverkit_AppleEthernetE1000-0x1000004bb user server timeout. Shows up 2x But slightly different ending.
 

Attachments

  • 3FCEBECF-19BE-46FB-BFE4-133D8D5D3C01.jpeg
    3FCEBECF-19BE-46FB-BFE4-133D8D5D3C01.jpeg
    4 MB · Views: 11
Joined
Apr 13, 2012
Messages
223
Motherboard
Asus WS X299 Sage/10g
CPU
i9-7940X
Graphics
Vega 64
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Mobile Phone
  1. iOS
No problem on this taking up my time...I’m just grateful to have the help!! The photo shows where it is hanging. Something like DK: Driverkit_AppleEthernetE1000-0x1000004bb user server timeout. Shows up 2x But slightly different ending.
My Ethernet ports are flashed to work with the Smalltree Kext. Not sure if that is related.
 
Joined
Mar 18, 2017
Messages
1,008
Motherboard
ASUS ROG Rampage VI Extreme
CPU
i9-7940X
Graphics
2 X VEGA 56
Mac
  1. iMac
  2. Mac mini
Mobile Phone
  1. iOS
My Ethernet ports are flashed to work with the Smalltree Kext. Not sure if that is related.
Yes ok : and in your kext file I don't see IntelMausi which for me is needed to work with Smalltree.kext : see here the latest release on acidanthera IntelMausi
See also here #1 for Smalltree.kext
 
Last edited:
Joined
Apr 13, 2012
Messages
223
Motherboard
Asus WS X299 Sage/10g
CPU
i9-7940X
Graphics
Vega 64
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Mobile Phone
  1. iOS
Do I need to do anything else besides add that kext to the kext folder? Maybe register intelmausi in the config.sys? I tried after just adding the intelmausi kext and I get the same hang...
 

Attachments

  • 98DE3407-F28E-42AB-9BD8-FBA6FC261219.jpeg
    98DE3407-F28E-42AB-9BD8-FBA6FC261219.jpeg
    4.1 MB · Views: 7
Joined
Mar 18, 2017
Messages
1,008
Motherboard
ASUS ROG Rampage VI Extreme
CPU
i9-7940X
Graphics
2 X VEGA 56
Mac
  1. iMac
  2. Mac mini
Mobile Phone
  1. iOS
Do I need to do anything else besides add that kext to the kext folder? Maybe register intelmausi in the config.sys? I tried after just adding the intelmausi kext Zbd I get the same hang...
You must edit the config.plist for it and add:
Code:
            <dict>
                <key>BundlePath</key>
                <string>IntelMausi.kext</string>
                <key>Comment</key>
                <string></string>
                <key>Enabled</key>
                <true/>
                <key>ExecutablePath</key>
                <string>Contents/MacOS/IntelMausi</string>
                <key>MaxKernel</key>
                <string></string>
                <key>MinKernel</key>
                <string></string>
                <key>PlistPath</key>
                <string>Contents/Info.plist</string>
            </dict>
 
Joined
Mar 18, 2017
Messages
1,008
Motherboard
ASUS ROG Rampage VI Extreme
CPU
i9-7940X
Graphics
2 X VEGA 56
Mac
  1. iMac
  2. Mac mini
Mobile Phone
  1. iOS
@patrickfogle :
Sorry but I did not explain yesterday where I wanted to end up:
- SSDT-X299-Vega64 : to prevent issue with display screen after wake and other improvements
- SSDT-X299-XHC / SSDT-X299-TB3HP / USBASUSX299SAGE.kext to add ports and properties for your USB devices and especially your "Raid devices" plugged on Titan Ridge
 
Joined
Apr 13, 2012
Messages
223
Motherboard
Asus WS X299 Sage/10g
CPU
i9-7940X
Graphics
Vega 64
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Mobile Phone
  1. iOS
@patrickfogle :
Sorry but I did not explain yesterday where I wanted to end up:
- SSDT-X299-Vega64 : to prevent issue with display screen after wake and other improvements
- SSDT-X299-XHC / SSDT-X299-TB3HP / USBASUSX299SAGE.kext to add ports and properties for your USB devices and especially your "Raid devices" plugged on Titan Ridge
Thanks
 
Joined
Apr 13, 2012
Messages
223
Motherboard
Asus WS X299 Sage/10g
CPU
i9-7940X
Graphics
Vega 64
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Mobile Phone
  1. iOS
You must edit the config.plist for it and add:
Code:
            <dict>
                <key>BundlePath</key>
                <string>IntelMausi.kext</string>
                <key>Comment</key>
                <string></string>
                <key>Enabled</key>
                <true/>
                <key>ExecutablePath</key>
                <string>Contents/MacOS/IntelMausi</string>
                <key>MaxKernel</key>
                <string></string>
                <key>MinKernel</key>
                <string></string>
                <key>PlistPath</key>
                <string>Contents/Info.plist</string>
            </dict>
Ok. I added all of that, but I still get the same hang....any ideas?
 

Attachments

  • EE1EE918-4A65-49FC-A3E9-6845924B48C4.jpeg
    EE1EE918-4A65-49FC-A3E9-6845924B48C4.jpeg
    4 MB · Views: 12
Top