Contribute
Register

X299 Big Sur Support

Joined
Apr 24, 2013
Messages
47
Motherboard
ASUS WS X299 SAGE/10G
CPU
i9-10980XE
Graphics
Radeon VII
Hello all. Would anyone be able to assist me with the random boots I am having with Catalina. On the introductory screen (country, apple id and etc.), the system will shut down and reboot. I have no clue why. If anyone could provide a cause it would be greatly appreciated. Much thanks in advance.
 

Attachments

  • EFI.zip
    2.7 MB · Views: 17
Joined
Sep 13, 2020
Messages
14
Motherboard
Gigabyte x299 Designare Ex
CPU
Intel i9 9980xe
Graphics
Sapphire Nitro+ Radeon RX 5700 XT
Thx guys for your update.
I have a question about MB configuration. I looked at Gigabyte settings and ... in M.I.T/Advanced Frequency Settings/Advanced CPU Core settings I have for Intel Turbo boost Max Technology 3.0 Native Mode or Legacy not Enabled/Disabled. I had a look on google but it's only talking about drivers installation in legacy mode

If I ask this question, I ran geekbench on my build on windows 10 and the system froze completely. When I boot, I had an error message "The system has experienced a boot failure possibly due to incorrect configuration. Previous settings in BIOS may not be compatible with current hardware state.

Current CPU Speed: 4501,4 MHz
Current BCLK: 100.2MHz
Current Memory Speed: 2133.82MHz"

EDIT: i tried to set to AUTO "Enhanced Multi-Core Performance" and no more crash under windows...
I'll try under macos
 
Last edited:

Ellybz

Retired
Joined
Apr 16, 2017
Messages
417
Motherboard
Gigabyte X299 WU-8
CPU
I9-7980Xe
Graphics
RX 580
Mobile Phone
  1. Android
Thx guys for your update.
I have a question about MB configuration. I looked at Gigabyte settings and ... in M.I.T/Advanced Frequency Settings/Advanced CPU Core settings I have for Intel Turbo boost Max Technology 3.0 Native Mode or Legacy not Enabled/Disabled. I had a look on google but it's only talking about drivers installation in legacy mode

If I ask this question, I ran geekbench on my build on windows 10 and the system froze completely. When I boot, I had an error message "The system has experienced a boot failure possibly due to incorrect configuration. Previous settings in BIOS may not be compatible with current hardware state.

Current CPU Speed: 4501,4 MHz
Current BCLK: 100.2MHz
Current Memory Speed: 2133.82MHz"

EDIT: i tried to set to AUTO "Enhanced Multi-Core Performance" and no more crash under windows...
I'll try under macos
@Loloflatsix post #1 tells you exactly the bios settings to apply on your Mobo.
Re: Intel Turbo boost Max Technology needs to be enabled.

You can also engage the XMP profile for your memory settings. Your freezes/crashes are most likely due to your overclocking parameters. You need to start with lower settings ( 40/41 ) and run a few Cinebench or Geekbench tests starting from there. If it passes , you can up the overclocking settings by a single digit at a time. Obviously you'll need a decent AIO Cooler or custom Cooler to reach higher CPU speed. You'll reach lower thermal ceiling with an Air Cooler.

The overclocking settings in Gigabyte are very tricky and more complex than Asus. They put bunch of security/safety settings that will Freeze, shut down and even reset/break your bios if you do not know what you are doing. It took me a while to learn & understand all of them before tweaking them. Patience is an absolute requirement. I also recommend to save regularly your Bios settings on a USB Key, so you access them quickly in case you'll get a Bios reset during this process.
 
Last edited:
Joined
Mar 18, 2017
Messages
1,008
Motherboard
ASUS ROG Rampage VI Extreme
CPU
i9-7940X
Graphics
2 X VEGA 56
Mac
  1. iMac
  2. Mac mini
Mobile Phone
  1. iOS
@hkuser :
I checked your EFI :
- MacProMemoryNotificationDisabler.kext not needed with iMacPro 1,1 SMBIOS (on your config.plist)
- You must perform your own USB.kext and SSDT-UIAC.aml with Hackintool and remove USBInjectall.kext
- add your required SSDT according to your IOReg
- also check your bios settings see post #1
- after boot completed your can attach your IOReg for help ;)
 
Last edited:
Joined
Mar 18, 2017
Messages
1,008
Motherboard
ASUS ROG Rampage VI Extreme
CPU
i9-7940X
Graphics
2 X VEGA 56
Mac
  1. iMac
  2. Mac mini
Mobile Phone
  1. iOS
@Ellybz : sorry but I omitted to point your EFI on post #72 on the resources post #2 I will edit now ;)
 
Joined
Sep 13, 2020
Messages
14
Motherboard
Gigabyte x299 Designare Ex
CPU
Intel i9 9980xe
Graphics
Sapphire Nitro+ Radeon RX 5700 XT
@Ellybz I read that Intel Turbo boost Max Technology needs to be enabled but ... my mobo does not have that choice. Only native or Legacy
The parameter Enhanced Multi-core Performance is for activating overclocking? I do not want to overclock now, only use stock perf but in performance mode, not lazy :D
 

Ellybz

Retired
Joined
Apr 16, 2017
Messages
417
Motherboard
Gigabyte X299 WU-8
CPU
I9-7980Xe
Graphics
RX 580
Mobile Phone
  1. Android
@Ellybz I read that Intel Turbo boost Max Technology needs to be enabled but ... my mobo does not have that choice. Only native or Legacy
The parameter Enhanced Multi-core Performance is for activating overclocking? I do not want to overclock now, only use stock perf but in performance mode, not lazy :D
You do not have this function??? :eek: ( screenshot below from my previous Mobo, GA Aorus Gaming 7 )
Line before Turbo Ratio (1-Core Active )
I even have it on my Wu-8.

Screen Shot 2020-09-14 at 12.43.15.png
 
Top