Contribute
Register

X299 Big Sur Support

Joined
Jun 13, 2018
Messages
696
Motherboard
Prime X299-A II
CPU
i9 9980XE
Graphics
RX 6800 XT
Mac
  1. iMac
  2. MacBook Pro
Classic Mac
  1. iMac
  2. Power Mac
Mobile Phone
  1. Android
  2. iOS
I'm baaaaaack!!! It was the PSU (mobo was fine after all)!! Anyway I swapped X299-A for A II and it's flawless.

I attach the USB fresh made kext for X299-A II (sleep working) for @rustEswan :headbang:
 

Attachments

  • USBMap.kext.zip
    1.2 KB · Views: 17
Joined
Apr 18, 2011
Messages
1,299
Motherboard
ASUS Pro WS X299 Sage II
CPU
i9-10980XE
Graphics
Radeon Pro W5500
Mac
  1. MacBook Air
  2. Mac Pro
Mobile Phone
  1. iOS
View attachment 524555

Anyone know the correct PCIid for the TB3 port?

I have the following in PCI list and none of them work.

Looks like its
Code:
PciRoot(0x0)/Pci(0x1C,0x4)/Pci(0x0,0x0)/Pci(0x0,0x0)/Pci(0x0,0x0)
however gfxutil shows
Code:
PciRoot(0x0)/Pci(0x1C,0x4)/Pci(0x0,0x0)/Pci(0x0,0x0)

Code:
48:00.0 8086 15EA 00CF 0000 Disabl Intel Corporation              JHL7540 Thunderbolt 3 Bridge [Titan Ridge 4C 2018] Bridge               PCI bridge           P05@1C,4/UPSB@0 pci-bridge      PciRoot(0x0)/Pci(0x1C,0x4)/Pci(0x0,0x0)
49:01.0 8086 15EA 0000 0000 Disabl Intel Corporation              JHL7540 Thunderbolt 3 Bridge [Titan Ridge 4C 2018] Bridge               PCI bridge           4/UPSB@0/DSB1@1 pci-bridge      PciRoot(0x0)/Pci(0x1C,0x4)/Pci(0x0,0x0)/Pci(0x1,0x0)
49:02.0 8086 15EA 0000 0000 Disabl Intel Corporation              JHL7540 Thunderbolt 3 Bridge [Titan Ridge 4C 2018] Bridge               PCI bridge           4/UPSB@0/DSB2@2 pci-bridge      PciRoot(0x0)/Pci(0x1C,0x4)/Pci(0x0,0x0)/Pci(0x2,0x0)
49:04.0 8086 15EA 0000 0000 Disabl Intel Corporation              JHL7540 Thunderbolt 3 Bridge [Titan Ridge 4C 2018] Bridge               PCI bridge           4/UPSB@0/DSB4@4 pci-bridge      PciRoot(0x0)/Pci(0x1C,0x4)/Pci(0x0,0x0)/Pci(0x4,0x0)
4B:00.0 8086 15EB 2222 1111 Disabl Intel Corporation              JHL7540 Thunderbolt 3 NHI [Titan Ridge 4C 2018]    Generic system perip System peripheral    0/DSB0@0/NHI0@0 pci8086,15eb    PciRoot(0x0)/Pci(0x1C,0x4)/Pci(0x0,0x0)/Pci(0x0,0x0)/Pci(0x0,0x0)

Looks right, but the SSDT may be overriding what is filled in DeviceProperties. I believe Casey's SSDT defaults to Slot-4 but a simple find/replace can fix it :)
 
Joined
Feb 26, 2011
Messages
126
Motherboard
ASUS PRIME X299-A II
CPU
i9 10940X
Graphics
AMD RX 560 | Nvidia RTX 3070
Mac
  1. MacBook
  2. MacBook Pro
Mobile Phone
  1. iOS
I'm baaaaaack!!! It was the PSU (mobo was fine after all)!! Anyway I swapped X299-A for A II and it's flawless.

I attach the USB fresh made kext for X299-A II (sleep working) for @rustEswan :headbang:
Excellent work! :clap:

I can't wait to get my machine back and get this implemented on mine, interested to take a look at the changes - how much did you have to change? Thank you :thumbup:
 
Joined
Jun 13, 2018
Messages
696
Motherboard
Prime X299-A II
CPU
i9 9980XE
Graphics
RX 6800 XT
Mac
  1. iMac
  2. MacBook Pro
Classic Mac
  1. iMac
  2. Power Mac
Mobile Phone
  1. Android
  2. iOS
Excellent work! :clap:

I can't wait to get my machine back and get this implemented on mine, interested to take a look at the changes - how much did you have to change? Thank you :thumbup:
Not to much actually, I just used USBToolBox in Windows. I discovered all the ports and then I checked all ports' personalities and types. Please keep in mind that all the ports work in 3.x mode (Type A and Type C) but only one USB 2.0 header works (the one on the left) and only the two upper USB 2.0 and the case port USB 2.0 personality is mapped. This since I had to stay below 15 obviously. Anyway, I really suggest you to go map yourself customizing it according to your needs, it's easy in windows you just have to follow the link here:

 
Joined
Feb 24, 2013
Messages
2,669
Motherboard
N/A
CPU
N/A
Graphics
N/A
Mac
  1. MacBook Air
  2. Mac Pro
Mobile Phone
  1. iOS
11.5 Updated flawlessly with 3 reboots

Will be testing Monterey soon on a secondary SSD, Big Sur has been super stable for me so far.
 
Joined
Feb 24, 2013
Messages
2,669
Motherboard
N/A
CPU
N/A
Graphics
N/A
Mac
  1. MacBook Air
  2. Mac Pro
Mobile Phone
  1. iOS
Does anyone have any ideas why I can't attach BT devices?

I have a wireless magic keyboard and it connects fine, just not AirPods or Bose QC35II
 
Joined
Apr 18, 2011
Messages
1,299
Motherboard
ASUS Pro WS X299 Sage II
CPU
i9-10980XE
Graphics
Radeon Pro W5500
Mac
  1. MacBook Air
  2. Mac Pro
Mobile Phone
  1. iOS
Does anyone have any ideas why I can't attach BT devices?

I have a wireless magic keyboard and it connects fine, just not AirPods or Bose QC35II

I've had issues with PCIe allocation and the PLX chips on the Sage board. Recently it’s been finicky on which slots it prefers to be populated first. I’m not sure if this is a more recent BIOS issue and/or Big Sur/Monterey issue.

I’m sure if all slots are populated they should operate normally but until then maybe shuffling the devices around will help.

Or I can be entirely wrong and there is an issue with my board lol. I’ve noticed PC03 completely disappears sometimes. Thankfully I think all I needed to do was a cmos/nvram reset
 
Last edited:
Top