Contribute
Register

X299 Big Sur Support

Joined
Sep 27, 2017
Messages
56
Motherboard
Asus Prime X299 Deluxe
CPU
i9-7900X
Graphics
Vega 64
Mac
  1. Mac Pro
Mobile Phone
  1. Android
Hello everyone!

I've been using my hackintosh with Mojave for a while and today I decided to give Big Sur a go, I used the EFI on @Loloflatsix github and in all my years of using hackintosh I've never had an installation go so smooth and fast, thank you for that!

One thing I cant figure out its the fans on my Vega 64 (Sapphire Nitro+), some times they are super quiet, some times they'll ramp up even when the computer is completely idle, didn't experience this on Mojave. Can anyone point me in the right direction on how to fix this? Cant seem to figure it out, I'm using the configuration on my signature.
 

Attachments

  • EFI NS.zip
    57.8 MB · Views: 33
Joined
Jun 13, 2018
Messages
736
Motherboard
Prime X299-A II
CPU
i9 9980XE
Graphics
RX 6800 XT
Mac
  1. iMac
  2. MacBook Pro
Classic Mac
  1. iMac
  2. Power Mac
Mobile Phone
  1. Android
  2. iOS
Hello everyone!

I've been using my hackintosh with Mojave for a while and today I decided to give Big Sur a go, I used the EFI on @Loloflatsix github and in all my years of using hackintosh I've never had an installation go so smooth and fast, thank you for that!

One thing I cant figure out its the fans on my Vega 64 (Sapphire Nitro+), some times they are super quiet, some times they'll ramp up even when the computer is completely idle, didn't experience this on Mojave. Can anyone point me in the right direction on how to fix this? Cant seem to figure it out, I'm using the configuration on my signature.
I think that's normal behavior of a GPU, that fact it stays quiet and sometimes ramps up means it works to my knowledge. It could be because MacOS is doing something in background since it is a new update, or simply because it uses GPU acceleration much more widely in the os. I would simply benchmark it with something heavy, like Luxmark of GFXBench and check stability at high power and temps.
 
Joined
Aug 2, 2012
Messages
168
Motherboard
Gigabyte X299 Designare EX ver1
CPU
i9-9960X
Graphics
RX Vega 64
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Mobile Phone
  1. iOS
After logging back in, run IORegistryExplorer and post the IOReg file
Hello Casey,
I managed to restart my rig and the USB3.1 appeared again.
I've re-saved the ioreg export file, please take a look see if this is what you were looking for for enabled Tb3:

Thank you so much!
 

Attachments

  • ioreg-x299-designare-ex - Mar30.ioreg
    5.2 MB · Views: 24

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
20,145
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Hello Casey,
I managed to restart my rig and the USB3.1 appeared again.
I've re-saved the ioreg export file, please take a look see if this is what you were looking for for enabled Tb3:

Thank you so much!
Unfortunately there's still no mention of Thunderbolt. We have seen this problem on some of the newer BIOSes that support Resizeable Base Address Registers (BAR). Which version of BIOS are you running?
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
20,145
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
The only suggestions I can make now:
  • Re-flash BIOS F6
  • Or consider flashing BIOS F7c
Then configure BIOS parameters again, starting with Load Optimized Defaults, then we can check IOReg once more. If Thunderbolt is still not visible it may be necessary to install Windows or Linux and see if Thunderbolt is available in those operating systems. If Thunderbolt is not active there as well, then it would indicate a board failure.
 
Joined
Aug 2, 2012
Messages
168
Motherboard
Gigabyte X299 Designare EX ver1
CPU
i9-9960X
Graphics
RX Vega 64
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Mobile Phone
  1. iOS
I'll follow your recommendation Casey,
Can I just ask you where exactly are you looking in my ioreg dump file to indicate that the Tb is not there?
I'll keep messing around with my system and I'll be testing myself if I'm on the right track. Once I get my Tb showing up, I'll then bug you again :)

I have no problem loading Linux, any specific recommendations? or all of them should be compatible with Tb3? I mean, I think I have linux-mint laying somewhere around already, would that be a useful tool to test my board?

Please advise,
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
20,145
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
I'll follow your recommendation Casey,
Can I just ask you where exactly are you looking in my ioreg dump file to indicate that the Tb is not there?
I'll keep messing around with my system and I'll be testing myself if I'm on the right track. Once I get my Tb showing up, I'll then bug you again :)
Simply enter "Thunderbolt" in the search box! You'll see that there are no hits at this time.

I have no problem loading Linux, any specific recommendations? or all of them should be compatible with Tb3? I mean, I think I have linux-mint laying somewhere around already, would that be a useful tool to test my board?

Please advise,
Yes all current distributions of Linux support Thunderbolt 3. Feel free to try Ubuntu, Kubuntu, Manjaro, Arch Linux, etc.
 
Joined
Sep 27, 2017
Messages
56
Motherboard
Asus Prime X299 Deluxe
CPU
i9-7900X
Graphics
Vega 64
Mac
  1. Mac Pro
Mobile Phone
  1. Android
I think that's normal behavior of a GPU, that fact it stays quiet and sometimes ramps up means it works to my knowledge. It could be because MacOS is doing something in background since it is a new update, or simply because it uses GPU acceleration much more widely in the os. I would simply benchmark it with something heavy, like Luxmark of GFXBench and check stability at high power and temps.
I was afraid that might be the case, I might have to go back to Mojave then :( I had a completely silent system and now its really noticeable.

Thank you!
 
Joined
Apr 18, 2011
Messages
1,492
Motherboard
ASUS Pro WS X299 Sage II
CPU
i9-10980XE
Graphics
W5500
Mac
  1. MacBook Air
  2. Mac Pro
Mobile Phone
  1. iOS
Update to 11.3 public beta 6 so far so good. Hopefully my issues with the W5500 and kps get fixed sometime...

Screen Shot 2021-03-31 at 10.39.16 PM.png
 
Top