Contribute
Register

X299 Big Sur Support

Joined
Apr 18, 2011
Messages
1,354
Motherboard
ASUS ROG Rampage VI Extreme Encore
CPU
i9-7900X
Graphics
Radeon Pro W5500
Mac
  1. MacBook Air
  2. Mac Pro
Mobile Phone
  1. iOS
Thank @djlild7hina I've updated previous post with IOReg and also a OC copy without the serial numbers ;)

Just in case :

- USB Audio Device and USB Dongle are plugged on front panel.
- Mouse and Keyboard are plugged on back IO USB3 ports.
- Ultra Studio is plugged on back TB3 (onboard)
- Intuos is on back USB3
- NZTX is onboard watercooler

Cleaned up your EFI a little. You had some kgp SSDTs with the wrong ioreg location. So disabled them temporarily, you can use DeviceProperties if you want it to show up in System profile.
I also renamed the ASmedia controller to XHC2 and fixed your thunderbolt hot plug SSDT (XHC3). Try this and run USBMap again.
 

Attachments

  • OC copy.zip
    3.4 MB · Views: 21
Joined
Jul 3, 2011
Messages
144
Motherboard
Gigabyte Designare EXII
CPU
9900 XE
Graphics
Vega 64
Mac
  1. MacBook Pro
  2. Mac mini
  3. Mac Pro
Mobile Phone
  1. iOS
Cleaned up your EFI a little. You had some kgp SSDTs with the wrong ioreg location. So disabled them temporarily, you can use DeviceProperties if you want it to show up in System profile.
I also renamed the ASmedia controller to XHC2 and fixed your thunderbolt hot plug SSDT (XHC3). Try this and run USBMap again.
This is what I'm getting :

Capture d’écran 2021-02-25 à 18.10.00.png
 
Joined
Apr 17, 2012
Messages
207
Motherboard
Asus X299 Prime Deluxe
CPU
i9-7960x
Graphics
Vega 56
Has anyone successfully cranked 256gb of ram on an x299 here? And if so, what board would you recommend?
I notice the QVL for many x299 boards don't even 'support' 128gb...

Thanks in advance!
 
Joined
Feb 24, 2013
Messages
2,668
Motherboard
N/A
CPU
N/A
Graphics
N/A
Mac
  1. MacBook Air
  2. Mac Pro
Mobile Phone
  1. iOS
Has anyone successfully cranked 256gb of ram on an x299 here? And if so, what board would you recommend?
I notice the QVL for many x299 boards don't even 'support' 128gb...

Thanks in advance!
I think manufacturers abandoned X299 they’re barely updating the BIOS.

Personally haven’t tried 256 but 128 works great on my board.
 
Joined
Apr 18, 2011
Messages
1,354
Motherboard
ASUS ROG Rampage VI Extreme Encore
CPU
i9-7900X
Graphics
Radeon Pro W5500
Mac
  1. MacBook Air
  2. Mac Pro
Mobile Phone
  1. iOS
Has anyone successfully cranked 256gb of ram on an x299 here? And if so, what board would you recommend?
I notice the QVL for many x299 boards don't even 'support' 128gb...

Thanks in advance!

I think @sixsixtysix has on the deluxe II
 
Joined
Apr 18, 2011
Messages
1,354
Motherboard
ASUS ROG Rampage VI Extreme Encore
CPU
i9-7900X
Graphics
Radeon Pro W5500
Mac
  1. MacBook Air
  2. Mac Pro
Mobile Phone
  1. iOS
Hey @djlild7hina here is the new IOReg...

Hope this helps.

Try this. Didn't realize the Thunderbolt tree is different on the alpine ridge. Otherwise I'm not sure :( not as familiar with Gigabyte systems
 

Attachments

  • OC copy2.zip
    3.4 MB · Views: 24
Last edited:
Joined
Jul 3, 2011
Messages
144
Motherboard
Gigabyte Designare EXII
CPU
9900 XE
Graphics
Vega 64
Mac
  1. MacBook Pro
  2. Mac mini
  3. Mac Pro
Mobile Phone
  1. iOS
Try this. Didn't realize the Thunderbolt tree is different on the alpine ridge. Otherwise I'm not sure :( not as familiar with Gigabyte systems

Thank you for your help @djlild7hina, things seem to be a lot better (attached images)

I mapped all my used ports now and I'm at 14 which is perfect and I exported the proper USBmap.kext which is working since I don't see anymore all the other ports and XHCIportlimit is turned off.

Sleep is working thanks to this too so amazing!!!

Only problem I'm having right now is that hotplug isn't working... when I remove a USB device from the USB-C port and plug it back it doesn't show up. Same with my TB3 device... unplugging and replugging it doesn't get detected.

Bluetooth seems to be wonky too, doesn't connect to anything.

I've attached the IOReg just in case.
 

Attachments

  • Capture d’écran 2021-02-26 à 00.26.52.png
    Capture d’écran 2021-02-26 à 00.26.52.png
    495.6 KB · Views: 50
  • IOReg_iMacPro_v003.ioreg
    10 MB · Views: 16
Last edited:
Joined
Apr 18, 2011
Messages
1,354
Motherboard
ASUS ROG Rampage VI Extreme Encore
CPU
i9-7900X
Graphics
Radeon Pro W5500
Mac
  1. MacBook Air
  2. Mac Pro
Mobile Phone
  1. iOS
Thank you for your help @djlild7hina, things seem to be a lot better (attached images)

I mapped all my used ports now and I'm at 14 which is perfect and I exported the proper USBmap.kext which is working since I don't see anymore all the other ports and XHCIportlimit is turned off.

Sleep is working thanks to this too so amazing!!!

Only problem I'm having right now is that hotplug isn't working... when I remove a USB device from the USB-C port and plug it back it doesn't show up. Same with my TB3 device... unplugging and replugging it doesn't get detected.

Bluetooth seems to be wonky too, doesn't connect to anything.

I've attached the IOReg just in case.

What happens when you disable the TB3 SSDT? I found that SSDT from another designare user from a couple years ago so wasn’t sure if it would work.

Still not sure why you only had two controllers in USBMap when there should’ve been three. I renamed the Alpine Ridge one to XHC3 and the ASMedia one to XHC2
 
Last edited:
Top