Contribute
Register

X299 Big Sur Support

Joined
Jul 3, 2011
Messages
144
Motherboard
Gigabyte Designare EXII
CPU
9900 XE
Graphics
Vega 64
Mac
  1. MacBook Pro
  2. Mac mini
  3. Mac Pro
Mobile Phone
  1. iOS
Ha! I feel you buddy... in my end everything went smooth regarding DRMs / GPU / Etc. But I see you are using a Radeon VII so that might be the culprit for you. Lets see if people can share more info but the questions has been "evaded" multiple times :D.

I suspect those performance jumps are purely GPU related, which is normal since iMac Pro didn't go further than Vegas I think, Mac Pro 7,1 is based on Radeon VII kind of and iMac 19,1 more of on the 5700 XTs.

Lets wait and see.
 
Joined
Feb 26, 2011
Messages
126
Motherboard
ASUS PRIME X299-A II
CPU
i9 10940X
Graphics
AMD RX 560 | Nvidia RTX 3070
Mac
  1. MacBook
  2. MacBook Pro
Mobile Phone
  1. iOS
I do want to do some proper testing of the performance with different SMBIOS - everyone seems to have an opinion on it but no one seems to actually know what MacOS does with the SMBIOS variable. (At least no one I've met yet, anyway)

I've been tackling a different problem this weekend which sadly seems to be related to faulty hardware - but I've switched back to my MSI X299 Pro and everything is stable and running great again - with the exception of Intel Power Gadget which just crashes on launch. And that is specific to this motherboard/EFI combo, on a different board it works fine but I do want to get that working correctly before I start testing SMBIOS implementations. If nothing else to to see if there is a difference in requested frequency etc or different SMBIOS while testing. Could be interesting but need to fix this first.

Btw - I can take and make calls with this machine without issue, no KP's at all and Im using this all day everyday as my primary work machine, I take nearly every call I get through the hack.
 
Joined
Jul 15, 2012
Messages
76
Motherboard
Asus WS X299 SAGE/10G
CPU
i9-7980XE
Graphics
AMD Radeon™ RX 6900 XT
Mac
  1. iMac
Mobile Phone
  1. iOS
macOS Big Sur 11.2 Release


macOS Big Sur 11.2 improves Bluetooth reliability and fixes the following issues:


  • External displays may show a black screen when connected to a Mac mini (M1, 2020) using an HDMI to DVI converter
  • Edits to Apple ProRAW photos in the Photos app may not save
  • iCloud Drive could turn off after disabling the iCloud Drive Desktop & Documents Folders option
  • System Preferences may not unlock when entering your administrator password
  • Globe key may not display the Emoji & Symbols pane when pressed
 
Joined
Apr 18, 2011
Messages
1,325
Motherboard
ASUS ROG Z690 Extreme
CPU
Intel i9-12900k
Graphics
Radeon Pro W5500
Mac
  1. MacBook Air
  2. Mac Pro
Mobile Phone
  1. iOS
macOS Big Sur 11.2 Release


macOS Big Sur 11.2 improves Bluetooth reliability and fixes the following issues:


  • External displays may show a black screen when connected to a Mac mini (M1, 2020) using an HDMI to DVI converter
  • Edits to Apple ProRAW photos in the Photos app may not save
  • iCloud Drive could turn off after disabling the iCloud Drive Desktop & Documents Folders option
  • System Preferences may not unlock when entering your administrator password
  • Globe key may not display the Emoji & Symbols pane when pressed

Update went fine here. Build 20D64 same as RC3

Screen Shot 2021-02-01 at 1.46.29 PM.png
OpenCore 0.6.6 wont be out until tomorrow but will release a Base-EFI then
 
Joined
Jul 20, 2014
Messages
850
Motherboard
Asus ProArt B550 Creator
CPU
Ryzen 9 5900X
Graphics
RX 6800 XT
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
macOS Big Sur 11.2 Release


macOS Big Sur 11.2 improves Bluetooth reliability and fixes the following issues:


  • External displays may show a black screen when connected to a Mac mini (M1, 2020) using an HDMI to DVI converter
  • Edits to Apple ProRAW photos in the Photos app may not save
  • iCloud Drive could turn off after disabling the iCloud Drive Desktop & Documents Folders option
  • System Preferences may not unlock when entering your administrator password
  • Globe key may not display the Emoji & Symbols pane when pressed
Any news about RX 600XT driver ?
Thanks
 
Joined
Oct 6, 2019
Messages
4
Motherboard
Gigabyte Z370 Aorus Gaming 7
CPU
i7 8700
Graphics
UHD 630
Mac
  1. iMac
Hi Everybody :wave:
and thank you very much for the richness of your expertise.

Pages ago I saw the discussion about the FS "sealed : broken".
For me that's a real problem as I can't do any clone no more via Disk Utility / Restore function.
Before, with Catalina, that was possible.
Now, with Big Sur, when I try to create a clone with Disk Utility, this error message occurs : "Impossible to restore the source volume because its seal is broken". (OSStatus error 22).
Does someone has a solution ?
I'd like to continue using this Disk Utility (and not bypassing the anomaly with another cloning software).

Thank you in advance for yours answers.
Patrick
 
Joined
Jan 18, 2012
Messages
130
Motherboard
Asus WS x299 Sage/10G
CPU
i9-9980XE
Graphics
Radeon VII
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
ASUS SAGE/10G 3302 BIOS with Apple Logo Splash Screen
Released 01/15/2021

Notes from
  • Fix crash free function

New Sage 10G bios after the new one below
ASUS SAGE/10G 3301 BIOS with Apple Logo Splash Screen
Released 01/12/2021

Notes from Asus
  • Improve system performance
  • Fix SSD device compatibility


Note: With ASUS BIOS, you can save your BIOS profile on a USB Stick through the BIOS as a .CMO file and then use Bios Flashback, then restore the settings from the .CMO. One thing I noticed is sometimes with this the Above 4G doesn't get enabled so be careful as upon reboot after restoring settings you will get a black screen, and also COM Ports are never restored properly (I always have it disabled on this board). I will try to post a guide for this soon, so it makes it easier for everyone if it's interesting let me know. It's pretty easy.


I finally could update bios to v3302 and Opencore 0.6.6. (I had a stupid problem with the HDMI cable). But when i use the OpenCore Sanity Checker website, choose Skylake-X and OpenCore 0.6.6 (Latest) it says i need the next things wrong:

DevirtualiseMmio = No (Should normally be Yes)
EnableWriteUnprotector = Yes (Should normally be No)
ProtectUefiServices = Yes (Should normally be No)
RebuildAppleMemoryMap = No (Should normally be Yes)
SetupVirtualMap = No (Should normally be Yes)


If I change all of this ones, macOS doesn't boot. Are this settings OK? Should i change something? I attach my EFI folder and the Sanity Checker results just in case something's wrong.

Also, as i have same hardware as you, would you mind to share your bios settings and EFI folder, so i can double check if everything is ok?

Thanks in advance.
 

Attachments

  • EFI.zip
    9.2 MB · Views: 26
  • OpenCore config.plist Sanity Checker.pdf
    94.5 KB · Views: 204
Last edited:
Top