Contribute
Register

X299 Big Sur Support

Joined
Apr 17, 2012
Messages
206
Motherboard
Asus X299 Prime Deluxe
CPU
i9-7960x
Graphics
Vega 56
What BT/Wifi card are you using
I bought the recommended BCM chip and put it into a pcie card as prescribed back in original KGP iMac Pro era.

Now it seems to be fine after a power cycle so I am going to keep an eye on it...
 
Joined
Feb 24, 2013
Messages
2,669
Motherboard
N/A
CPU
N/A
Graphics
N/A
Mac
  1. MacBook Air
  2. Mac Pro
Mobile Phone
  1. iOS
I bought the recommended BCM chip and put it into a pcie card as prescribed back in original KGP iMac Pro era.

Now it seems to be fine after a power cycle so I am going to keep an eye on it...

There's different chipsets and some cause lag. I bought this and it solved all my problems. I went through 4 different wifi/bt cards.
 
Joined
Apr 17, 2012
Messages
206
Motherboard
Asus X299 Prime Deluxe
CPU
i9-7960x
Graphics
Vega 56
There's different chipsets and some cause lag. I bought this and it solved all my problems. I went through 4 different wifi/bt cards.
that's good to know but so pricey! Mine has worked like a charm going on 3 years. I'm wondering if it has to do with switchresx or something graphics related..
I switched back to my Vega56 SSDT from VegaFixup kext. Not entirely sure what's best on Mac Pro 7,1 with OC.

But again, the issue was exclusively the trackpad and nothing else graphically so it's quite odd.
 
Joined
Feb 21, 2016
Messages
143
Motherboard
ASRock X299E-ITX/ac
CPU
i7-7820X
Graphics
RX 6800 XT
Has anyone had random stuttering of their bluetooth magic trackpad 2?
Yes, i encountered that too.

I am using a genuine Apple-WiFi card stuffed in to the "m.2" slot of the mainboard via an adapter.
Under Catalina i had no issues but when switching to Big Sur i also switched to OC.
So i can not put the blame on either one. ;-)
I also read about similar issues on real Macs running Big Sur and some said it might be beneficial to turn of Handoff in System Preferences. I haven't tried that.
Also USB 3 Devices may cause bluetooth issues.

What fixes it for me is switching of WiFi under MacOS. As my Computer uses wired network that's no problem.
 
Joined
Apr 18, 2011
Messages
1,325
Motherboard
ASUS ROG Z690 Extreme
CPU
Intel i9-12900k
Graphics
Radeon Pro W5500
Mac
  1. MacBook Air
  2. Mac Pro
Mobile Phone
  1. iOS
Does anyone use the X299 Sage II and have the 2.5g Ethernet ports working? I assume it works OOB but wasn't sure. My board comes in next week so thought I'd prep some stuff early

Welp Sage II install was uneventful plus the 2.5 built-in ports work OOB :)
 
Joined
Jul 15, 2012
Messages
76
Motherboard
Asus WS X299 SAGE/10G
CPU
i9-7980XE
Graphics
AMD Radeon™ RX 6900 XT
Mac
  1. iMac
Mobile Phone
  1. iOS
In my hackintosh everything is fine with macOS Big Sur 11.1 except that occasionally kernel Panics occur which have also been highlighted by apple users here:



watchdog timeout: no successful checkins from com.apple.WindowServer in 120 seconds

I share my efi with you.

Regards
 

Attachments

  • EFI.zip
    8.7 MB · Views: 32
Joined
Dec 10, 2018
Messages
242
Motherboard
Asus Prime X299-A
CPU
7960X
Graphics
6900 XT
Mac
  1. MacBook Pro
  2. Mac Pro
Mobile Phone
  1. iOS
Welp Sage II install was uneventful plus the 2.5 built-in ports work OOB :)

does this run better than your old Sage build? is there anything that doesn't work? let me know how stable it is later. Thinking of changing mobo due to multiple gpus in the future.
 
Joined
Apr 18, 2011
Messages
1,325
Motherboard
ASUS ROG Z690 Extreme
CPU
Intel i9-12900k
Graphics
Radeon Pro W5500
Mac
  1. MacBook Air
  2. Mac Pro
Mobile Phone
  1. iOS
does this run better than your old Sage build? is there anything that doesn't work? let me know how stable it is later. Thinking of changing mobo due to multiple gpus in the future.

So far pretty much the same and that’s a good thing since I feel like the Sage boards are the most stable out of the bunch.

The Sage II just has some minor refreshes compared to the Sage I.
* Additional U.2 port for Cascade Lake X CPUs
* 2 2.5G ports (Supported OOB no kexts required)
* Additional RGB headers and slightly different design

I decided to get the Sage II instead of the 10G again because I still haven’t switched my home setup to 10G and I like having the additional Intel USB ports since the 10G only has 4 on the back. I can always add a 10G card later on down the line and there’s more U.2 ports that I can adapt for m.2 nvme. I bought an adapter+cable on amazon and it works fine.

@Loloflatsix and I haven't had the best luck with the Rampage Encore. We both had issues and I believe it’s working for the both of us now though. Mine worked great in the beginning but macOS wouldn’t boot after clearing my CMOS. Had to troubleshoot for a few days and it randomly worked again.

EDIT: Added my EFI with USB map.
 

Attachments

  • DJ7-ProWSX299SageII-OC065.zip
    3.1 MB · Views: 72
  • DJ7-ProWSX299SageIIUsbMapping.png
    DJ7-ProWSX299SageIIUsbMapping.png
    231.4 KB · Views: 33
Last edited:
Joined
Jan 29, 2011
Messages
97
Motherboard
Asus WS X299 Sage 10G
CPU
i9-7980XE
Graphics
RX 580
Mac
  1. Mac mini
Mobile Phone
  1. iOS
I add the EFI 0C 0.6.0 EVGA X299
Works for :
- EVGA X299 FTW-K with Bios 1.23 or newer
- For other X299 brands with no AWAC (look on your system DSDT) and Bios updated for Cascade-Lake X processors
SSDTs / ACPI :
- must be adapted according to your system
Removed :
- MLB, Serial and SMUUID : you must GenSMBIOS and edit the config.plist
Just on with an EVGA X299 Dark / 7980XE build. Only put it together last night but can't get past the OC 0.6.4 picker.

I see you have the EVGA X299 FTW-K board - thanks for posting your configs. I have a couple of questions which I hope you can help me with:

Can you tell me please if EHCI/XHCI handoff setting is available in the bios of your EVGA X299 FTW?

I had Big Sur installed on my Z390 Dark before I broke the board and the CPU (don't ask lol) - and I just can't remember if the XHCI handoff option was available in the Z390's bios. That booted perfectly though. None of my other builds will boot with XHCI handoff disabled.

Busy now creating custom ACPI's for the X299 Dark and rebuilding the EFI

Help would be much appreciated.
 
Joined
Mar 18, 2017
Messages
1,031
Motherboard
ASUS ROG Rampage VI Extreme
CPU
i9-7940X
Graphics
2 X VEGA 56
Mac
  1. iMac
  2. Mac mini
Mobile Phone
  1. iOS
Just on with an EVGA X299 Dark / 7980XE build. Only put it together last night but can't get past the OC 0.6.4 picker.

I see you have the EVGA X299 FTW-K board - thanks for posting your configs. I have a couple of questions which I hope you can help me with:

Can you tell me please if EHCI/XHCI handoff setting is available in the bios of your EVGA X299 FTW?

I had Big Sur installed on my Z390 Dark before I broke the board and the CPU (don't ask lol) - and I just can't remember if the XHCI handoff option was available in the Z390's bios. That booted perfectly though. None of my other builds will boot with XHCI handoff disabled.

Busy now creating custom ACPI's for the X299 Dark and rebuilding the EFI

Help would be much appreciated.
Here I attach my bios settings
The EVGA bios is very simple and intuitive.
My main disk is an NVMe 970 EVO and I have a USB docking station for backup with two Seagate SSDs

As this system is my workstation for my work, I never make any changes to it.

( I recently encountered several issues while setting up my new ASUS Rampage VI over the Christmas holidays and just had my system stable before working on Monday : so I recommend to be careful )




Screenshot 2021-01-07 at 21.50.05.pngScreenshot 2021-01-07 at 21.50.36.pngScreenshot 2021-01-07 at 21.51.06.pngScreenshot 2021-01-07 at 21.51.38.pngScreenshot 2021-01-07 at 21.52.29.pngScreenshot 2021-01-07 at 21.53.10.pngScreenshot 2021-01-07 at 21.54.00.pngScreenshot 2021-01-07 at 21.54.24.pngScreenshot 2021-01-07 at 21.54.40.pngScreenshot 2021-01-07 at 21.53.34.png
 
Last edited:
Top