Contribute
Register

X299 Big Sur Support

Joined
Apr 1, 2011
Messages
141
Motherboard
Asus X-299 Prime deluxe,Asus X-99 Deluxe II
CPU
i9-7980XE, Xeon E5-2696 v4
Graphics
XFX Radeon VII, Sapphire Nitro+ Radeon RX Vega 64 8GB
Mac
  1. Mac Pro
Mobile Phone
  1. iOS
Does anyone still uses a SATA Optical Drive? I have a Pioneer Blu-Ray writer connected to the Sata Port. It was running well in Catalina(Clover), but after updated to Big Sur(Opencore), the connection will dropped when the finder window is opened.... anyone face the same issue?
 
Joined
Feb 24, 2013
Messages
2,669
Motherboard
N/A
CPU
N/A
Graphics
N/A
Mac
  1. MacBook Air
  2. Mac Pro
Mobile Phone
  1. iOS
Does anyone still uses a SATA Optical Drive? I have a Pioneer Blu-Ray writer connected to the Sata Port. It was running well in Catalina(Clover), but after updated to Big Sur(Opencore), the connection will dropped when the finder window is opened.... anyone face the same issue?

probably better idea to put it in an external usb enclosure

literally no mac exists with a sata (they all use nvme, except the 2 internal sata ports in Mac Pro 2019) drive anymore and no Mac had a optical drive anymore. Apple is going to drop all these legacy drivers eventually except maybe keep stuff like external usb support for such devices
 
Joined
Apr 18, 2011
Messages
1,325
Motherboard
ASUS ROG Z690 Extreme
CPU
Intel i9-12900k
Graphics
Radeon Pro W5500
Mac
  1. MacBook Air
  2. Mac Pro
Mobile Phone
  1. iOS
Does anyone use the X299 Sage II and have the 2.5g Ethernet ports working? I assume it works OOB but wasn't sure. My board comes in next week so thought I'd prep some stuff early
 

Ellybz

Retired
Joined
Apr 16, 2017
Messages
415
Motherboard
Gigabyte X299 WU-8
CPU
I9-7980Xe
Graphics
RX 580
Mobile Phone
  1. Android
Happy New Year, Feliz año nuevo, Bonne Année, Frohes neues Jahr, Felice anno nuovo,
Feliz Ano Novo, Xīnnián kuàilè, Akemashiteomedetōgozaimasu, sanah jadiduh saeidah, S Novym Godom and to all others around the world.
May the hackintosh community live happy & keep helping each other for many years to come. :wave:

PS: Please stay safe, the vaccin is around the corner.
 
Joined
Mar 18, 2017
Messages
1,028
Motherboard
ASUS ROG Rampage VI Extreme
CPU
i9-7940X
Graphics
2 X VEGA 56
Mac
  1. iMac
  2. Mac mini
Mobile Phone
  1. iOS
Can anyone help with Shutdown > Rebooting issue?


I looked at the DSDT and it doesn't seem to work properly.

I do have a PCIe USB card and have added that as an SSDT, but still didn't work.

Code:
DefinitionBlock ("", "SSDT", 2, "Slav", "ZPTS", 0x00000000)
{
    External (_SB_.PC00.XHCI.PMEE, FieldUnitObj)
    External (ZPTS, MethodObj)    // 1 Arguments

    Method (_PTS, 1, NotSerialized)  // _PTS: Prepare To Sleep
    {
        ZPTS (Arg0)
        If ((0x05 == Arg0))
        {
            \_SB.PC00.XHCI.PMEE = Zero
        }
    }
}
I'll take a look tomorrow, also interested in a shutdown patch.
 
Joined
Apr 18, 2011
Messages
1,325
Motherboard
ASUS ROG Z690 Extreme
CPU
Intel i9-12900k
Graphics
Radeon Pro W5500
Mac
  1. MacBook Air
  2. Mac Pro
Mobile Phone
  1. iOS
I'll take a look tomorrow, also interested in a shutdown patch.

Does your rampage not shutdown? Shutdown, restart works here except sleep decided to stop working
 
Joined
Mar 18, 2017
Messages
1,028
Motherboard
ASUS ROG Rampage VI Extreme
CPU
i9-7940X
Graphics
2 X VEGA 56
Mac
  1. iMac
  2. Mac mini
Mobile Phone
  1. iOS
Does your rampage not shutdown? Shutdown, restart works here except sleep decided to stop working
Shutdown / restart not working: USBmap rechecked, I'll try later with Fixing Shutdown/Restart | OpenCore Post-Install as mentioned before, but no other problem today for about four hours of use, tomorrow I will be using it all day because the Christmas holidays are over.
I adopted MacPro 7,1 SMBIOS and I’m currently working on CustomMemory for my config.plist.
 
Last edited:
Joined
Apr 18, 2011
Messages
1,325
Motherboard
ASUS ROG Z690 Extreme
CPU
Intel i9-12900k
Graphics
Radeon Pro W5500
Mac
  1. MacBook Air
  2. Mac Pro
Mobile Phone
  1. iOS
Shutdown / restart not working: USBmap rechecked, I'll try later with Fixing Shutdown/Restart | OpenCore Post-Install as mentioned before, but no other problem today for about four hours of use, tomorrow I will be using it all day because the Christmas holidays are over.
I adopted MacPro 7,1 SMBIOS and I’m currently working on CustomMemory for my config.plist.

So weird... I don't have any issues
 
Joined
Feb 24, 2013
Messages
2,669
Motherboard
N/A
CPU
N/A
Graphics
N/A
Mac
  1. MacBook Air
  2. Mac Pro
Mobile Phone
  1. iOS
Shutdown / restart not working: USBmap rechecked, I'll try later with Fixing Shutdown/Restart | OpenCore Post-Install as mentioned before, but no other problem today for about four hours of use, tomorrow I will be using it all day because the Christmas holidays are over.
I adopted MacPro 7,1 SMBIOS and I’m currently working on CustomMemory for my config.plist.

It may be related to ASMedia controller from my research (also somewhat confirmed by Vit from OpenCore). Going to try some things on my end too. I can post my DSDT if it helps.
 
Joined
Apr 18, 2011
Messages
1,325
Motherboard
ASUS ROG Z690 Extreme
CPU
Intel i9-12900k
Graphics
Radeon Pro W5500
Mac
  1. MacBook Air
  2. Mac Pro
Mobile Phone
  1. iOS
It may be related to ASMedia controller from my research (also somewhat confirmed by Vit from OpenCore). Going to try some things on my end too. I can post my DSDT if it helps.

Do you guys have the ASmedia kext?
 

Attachments

  • ASMedia.kext.zip
    2.2 KB · Views: 41
Top