X299 Big Sur Support

Thanks for setting this up @Loloflatsix.

Running Public Beta 1 and everything works (except SideCar)

View attachment 483117

Some important notes:
1. Users that updated their BIOS to 3006 or higher on pre Cascade Lake X motherboards needed to add SSDT-AWAC.aml to boot macOS Catalina/Mojave. Same with all Cascade Lake X refresh motherboards. For Big Sur, SSDT-AWAC is replaced with SSDT-RTC0.aml since Big Sur is a lot more picky with RTC. Asus didn't map regions 0x72 and 0x73 so the SSDT-RTC0.aml adds those regions in. Like @Loloflatsix mentioned, there are two versions of SSDT-RTC0 on my github. SSDT-RTC0-NOAWAC.aml (BIOS 2002 and below) and SSDT-RTC0.aml (BIOS 3006 and higher or all Cascade Lake X motherboards).
2. OpenCore 0.6.0 is required to boot Big Sur and lilu kexts may not be compatible yet (I.E., MacProMemoryNotificationDisabler.kext). Refer to Dortania's OpenCore Guide Big Sur section for more details.

Installation Guide:
Dortania OpenCore Guide
Skylake X Section

My github will no longer be updated. Refer to post

Thunderbolt with Thunderbolt Bus support
Credits to @CaseySJ and contributors in his forum. As well as @DSM2 for releasing initial modified NVM23 firmware
View attachment 483122

Flashing guides:
Thunderbolt Firmware Files
Thunderbolt DROM Guide for Gigabyte GC-Titan Ridge

Original @kgp guides: Largely outdated due to majority of users have moved onto OpenCore and SSDT/ACPI patches are not required and are largely cosmetic. However, there is still useful information such as BIOS settings, activating Thunderbolt, and patching Intel 10G.
.Meaning you can have network support if flashed?
Do you upgraded to BIG SUR? Can EFI share? Thank you!
The main problem of my ASUS APEX motherboard and EFI is not solved
1) Power management is not perfect
2) Can't use Apple Bluetooth keyboard to wake up,
3) Sometimes the Bluetooth keyboard loses connection after restarting and waking up


    1.9 MB · Views: 91
@apfelnico found the solution for the boot issues on big sur and the error code 97.

"It seems Apple's new USB-ASMedia connection is broken. We use "ASMedia2142" on our boards, but Apple's driver is for "ASMedia3142". This driver runs first, then it doesn't run anymore on further reboots. Then the higher-level driver takes over, and it doesn't work with our chip. But the old working "AppleUSBXHCIPCI" is still in the system, which is included with Catalina. We can fix this by loading this Kext for the ASMedia controllers."
Hi, i have the problem with asmedia usb which is not working , i add in the kext folder the XHCI-unsupported kext and ASMedia kext but still no luck , on catalina was working perfectly , usb has been configured with Hackintool and before was working good . Why with Big sure the ASMedia is not working
Hi, I am looking to get sleep working with thunderbolt on my system. can anyone please help me? any help help is greatly appreciated, thanks.


  • Oston’s iMac Pro.ioreg
    8.3 MB · Views: 41
Hi, I am looking to get sleep working with thunderbolt on my system. can anyone please help me? any help help is greatly appreciated, thanks.
The guru when it comes to TB on hacks is @CaseySJ , so if you don’t get any solution here, try him :)

After much testing I think I have a reproducible method by which someone can do a fresh Big Sur install without having working NVRAM.

At least, this method is working reliably for me in my tests. I am testing a 'broken NVRAM' situation by clearing my NVRAM from the OpenCore picker after each reboot.

@rustEswan @amitbapat @oli.mathieu and anyone else with broken NVRAM, if one of you could try this method to confirm it works on a real board with no NVRAM, that would be great.

So far I have only tested this with a fresh Big Sur install. I will look at upgrades next. The same method likely also works for upgrades, but the script provided definitely won't. I hope to have news on upgrades in the next 24 hours.


Please read and follow the method carefully.

Requirements: A Big Sur install USB stick, with EFI containing OpenCore 0.6.3 DEBUG version and suitable config capable of booting and running Big Sur on your system.

In order for this preliminary method to work, you must set Target = 65 in config.plist, which will enable debug boot logging. This will create opencore-<date>.txt logfiles in the root of the EFI partition on your USB.

In order to run the script necessary for generating the required NVRAM key, you must have another macOS system available. This could be a second Hack, a real Mac, or even the same X299 Hack if you reboot to an existing install (though in this test that would also require some disk swapping, as I'd like you to do the install with no other drives plugged in).

In future I hope to provide a method that requires no second system, but for now you need to run a command line script on macOS to generate the necessary NVRAM key, which is based on data in your OpenCore logfile.

Script: Download the script from this URL. Save it somewhere you can easily run it from Terminal, eg your home directory.

  1. Find a suitable SSD on which to do a test install of macOS. I have been using a spare 120GB SSD.
  2. Remove all other SSDs/NVMe drives from the machine during the install process. This shouldn't be necessary in future, but to ensure the success of this test run and my script for generating the key, I want to be sure no other drives are present that could affect anything.
  3. Get a USB stick prepared with the Big Sur installer, and your EFI partition.
    1. Please prepare the USB stick according to the Dortania guide, using gibMacOS:
  4. The EFI partition must contain OpenCore 0.6.3 DEBUG version
  5. The config.plist must have Target = 65 set, so that debug logging will be written to the USB EFI.
  6. If you have any existing opencore-*.txt logfiles, please move or delete them, so you can be sure you know which log files were generated during the test run.
The method:
  1. Boot from USB and choose the Install Big Sur option from the USB drive.
  2. When the GUI appears, open Disk Utility.
  3. Format your target SSD as APFS / GUID. Give it any name.
  4. Now run the installation as normal.
  5. When it gets to "12 minutes remaining", the system will reboot.
  6. Let it reboot to OpenCore, but then do not select any option in the boot picker. Just get to the boot picker menu, then:
    1. We will return to it in a moment. But first we need to edit the config.plist.
    2. It is vital it does not continue automatically into step two of the install, as if it starts and fails this process, you will likely have to start from step 1 again.
  8. Take your USB stick and mount the EFI on your secondary macOS machine.
  9. Look in /Volumes/EFI and note the most recent opencore-*.txtlogfile.
    1. We want the logfile that was generated by step 6 - when you rebooted after stage 1 of the install, and then shut down the system without selecting any option.
  10. Open Terminal.
  11. Change to the directory where you downloaded my script.
  12. First we need to make it executable, run:
    1. chmod +x GenNVRAMKey.command
  13. Now run it:
    1. ./GenNVRAMKey.command
  14. It will prompt you for the location of an OpenCore logfile. You can either type in the path, or just drag and drop the file from Finder, which will paste in the path. Then hit enter.
    1. For example: /Volumes/EFI/opencore-2020-11-30-151132.txt
  15. If it has worked correctly you will be given some code to put in config.plist, as in the following screenshot
    1. View attachment 499223
  16. Open your config.plistin a text editor:
    1. Scroll down to NVRAM -> ADD -> 7C436110-AB2A-4BBB-A880-FE41995C9F82
      1. This entry should already exist in your config.plist, as it's used to supply csr-active-config, amongst others.
    2. Paste in the two lines of code given by the script, and save the file.
    3. With the lines added, file should look something like this (your data value will differ, of course):
      1. View attachment 499229
  17. Unmount your EFI, and put the USB back in the X299 system.
  18. Boot again from the USB, and continue the install by choosing "macOS Installer" from the OpenCore menu, as your normally would. It won't be the default entry, due to your broken NVRAM.
  19. If the method has been successful, you expect the next stage of the install to take 10-20+ minutes, rather than rebooting immediately as it would have done before.
  20. It will reboot 3 more times before you reach the setup screen.
  21. Note that on one or two of the later reboots you might see that the progress bar is right back to the beginning, and doesn't move at all during that stage of the process. This is OK, don't abort it; it should still complete fine. I believe the progress bar level is set by another NVRAM variable, and without this it shows the bar right at the beginning. It's just cosmetic.
  22. Once you've (hopefully) reached the setup screen and created your account and logged in, you can confirm that diskutil apfs list shows "Snapshot Sealed: Yes" (though the filesystem itself will be 'Broken', as we were talking about in recent posts), and that the OS is running fine.
  23. The NVRAM key you added (msu-product-url) can either be removed or left in config.plist - it should work identically for future updates if any require it, however Big Sur to Big Sur upgrades use a new method, based on snapshots, so it may not be needed again.

And that's it. Someone try it out and let me know if it works, and do report back if you have problems anywhere along the way.

Once it's confirmed to work on machines with real broken NVRAM, I'll start investigating the update process. And if/when I can get it working reliably for both installs and upgrades, I will contact Acidanthera and see if they'd be interested to add this method as a Quirk, to fix upgrade/install for anyone with non-working NVRAM. No guarantees they'll consider it suitable to add, but I'll have a go. At the very least, I'll look into making a Dortania guide for it in future.

But first we need to see if it works :)
@TheBloke Thank you for your great post, I have installed BS successfully. I tried to patch AICPM on my PC as well as installed many softwares, so macOS was unstable. Therefore, I decided to re-install a new BS by using the same EFI, but I could not install BS again. I still have a problem with reboot loop (please see in attach picture). I think this problem from broken NVRAM. Help me please!

P/s: my specs are dell T5600, X79, intel xeon E5-2690v1, 128Gb Ram, vga 5700xt

So, the BS 11.1 is out. Just tried upgrading directly on my nvme drive... the upgrade process seemed to run through normally, but after the restart, it's back at 11.0.1! So, this broken nvram saga continues...:mad::mad: