Contribute
Register

X299 Big Sur Support

Joined
Dec 10, 2018
Messages
242
Motherboard
Asus Prime X299-A
CPU
7960X
Graphics
6900 XT
Mac
  1. MacBook Pro
  2. Mac Pro
Mobile Phone
  1. iOS
@Junologue @oli.mathieu @shutterbug168 you guys with RX 5000 series cards, can confirm they can output multimonitor and have working DRMs (Netflix / Prime)? Do you use WEG with them? Anyone has any kind of info about Radeon Pro W5500? I'm trying to find the most compatible card out there (I don't need too much power). Originally I bought my actual Radeon VII because it was the closest to Radeon Pro Vega II MPX module, but now I have broken DRMs (with and without WEG and shikigva=128) and sometimes one of my screens (I got 3 x 4Ks via 3 x DisplaPorts) briefly goes black from time to time. In windows this doesn't occur, so I don't think it's cable or display itself damaged.

yes, my 'Asrock Radeon RX 5700 Challenger' (flashed vbios to 'RX 5700 XT Challenger')
works just fine with DRMs. Altough somewhere on the way from bigsur beta 8 to 10.0.1, a bug occured with regular videos in safari. fullscreen gives a small letterbox screen etc. But that is likely just a big sur bug.
 
Joined
Jun 13, 2018
Messages
703
Motherboard
Prime X299-A II
CPU
i9 9980XE
Graphics
RX 6800 XT
Mac
  1. iMac
  2. MacBook Pro
Classic Mac
  1. iMac
  2. Power Mac
Mobile Phone
  1. Android
  2. iOS
yes, my 'Asrock Radeon RX 5700 Challenger' (flashed vbios to 'RX 5700 XT Challenger')
works just fine with DRMs. Altough somewhere on the way from bigsur beta 8 to 10.0.1, a bug occured with regular videos in safari. fullscreen gives a small letterbox screen etc. But that is likely just a big sur bug.
We also share the same mobo :p

do you use WEG | agdpmod=pikera | shikigva=128 in any kind of combination? multi monitor? DP or HDMI?
 
Joined
Feb 26, 2011
Messages
126
Motherboard
ASUS PRIME X299-A II
CPU
i9 10940X
Graphics
AMD Radeon RX 6800 XT
Mac
  1. MacBook
  2. MacBook Pro
Mobile Phone
  1. iOS
I have a question regarding adding device properties in OC - as @Ellybz described in this post.

Is this truely just cosmestic or can it actually impact the operational function of Big Sur?

The reason I ask is that I just added some device properties to tidy up my system profiler and after reboot Big Sur fails to boot again. The thing is, it could just be coincidence that I change the device properties...

I have been having maybe every 5th or 6th boot fail, but a reboot has always sorted it.

This time im getting a lot of errors "AppleKeyStore: operation failed/unexpected session".

And then apfs_vsop events - much like when the installer was failing, which we now think is due to NVRAM not working correctly (it looks like some UEFI firmwares implement a white-listing method for preventing all but certain NVRAM variables to write) so im wondering if this failure to boot is actually related to the NVRAM issue rather than me fiddling with device properties?

@TheBloke - any joy with your NVRAM variable spoofing tests?

Edit: I should add - I have booted from a backup EFI made before the device properties changes and it is still failing with the same errors :)
 
Last edited:
Joined
Dec 10, 2018
Messages
242
Motherboard
Asus Prime X299-A
CPU
7960X
Graphics
6900 XT
Mac
  1. MacBook Pro
  2. Mac Pro
Mobile Phone
  1. iOS
We also share the same mobo :p

do you use WEG | agdpmod=pikera | shikigva=128 in any kind of combination? multi monitor? DP or HDMI?
Yup, i assisted you when going from clover to OC, if i don’t remember it wrong =)

No No & No :) Main Display/DP, Projector/HDMI
 
Joined
Dec 10, 2018
Messages
242
Motherboard
Asus Prime X299-A
CPU
7960X
Graphics
6900 XT
Mac
  1. MacBook Pro
  2. Mac Pro
Mobile Phone
  1. iOS
I have a question regarding adding device properties in OC - as @Ellybz described in this post.

Is this truely just cosmestic or can it actually impact the operational function of Big Sur?

The reason I ask is that I just added some device properties to tidy up my system profiler and after reboot Big Sur fails to boot again. The thing is, it could just be coincidence that I change the device properties...

I have been having maybe every 5th or 6th boot fail, but a reboot has always sorted it.

This time im getting a lot of errors "AppleKeyStore: operation failed/unexpected session".

And then apfs_vsop events - much like when the installer was failing, which we now think is due to NVRAM not working correctly (it looks like some UEFI firmwares implement a white-listing method for preventing all but certain NVRAM variables to write) so im wondering if this failure to boot is actually related to the NVRAM issue rather than me fiddling with device properties?

@TheBloke - any joy with your NVRAM variable spoofing tests?

Edit: I should add - I have booted from a backup EFI made before the device properties changes and it is still failing with the same errors :)

mostly cosmetical, apart from audio id’s and gpu powersettings such as fan curves, overclock etc
 
Joined
Feb 26, 2011
Messages
126
Motherboard
ASUS PRIME X299-A II
CPU
i9 10940X
Graphics
AMD Radeon RX 6800 XT
Mac
  1. MacBook
  2. MacBook Pro
Mobile Phone
  1. iOS
mostly cosmetical, apart from audio id’s and gpu powersettings such as fan curves, overclock etc
Strange - that's what I thought too...

Anyway I was getting confused about booting off my old backup EFI, I wasn't, motherboard had switched to default booting from my Big Sur disk which I'd forgotten so actually removing the Device properties has fixed it and everything works fine again.

I'll try again tomorrow adding my device properties back in one by one until it fails - potentially changing device names upset WEG or NVMefix or something - not to worry, I'll work it out and report back - cheers
 
Joined
Dec 10, 2018
Messages
242
Motherboard
Asus Prime X299-A
CPU
7960X
Graphics
6900 XT
Mac
  1. MacBook Pro
  2. Mac Pro
Mobile Phone
  1. iOS
Strange - that's what I thought too...

Anyway I was getting confused about booting off my old backup EFI, I wasn't, motherboard had switched to default booting from my Big Sur disk which I'd forgotten so actually removing the Device properties has fixed it and everything works fine again.

I'll try again tomorrow adding my device properties back in one by one until it fails - potentially changing device names upset WEG or NVMefix or something - not to worry, I'll work it out and report back - cheers

If you upload your EFI with the device properties entered, i could have a look.

or a screenshot
 
Joined
Feb 26, 2011
Messages
126
Motherboard
ASUS PRIME X299-A II
CPU
i9 10940X
Graphics
AMD Radeon RX 6800 XT
Mac
  1. MacBook
  2. MacBook Pro
Mobile Phone
  1. iOS
If you upload your EFI with the device properties entered, i could have a look.

or a screenshot
This is my first attempt at adapting these and I was thinking it was just cosmetic so go easy on me if its all over the place... ;)

Thanks!

(Serial and UUID cleaned etc)
 

Attachments

  • backup.plist
    30.7 KB · Views: 25
Joined
Apr 3, 2012
Messages
457
Motherboard
gigabyte x299x designare 10g
CPU
i9-7940X
Graphics
AMD Radeon Pro 5700 XT 8 GB
Mac
  1. iMac
  2. MacBook Air
  3. MacBook Pro
  4. Mac Pro
Mobile Phone
  1. iOS
Do you have a Working OC EFI for Catalina and big sure you could share with me? I've been using the one in the (with updated kext) op (that works fine with a little tweaking/updating) but I'm trying to update to the latest 0.6.3 and I can boot all but my clover EFI works flawlessly (minus the downsides clover bring). I have the same MB X299X GB 10G with the 5700XT. I tried your TheBloke.OpenCore.0.6.3-DEBUG.EFI.17112020, but I can't get the Big Sur install screen. It loads everything up the black screen then shut down. I'm just trying to migrate clover to OC on Catalina first, then move to getting a fully functional Big Sur... I also have your been using your bios version FC3macOSAuto. Im not a newbie at this at all its' just OC the new to me and I've stayed up the last 3 days until 5am just to get OC to work with the least 0.6.3.
Thanks in advanced bro for any help, I appreciate it fr.
 
Joined
Jan 28, 2012
Messages
62
Motherboard
Asus Rampage VI Extreme Omega
CPU
Core i9 10980XE
Graphics
Radeon 6800 XT
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
@rustEswan It really depends on what you are injecting. Yes, most of the time you inject purely cosmetic stuff. But you can also inject properties that alter stuff in a more serious way. For example you can attach informations to your GPU that will let macOS use a different framebuffer:

1606364418467.png
 
Top