Contribute
Register

X299 Big Sur Support

Joined
Apr 18, 2011
Messages
1,328
Motherboard
ASUS ROG Z690 Extreme
CPU
Intel i9-12900k
Graphics
Radeon Pro W5500
Mac
  1. MacBook Air
  2. Mac Pro
Mobile Phone
  1. iOS
Thank you, always great support.
I am currently using OC 0.6.0 and your base EFI. But i am with the 2002 bios version because i tested the new Asus bios 3203 and i have a problem: my ram, both with and without XMP, are unstable: at the moment i was unable to configure them and therefore i went back to bios 2002. With this bios i replace SSDT-RTC0.aml with SSDT-RTC0-NOAWAC.aml and rename to SSDT-RTC0.aml. Possible to update to Big Sur with these settings?

Yes that should work.
 
Joined
Dec 7, 2013
Messages
40
Motherboard
ASUS x299 Prime Deluxe
CPU
i9-7900x
Graphics
GIGABYTE RX 580 8GB
Mac
  1. iMac
@egroys and X299 Prime Deluxe owners :

Here I share my EFI OC 6.0.1 X299 Prime Deluxe : I am still with the old BIOS.

So see post #3 for new BIOS

SSDTs / ACPI :
- must be adapted according to your system
Removed :
- MLB, Rom, Serial and SMUUID : you must GenSMBIOS and edit the config.plist

View attachment 484938

Thank you for this! What BIOS are you on? Mine is 1704...so pretty old. I'm thinking of going up to 2002 maybe. Seems like MSR is still an issue though, so it makes me wary.
 
Joined
Mar 18, 2017
Messages
1,034
Motherboard
ASUS ROG Rampage VI Extreme
CPU
i9-7940X
Graphics
2 X VEGA 56
Mac
  1. iMac
  2. Mac mini
Mobile Phone
  1. iOS
Thank you for this! What BIOS are you on? Mine is 1704...so pretty old. I'm thinking of going up to 2002 maybe. Seems like MSR is still an issue though, so it makes me wary.
I am with a Bios older than yours : 1509 So it should be time to try what we have with the most recent . ...
 
Joined
Apr 17, 2012
Messages
206
Motherboard
Asus X299 Prime Deluxe
CPU
i9-7960x
Graphics
Vega 56
@egroys and X299 Prime Deluxe owners :

Here I share my EFI OC 6.0.1 X299 Prime Deluxe : I am still with the old BIOS.

So see post #3 for new BIOS

SSDTs / ACPI :
- must be adapted according to your system
Removed :
- MLB, Rom, Serial and SMUUID : you must GenSMBIOS and edit the config.plist

View attachment 484938
YOU ROCK! I will try this today. I am on BIOS 2002.
 
Joined
Dec 7, 2013
Messages
40
Motherboard
ASUS x299 Prime Deluxe
CPU
i9-7900x
Graphics
GIGABYTE RX 580 8GB
Mac
  1. iMac
I am with a Bios older than yours : 1509 So it should be time to try what we have with the most recent . ...

Seems like I'm still stuck. The alpine ridge card DOES work when the device is plugged in at boot, but no HP. I tried the EFI you posted with the card on PCIE16_3. Ioreg shows that the SSDT TB3 path is fine. Can't figure out what killed my hotplug from Clover.
 

Attachments

  • Screen Shot 2020-08-19 at 7.56.55 PM.png
    Screen Shot 2020-08-19 at 7.56.55 PM.png
    69.4 KB · Views: 35
Joined
Apr 17, 2012
Messages
206
Motherboard
Asus X299 Prime Deluxe
CPU
i9-7960x
Graphics
Vega 56
@egroys and X299 Prime Deluxe owners :

Here I share my EFI OC 6.0.1 X299 Prime Deluxe : I am still with the old BIOS.

So see post #3 for new BIOS

SSDTs / ACPI :
- must be adapted according to your system
Removed :
- MLB, Rom, Serial and SMUUID : you must GenSMBIOS and edit the config.plist

View attachment 484938
Quick question regarding your TB SSDT - I am noticing two SSDT's? Also, are you using a flashed Titan Ridge card or unflashed?

Lastly, I cannot seem to open/view your config.plist in either Propertree or OC Config.
Screen Shot 2020-08-19 at 6.18.22 PM.png

Edit: Only PlistEditorPro seems to read it... and a resave made it work in the other apps. Just a heads up for anyone looking to check the package out
 
Last edited:
Joined
Dec 7, 2013
Messages
40
Motherboard
ASUS x299 Prime Deluxe
CPU
i9-7900x
Graphics
GIGABYTE RX 580 8GB
Mac
  1. iMac
Quick question regarding your TB SSDT - I am noticing two SSDT's? Also, are you using a flashed Titan Ridge card or unflashed?

Lastly, I cannot seem to open/view your config.plist in either Propertree or OC Config.
View attachment 484983
Edit: Only PlistEditorPro seems to read it... and a resave made it work in the other apps. Just a heads up for anyone looking to check the package out

Yeah - this is a straight dl from your link as I wanted to test it against what I had. I had trouble opening the plist and was only able to read by converting via Xcode.

I am only using one card - the GC-Alpine Ridge, so not even the Titan Ridge.
 
Joined
Apr 17, 2012
Messages
206
Motherboard
Asus X299 Prime Deluxe
CPU
i9-7960x
Graphics
Vega 56
Great news! Thanks to @Loloflatsix I got my first OC boot! I need to now make sure it's stable but this is an excellent first step.

I would still would like to know if you are using a flashed TTR or not.

Thank you so much! Onward!
 
Last edited:
Joined
Mar 18, 2017
Messages
1,034
Motherboard
ASUS ROG Rampage VI Extreme
CPU
i9-7940X
Graphics
2 X VEGA 56
Mac
  1. iMac
  2. Mac mini
Mobile Phone
  1. iOS
Quick question regarding your TB SSDT - I am noticing two SSDT's? Also, are you using a flashed Titan Ridge card or unflashed?

Lastly, I cannot seem to open/view your config.plist in either Propertree or OC Config.
View attachment 484983
Edit: Only PlistEditorPro seems to read it... and a resave made it work in the other apps. Just a heads up for anyone looking to check the package out
The GC Titan Ridge I use on this build is not flashed.
I use the old method from Kgp : first SSDT for the Pcie Titan Ridge SSDT-X299-TB3HP-TTR and second SSDT for L_69 method SSDT-X299-TB3HP-TTR for better Hotplug when the TTR isn't flashed.
I use a very nice text editor : TextMate ( Google it...) : compatible with Big Sur or older and free .
 
Joined
Jul 15, 2012
Messages
77
Motherboard
Asus WS X299 SAGE/10G
CPU
i9-7980XE
Graphics
AMD Radeon™ RX 6900 XT
Mac
  1. iMac
Mobile Phone
  1. iOS
Yes, you'll need SSDT-RTC0.aml instead of SSDT-AWAC and OpenCore 0.6.0. Make sure to create a backup of Catalina and your EFI in case something happens.
Hi,
Confirmed: i did the update from Catalina to last beta of big sur a few hours ago and all is ok. Thank you!
 
Top