Contribute
Register

X1 Carbon 2017 (5th) can't install High Sierra due to the SSD PM981

Joined
Aug 31, 2017
Messages
24
Motherboard
X1 Carbon 5th
CPU
i7-7600U
Graphics
HD620
Mobile Phone
Android, iOS
Hi,@RehabMan ,I had baught the X1 Carbon 2017 (5th), and the hardware is like this,
CPU: I7-7600U
MEMORY:16G
DISPLAY:2560*1440
SSD:SAMSUNG PM981 1T

I try to install the High Sierra 10.13.2 (Sierra 10.12.6 also) to it ,but I have some problems,
1、Load clover,and the first install screen is finished but can't proceed in secend install screen,it will restart.
2、I install the High Sierra 10.13.2 into USB device at X1C 5TH by the same EFI
3、I make a copy image from the USD system and restore it into SSD, I boot it from the EFI normally.
4、The macOS in SSD pm981 works not well, it would work sometimes but fail to boot is still a nightmare.
5、When it boots sucessfully, I can use it but can't setup the office 2016 for mac, and sometimes the system would crash.
6、Maybe the SSD PM981 cause this problem, do you have any ideas to solve it? such as SSD drivers or some KEXT patches?

Thank you very much.
 
Last edited:
Joined
Jan 10, 2018
Messages
94
Motherboard
Clevo N155RF1
CPU
i7-6700HQ HM170
Graphics
HD530 GTX965M
my pm981 also have this problem.
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,717
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Hi,@RehabMan ,I had baught the X1 Carbon 2017 (5th), and the hardware is like this,
CPU: I7-7600U
MEMORY:16G
DISPLAY:2560*1440
SSD:SAMSUNG PM981 1T

I try to install the High Sierra to it ,but I have some problems,
1、Load clover,and the first install screen is finished but can progress in secend install screed,it will restart.
2、I can install the High Sierra into USB device at X1C 5TH by the same EFI
3、I make a copy image from the USD system and restore it into SSD, I can boot it from the EFI
4、But the macOS in SSD works not well, it would work sometimes but fail to boot is still a nightware.
5、When it boot sucessfully, I can use it but can setep the office 2016, and sometimes the system would crash.
6、Maybe the SSD PM981 cause this problem, do you have any ideas to solve it? such as SSD drivers or some KEXT patches?

Thank yuo very much.
Not a desktop. Moved to laptop support.

Follow the Clover guide linked from the FAQ.
http://www.tonymacx86.com/el-capitan-laptop-support/164990-faq-read-first-laptop-frequent-questions.html

Although you should read the FAQ for an overview of issues, the Clover guide is linked from the first question: "Q. Where do I start?", just after the bold face "Clover Guide".
Here is a direct link, just to be clear:
https://www.tonymacx86.com/threads/guide-booting-the-os-x-installer-on-laptops-with-clover.148093/

Also, your profile must be filled out with complete details as requested in the FAQ, again under "Q. Where do I start?". All seven details requested are equally important.

And if you have an issue (after following the guide), or on any other problem, you must provide a detailed description of the problem including information that helps us understand what you're doing. Always attach "Problem Reporting" files as per FAQ.
http://www.tonymacx86.com/el-capitan-laptop-support/164990-faq-read-first-laptop-frequent-questions.html
The required files and data are fully detailed in the last question in the FAQ:
"Q. What are typical "Problem Reporting" files?"
 
Joined
Jan 15, 2018
Messages
2
Motherboard
Ip7
CPU
i5 7300hq
Graphics
gt630
my pm981 also have this problem.
My Clover File is perfect with my Xps15 9560 before but When i install 10.13.2,the first install screen is finished and then I can go into the preboot but Progress bar does not go and it will restart. PM 981 512gb...
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,717
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Joined
Jan 10, 2018
Messages
94
Motherboard
Clevo N155RF1
CPU
i7-6700HQ HM170
Graphics
HD530 GTX965M
My Clover File is perfect with my Xps15 9560 before but When i install 10.13.2,the first install screen is finished and then I can go into the preboot but Progress bar does not go and it will restart. PM 981 512gb...
My Clover File is perfect with my Xps15 9560 before but When i install 10.13.2,the first install screen is finished and then I can go into the preboot but Progress bar does not go and it will restart. PM 981 512gb...
When I enable pm981, MacOS will suddenly restart. (I have installed macOS into other sata SSD). I can only patch acpi to disable nvme, or I can't use macOS.my macos version is 13.2.
 
Joined
Aug 31, 2017
Messages
24
Motherboard
X1 Carbon 5th
CPU
i7-7600U
Graphics
HD620
Mobile Phone
Android, iOS
When I enable pm981, MacOS will suddenly restart. (I have installed macOS into other sata SSD). I can only patch acpi to disable nvme, or I can't use macOS.my macos version is 13.2.
10.12.6 also crashed, I hv tried it.
 
Joined
Jan 15, 2018
Messages
2
Motherboard
Ip7
CPU
i5 7300hq
Graphics
gt630
When I enable pm981, MacOS will suddenly restart. (I have installed macOS into other sata SSD). I can only patch acpi to disable nvme, or I can't use macOS.my macos version is 13.2.
I have already sold it and bought a sm961 :(
 
Joined
Jan 10, 2018
Messages
94
Motherboard
Clevo N155RF1
CPU
i7-6700HQ HM170
Graphics
HD530 GTX965M
Maybe when the official version of pm981 comes out (970evo or 980evo), Samsung should solve these problems.
 
Top