Contribute
Register

[Works] Sapphire 6450 512MB full CI/QE

Status
Not open for further replies.
Joined
Aug 14, 2011
Messages
11
Motherboard
GA-H97N-WIFI
CPU
Intel Core i5-4430 3.0 GHz
Graphics
Intel HD Graphics 4600
Mac
Classic Mac
Mobile Phone
  1. iOS
  2. Other
tried all of that still no luck
 
Joined
Aug 14, 2011
Messages
11
Motherboard
GA-H97N-WIFI
CPU
Intel Core i5-4430 3.0 GHz
Graphics
Intel HD Graphics 4600
Mac
Classic Mac
Mobile Phone
  1. iOS
  2. Other

Attachments

  • Screen Shot 2012-08-30 at 9.27.30 AM.png
    Screen Shot 2012-08-30 at 9.27.30 AM.png
    101.2 KB · Views: 317
Joined
Mar 10, 2011
Messages
22
Motherboard
OS X 10.8.2
CPU
3.16 GHz Intel Core 2 Duo (E8500)
Graphics
ATI Radeon HD 6450 1024 MB Sapphire
Mac
Classic Mac
Mobile Phone
  1. iOS
After trying all the different fixes mentionned in this thread...none seemed to fix the damn generic framebuffer....until i came across a thread by BugsB somewhere saying you should add the following for ATI setups...and it worked!!!

<key>PCIRootUID</key>
<string>4</string>

It's working but still no fix for dvi issue...you have to plug in an hdmi - dvi cable as reported earlier by iba....

I'm wondering what's the best personality for this card though? currently set to Juncus as advised by claes...Juncus vs Pithecia vs duckweed vs default bulrushesany...any thoughts on that?

I'm currently on 10.8.2.
 
Joined
Sep 23, 2012
Messages
12
Motherboard
ML 10.8
CPU
I5-2500
Graphics
Sapphire Flex HD6450 1024MB
Mac
  1. iMac
Classic Mac
  1. PowerBook
Mobile Phone
  1. Android
maybe this can make some help.

i buy another one sapphire Flex HD6450 1024MB -> Official Website link

and made a framebuffer patch by myself, posted on other posts two days ago.
checkout #2 -> http://www.tonymacx86.com/graphics/71131-sapphire-6450-flex-triple-monitors.html

if u dont want make a FB fix in DSDT, then simply write below in the org.chameleon.boot.plist
Code:
<key>GraphicsEnabler</key>
<string>Yes</string>
<key>AtiConfig</key>
<string>specific framebuffer name</string>
<key>AtiPorts</key>
<string>Real port numbers</string>
 
Joined
Mar 10, 2011
Messages
22
Motherboard
OS X 10.8.2
CPU
3.16 GHz Intel Core 2 Duo (E8500)
Graphics
ATI Radeon HD 6450 1024 MB Sapphire
Mac
Classic Mac
Mobile Phone
  1. iOS
Thx "b9415017" for the feedback!!!

For my setup, graphicenabler=yes is a must, otherwise no framebuffer (HD6xxx)!, I saw yours is on Pithecia framebuffer, how does it perform? score?

Thx a lot!!!
 
Joined
Sep 23, 2012
Messages
12
Motherboard
ML 10.8
CPU
I5-2500
Graphics
Sapphire Flex HD6450 1024MB
Mac
  1. iMac
Classic Mac
  1. PowerBook
Mobile Phone
  1. Android
i didnt run any bench for that, sorry.
AND i got QE/CI, ripple wave via adding widget, after patch.

also, system identify correct type model -> HD6450 1024MB , which means i can run dvd player without error.

ohh~ i made a little mistake on my last post above about DSDT part.
framebuffer only works with GraphicsEnabler=Yes, instead of No.
 
Joined
Nov 17, 2010
Messages
58
Motherboard
Z68XP-UD4 10.6.8
CPU
i5-2500k
Graphics
ATI 6450 1GB
Mac
Classic Mac
  1. SE
Mobile Phone
  1. Android
maybe this can make some help.

i buy another one sapphire Flex HD6450 1024MB -> Official Website link

and made a framebuffer patch by myself, posted on other posts two days ago.
checkout #2 -> http://www.tonymacx86.com/graphics/71131-sapphire-6450-flex-triple-monitors.html

if u dont want make a FB fix in DSDT, then simply write below in the org.chameleon.boot.plist
Code:
<key>GraphicsEnabler</key>
<string>Yes</string>
<key>AtiConfig</key>
<string>specific framebuffer name</string>
<key>AtiPorts</key>
<string>Real port numbers</string>


It must be smbios = IMac 12,2 wo it doesn't work.
 
Joined
Sep 23, 2012
Messages
12
Motherboard
ML 10.8
CPU
I5-2500
Graphics
Sapphire Flex HD6450 1024MB
Mac
  1. iMac
Classic Mac
  1. PowerBook
Mobile Phone
  1. Android
Status
Not open for further replies.
Top