Contribute
Register

Working BCM94360NG native support for catalina VS BCM94352 DW1560

Joined
Mar 12, 2017
Messages
31
Motherboard
Dell XPS 15 7590
CPU
i7-9750H
Graphics
Intel 630 - GTX 1650
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
so, i tried many cards

DW1820A
BCM94360NG
DW1560
DW1830

all cards were a pain in some aspect, DW1830 seemed like it had hope but it didnt really fit my setup because of how wide the card is

today i finaly got BCM94360CS2 and its working like a charm, i finaly managed to get a nice 2x2 connection and aidrop transfer speeds are in the 150-200mbps range - 2GB transfer clocked at 1:40

considering i also had a netgear wifi adapter for testing purposes, i have now had to return 5 wifi cards, thank goodness thats over :)
do you use some kext to make airdrop works? I had it work in the past, then change config and now it doesn't work mmm
 
Joined
Oct 16, 2020
Messages
74
Motherboard
Thinkpad T440P
CPU
i7-4710MQ
Graphics
HD 4600
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
do you use some kext to make airdrop works? I had it work in the past, then change config and now it doesn't work mmm
for which card? i am using BCM94360CS2 and it requires no kexts.
 
Joined
Mar 12, 2017
Messages
31
Motherboard
Dell XPS 15 7590
CPU
i7-9750H
Graphics
Intel 630 - GTX 1650
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
for which card? i am using BCM94360CS2 and it requires no kexts.
ooh right, that's a different model. how did you make it fit?
 
Joined
Oct 16, 2020
Messages
74
Motherboard
Thinkpad T440P
CPU
i7-4710MQ
Graphics
HD 4600
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
ooh right, that's a different model. how did you make it fit?
i followed this guide : https://github.com/notthebee/t440p-airport

however he did it with a different card, basically you have to remove keyboard and palmrest to remove backplate and then it sits down nicely (i was suprised), you dont need to unplug cmos you can just pull it up and place it on ram to avoid annoying bios reset, i think i will try with BCM94360CS next, the 3x3 card, as this one is 2x2
 
Joined
Mar 12, 2017
Messages
31
Motherboard
Dell XPS 15 7590
CPU
i7-9750H
Graphics
Intel 630 - GTX 1650
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
all right I see, thank you :D a little bit too much for me at the moment, but it's interesting.
 
Joined
Mar 12, 2017
Messages
31
Motherboard
Dell XPS 15 7590
CPU
i7-9750H
Graphics
Intel 630 - GTX 1650
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
Btw my problems with airdrop were due to some firewall settings, not the card.
 
Joined
Nov 9, 2018
Messages
57
Motherboard
Dell XPS 9560 - YH90J
CPU
I7-7700HQ
Graphics
GTX 1050, HD 630
How did you get that to work?

I got an original DW1560 (from dell).

If I connect to my personal wifi. It’s showing 300 mbps. NSS 2

Is this a issue of my router or the card?
On my routers website it says my router can do 300+1300 mbit/s.
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
16,415
Motherboard
Gigabyte Z390 M Gaming
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
Radeon VII
Mac
  1. MacBook
  2. Mac Pro
Classic Mac
  1. iBook
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
How did you get that to work?

I got an original DW1560 (from dell).

If I connect to my personal wifi. It’s showing 300 mbps. NSS 2

Is this a issue of my router or the card?
On my routers website it says my router can do 300+1300 mbit/s.

I just installed the kexts. Didn't have to do anything special. Make sure you are connected to 5Ghz Wi-Fi for best performance.
 
Joined
Oct 16, 2020
Messages
74
Motherboard
Thinkpad T440P
CPU
i7-4710MQ
Graphics
HD 4600
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
How did you get that to work?

I got an original DW1560 (from dell).

If I connect to my personal wifi. It’s showing 300 mbps. NSS 2

Is this a issue of my router or the card?
On my routers website it says my router can do 300+1300 mbit/s.
300mbps NSS:2 would be a 40MHz 802.11 N Channel at max speed MCS7 or a 40MHz 802.11AC channel at MSC7 (MSC9 is possible on AC whereas MCS7 is max on N)

this could be occuring on 2.4GHz or 5GHz, if your on 2.4GHz i would drop the channel width to 20MHz which will drop your max rate to 150mbps but realistically your connection should be more stable (2.4GHz never worked good at 40MHz, even when you have no neighboors.

if your on 5GHz you need to make sure your on AC mode in 5GHz settings and have channel width at 80MHz
 
Joined
Nov 9, 2018
Messages
57
Motherboard
Dell XPS 9560 - YH90J
CPU
I7-7700HQ
Graphics
GTX 1050, HD 630
300mbps NSS:2 would be a 40MHz 802.11 N Channel at max speed MCS7 or a 40MHz 802.11AC channel at MSC7 (MSC9 is possible on AC whereas MCS7 is max on N)

this could be occuring on 2.4GHz or 5GHz, if your on 2.4GHz i would drop the channel width to 20MHz which will drop your max rate to 150mbps but realistically your connection should be more stable (2.4GHz never worked good at 40MHz, even when you have no neighboors.

if your on 5GHz you need to make sure your on AC mode in 5GHz settings and have channel width at 80MHz
I was on AC with 5GHz.

It kinda seems like some faulty opencore config (on my side).
After I took the one from someone else the tx rate is now up to 800+.
 
Top