Contribute
Register

[WIP-Guide] XPS 9570 Hackintosh Guide

Status
Not open for further replies.
Joined
May 27, 2019
Messages
4
Motherboard
dell xps 9570
CPU
i7-8750H
Graphics
GTX 1050 Ti + GTX 1080
Update: I switched from Bavariancake' EFI to LuletterSoul's EFI........ everything works including the gestures..... BUT I have a problem with the wifi/bluetooth card DW 1830....... sometimes when you boot up the computer, the system takes around 3 minutes to boot up and then there's no bluetooth available....... so I have to restart the computer and 'pray' that it doesn't happen again....... it could happen again, or it could boot up super fast with the DW1830 card working perfect.

I already tried his solution to fix this issue by putting tape on the pins 54 and 56, but it didn't fix the problem at all, so I still have this bluetooth/slow boot-up problem randomly.

Any solutions guys? Or maybe another EFI that really works on my dell 9570 - 1080?
 
Joined
Oct 2, 2019
Messages
1
Motherboard
Dell XPS 15 - 9570
CPU
i7-8750H
Graphics
NVIDIA GeForce GTX 1050 Ti
NOOB questions: I've read lots of things on this forum but I am still lost around something, cause there is many information to grasp.

The only thing that is missing for having Nvidia GTX 1050 ti on XPS 9570 on Mojave are the nvidia drivers or will it never be possible to use it because switched dual-GPU are not supported on hackintosh?
GTX 1050 ti also does not work 100% on XPS 9570 + High Sierra with nvidia web drivers ?

In case it only works with High Sierra, is there a guide for High Sierra like BavarianCake ? Or will everything work properly if use Bavariancake EFI but using High Sierra instead of Mojave ?
 
Last edited:
Joined
Oct 15, 2019
Messages
2
Does anyone know how to get past the HDCP error when playing DRM video? I've gotten it to start playing and I get sound, but no video.
 

Leesureone

Moderator
Joined
Feb 21, 2010
Messages
3,302
Motherboard
Asus Z690i Gaming Wifi
CPU
i9-12900K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. iOS
Just wanted to post thanks to everyone participating in this thread. My new XPS15 9570 (with the DW1560 card) using LuletterSoul's EFI and updated kexts/ clover is flawless. Could not be happier!
 

Leesureone

Moderator
Joined
Feb 21, 2010
Messages
3,302
Motherboard
Asus Z690i Gaming Wifi
CPU
i9-12900K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. iOS
https://www.tonymacx86.com/threads/wip-guide-xps-9570-hackintosh-guide.259844



What kexts/patches are you using specifically to get Thunderbolt 3 working? I recently set up my 9750 (i7 model) but I can't seem to get TB3 devices or USB-C docks to work, hot-plug or at boot Thanks.
I have an external Thunderbolt 2 Hard Drive I connect to using an Apple Thunderbolt 2 to 3 adapter and it works fine, can't attest to other devices and I should probably try USB c. Thunderbolt is natively supported, if it isn't working check your bios settings. Go to System Configuration/ Thunderbolt Adapter Configuration and check the "No Security" box. It should work, let us know.
 
Last edited:
Joined
Nov 10, 2013
Messages
22
Motherboard
Dell XPS 9570
CPU
i7-8750H
Graphics
UHD 630 / GTX 1050 Ti
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. iOS
Is anyone experiencing any graphics glitches in Catalina 10.15.2? I'm on bavariancake's EFI and I sometimes get very dim screen at boot with periodic black screen.

Good to know, I'll hold up with the upgrade then. Perhaps filing an issue on the repository on github may be a good ide ato keep track of progress. Thanks for the heads up.
 
Joined
Jul 9, 2016
Messages
41
Motherboard
Dell XPS 15 9570
CPU
i7 8750H
Graphics
UHD 630/1050Ti, 3840x2160
Has anyone else run into the problem where boot stalls at gIOScreenLockState 3 using bravariancake's EFI? I know from searching this site it's a graphics problem, but I can't figure out why I'm getting it with this EFI. I thought it was already configured to use the Intel graphics and disable the Nvidia graphics. Screen shot attached for what it's worth. I'm on Catalina 15.2

20200126_104344.jpg
 

Leesureone

Moderator
Joined
Feb 21, 2010
Messages
3,302
Motherboard
Asus Z690i Gaming Wifi
CPU
i9-12900K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. iOS
Has anyone else run into the problem where boot stalls at gIOScreenLockState 3 using bravariancake's EFI? I know from searching this site it's a graphics problem, but I can't figure out why I'm getting it with this EFI. I thought it was already configured to use the Intel graphics and disable the Nvidia graphics. Screen shot attached for what it's worth. I'm on Catalina 15.2

View attachment 446806
Catalina can require updated kexts, do you have the latest versions? The ones in the EFI folder are 6 months old. If not update WEG and Lilu in your USB EFI folder and try again.
 
Last edited:
Joined
Jul 9, 2016
Messages
41
Motherboard
Dell XPS 15 9570
CPU
i7 8750H
Graphics
UHD 630/1050Ti, 3840x2160
Catalina can require updated kexts, do you have the latest versions? The ones in the EFI folder are 6 months old. If not update WEG and Lilu in your USB EFI folder and try again.
Yep, I made sure I have the latest version of all the kexts.
 
Status
Not open for further replies.
Top