Contribute
Register

[WIP-Guide] XPS 9570 Hackintosh Guide

Joined
May 10, 2019
Messages
6
Motherboard
Dell 0D0T05 A00
CPU
Intel Core i7-8750H
Graphics
Nvidia GTX 1050Ti with Max-Q
Hi There, Brand New as of today. I'm attempting to install Mojave on my XPS 9570, bios version 1.10, i7-8570h, 8gb, 256gb Toshiba, GTX 1050ti, 1080p. I swapped out the Killer Wireless for an Intel 9260 No Vpro. I followed the Mojave guide and was able to create the boot disk with Unibeast. Now I guess the next step is to try installing it on the dell. I've seen several different guides here and found 2-3 different Posts on github that look promising, but I don't know what to edit to match my system config or really how to proceed. Do I replace the EFI folder on my boot disk with the one I want to use This is the one i have in mind. I know most of you have put a lot of time and energy into learning this process and it's taken a lot trial and error. I'm just kind of lost and hope one of you can point me in the right direction.I've attached screens of the boot disk I made and the EFI i'd like to use.
 

Attachments

Feartech

Moderator
Joined
Aug 3, 2013
Messages
12,920
Motherboard
Asus N752VX-Clover
CPU
i7-6700HQ / HM170
Graphics
HD530 + GTX 950m 1920 x 1080
Mac
iMac
Mobile Phone
iOS
Hi There, Brand New as of today. I'm attempting to install Mojave on my XPS 9570, bios version 1.10, i7-8570h, 8gb, 256gb Toshiba, GTX 1050ti, 1080p. I swapped out the Killer Wireless for an Intel 9260 No Vpro. I followed the Mojave guide and was able to create the boot disk with Unibeast. Now I guess the next step is to try installing it on the dell. I've seen several different guides here and found 2-3 different Posts on github that look promising, but I don't know what to edit to match my system config or really how to proceed. Do I replace the EFI folder on my boot disk with the one I want to use This is the one i have in mind. I know most of you have put a lot of time and energy into learning this process and it's taken a lot trial and error. I'm just kind of lost and hope one of you can point me in the right direction.I've attached screens of the boot disk I made and the EFI i'd like to use.
Intel Wifi is not supported on macs
 
Joined
May 10, 2019
Messages
6
Motherboard
Dell 0D0T05 A00
CPU
Intel Core i7-8750H
Graphics
Nvidia GTX 1050Ti with Max-Q
Intel Wifi is not supported on macs
Would that cause my install to keep rebooting during install? I managed to get unibeast loaded and each time I try to install even verbatim it loads halfway and then boot cycles
 

Feartech

Moderator
Joined
Aug 3, 2013
Messages
12,920
Motherboard
Asus N752VX-Clover
CPU
i7-6700HQ / HM170
Graphics
HD530 + GTX 950m 1920 x 1080
Mac
iMac
Mobile Phone
iOS
Would that cause my install to keep rebooting during install? I managed to get unibeast loaded and each time I try to install even verbatim it loads halfway and then boot cycles
not really

Link to laptop guide:
 
Joined
Jul 9, 2016
Messages
37
Motherboard
Gigabyte z390 M Gaming
CPU
i5 9600k
Graphics
RX 560
Anyone have issues doing a straight update from 10.14.3 to 10.14.4?
Have you figured out how to update? I've been trying to update from 10.14.2 to 10.14.4 and can't get it to work. It hangs on ACPICPU timeouts. I updated Clover to the latest version along with Lilu ,Whatevergreen and AppleALC kexts which seemed to help some people, but didn't fix the problem for me.
 
Joined
Jan 25, 2019
Messages
6
Motherboard
Gigabyte Aorus Master
CPU
i9 9900K
This might be a little bit of a basic question, but I've got an i9 8950hk 1080 xps 15 9570 working great, but somewhere along the way I think I set the processor incorrectly since system report is showing that I'm running an i7 at a base freq of 2.9; when I think it should display i9 at 2.9. Using macbook pro 15,1 model identifier. It's showing 6 cores and running stable, with a geekbench 4 single core score of around 5000.... Got a little higher in windows. Is there something I should change to improve speed/efficiency? I've been experimenting with undervolting via voltageshift. Running mojave 10.14.2 Any help appreciated. I've attached my EFI just in case it's helpful to anyone out there. (Working sleep, usb, hdmi, thunderbolt when plugged in at boot usbc, sound, graphic acceleration, trackpad gestures. Not working sd card reader, brightness buttons on keyboard, thunderbolt hotswap) Thanks
Hi - looking at getting the i9 9570 and seems that you have a decent, stable system running. Did you follow any particular guide to start with? Haven't seen any other 9570 i9 hacks out there so really appreciate you also posting your EFI.
Thanks
 
Joined
Aug 4, 2018
Messages
30
Motherboard
Dell XPS 15 9570
CPU
i9-8950HK/CM246
Graphics
UHD 630/1050Ti, 3840x2160
Mac
MacBook Pro
Mobile Phone
iOS
Have you figured out how to update? I've been trying to update from 10.14.2 to 10.14.4 and can't get it to work. It hangs on ACPICPU timeouts. I updated Clover to the latest version along with Lilu ,Whatevergreen and AppleALC kexts which seemed to help some people, but didn't fix the problem for me.
You may have to wait quite a while to get past those timeouts - like 2 hours to be sure. I think the 10.14.4 update took about an hour on my system.
 
Joined
Aug 4, 2018
Messages
30
Motherboard
Dell XPS 15 9570
CPU
i9-8950HK/CM246
Graphics
UHD 630/1050Ti, 3840x2160
Mac
MacBook Pro
Mobile Phone
iOS
Hi - looking at getting the i9 9570 and seems that you have a decent, stable system running. Did you follow any particular guide to start with? Haven't seen any other 9570 i9 hacks out there so really appreciate you also posting your EFI.
Thanks
I'm using an i9 on the 9570 and it's working pretty well. No issues related to the CPU, although I believe the max. turbo frequency could be higher. Not really an issue for me, however.

 
Joined
Jan 25, 2019
Messages
6
Motherboard
Gigabyte Aorus Master
CPU
i9 9900K
I'm using an i9 on the 9570 and it's working pretty well. No issues related to the CPU, although I believe the max. turbo frequency could be higher. Not really an issue for me, however.

Wicked - many thanks indeed
 
Joined
Apr 30, 2019
Messages
2
Motherboard
dell xps 9570
CPU
8th gen intel i7
Graphics
gtx 1050ti
411727


I do not know the cause of the error code
 
Top