Contribute
Register

WIN10 partition won't boot in OpenCore but boots fine through BIOS

Joined
Sep 19, 2017
Messages
81
Motherboard
ASUS Maximus IX Hero
CPU
i7 7700k
Graphics
GTX 1060
Mac
  1. iMac
  2. MacBook
  3. MacBook Pro
  4. Mac mini
  5. Mac Pro
Mobile Phone
  1. iOS
Hi all,

Have finished migrating from Clover to OpenCore and upgrading from Mojave to Big Sur. I had a Windows 10 partition which was booting fine with Clover/Mojave and still does if I select it in the BIOS boot screen.

In OpenCore, even though it shows up as an option, it brings up a recovery screen similar to the attachment, asking to repair the drive. The options there don't do much and I don't want to mess with the Windows EFI as it still works through BIOS.

Are there any settings I need to change within OpenCore after initial setup for it to be able to boot the WIN10 drive? It kind of defeats the purpose of the whole setup if I have to change boot drives in BIOS every time I need to change OS.

Any ideas welcome. Thanks!
 

Attachments

  • external-content.duckduckgo.png
    external-content.duckduckgo.png
    259.9 KB · Views: 12
Last edited:
Joined
Jul 25, 2015
Messages
16
Motherboard
GA97
CPU
i3-4330
Graphics
Sapphire Pulse Radeon RX550 (spoofed to 0x67FF)
Hi there!

Same problem here, but even more troubling.
My OC 6.8 was working flawlessly (Win10, BigSur, various linux distros), as were previous installs (starting with OC6.4).
I changed my PC box (the former had short circuits which I wasn't able to pinpoint).

Most probably, the sata plugs have been re-plugged in different places.

Anyway, everything boots fine but win10. I get the circling dots then a black screen. Upon 3rd reboot, Win ME offers the option to repair. Boot repait doesn't work.

Did a BIOS reset, Nvram reset : to no avail.

I'm at a loss, here..
 
Joined
Jul 25, 2015
Messages
16
Motherboard
GA97
CPU
i3-4330
Graphics
Sapphire Pulse Radeon RX550 (spoofed to 0x67FF)
I'm back, with a working solution : disable windows fast boot.
I previously disabled fast boot (for whatever reasons) and did not isable this option on my new install.
With fast boot enabled, the boot process somehow got entangled in nowhere space.

Voilà!
 
Top