Contribute
Register

Will there be better fermi GPU support in mt lion??

Status
Not open for further replies.
Joined
Jun 19, 2012
Messages
79
Motherboard
Intel DZ68DB
CPU
i5 2500K
Graphics
GTX 560 SC
Mac
  1. MacBook
  2. Mac mini
Classic Mac
Mobile Phone
Hay, I am wondering if Mountain Lion will have better drivers for fermi cards. I have a GTX 560 and its lags opening launchpad but once I open it a few more times it becomes smooth again. I am also wondering this because it seems like apple is switching back to nvidia.
 

MacMan

Administrator
Staff member
Joined
Feb 2, 2010
Messages
7,988
Motherboard
ASUS TUF Z390-PRO GAMING - 2606 - UEFI
CPU
i9-9900K
Graphics
Vega 64
Mac
  1. MacBook Pro
  2. Mac Pro
Classic Mac
  1. Power Mac
  2. PowerBook
Mobile Phone
  1. iOS
Joined
Jun 19, 2012
Messages
79
Motherboard
Intel DZ68DB
CPU
i5 2500K
Graphics
GTX 560 SC
Mac
  1. MacBook
  2. Mac mini
Classic Mac
Mobile Phone
I have tried changing my system definition to pro 5.1 and IMac 12.1 currently im using Pro 3.1, the NVIDIA 4xx/5xx support in Multibeast, and the CUDA and GeForce drivers from Nvidia's site. Also sometimes when I wake the computer up It only displays static like an old analog tv without signal. Do you have any suggestions to try? If I cant get it working I think I should just try upgrading to Mt Lion and see how it works. How did you enable yours?

Thank You.
 

MacMan

Administrator
Staff member
Joined
Feb 2, 2010
Messages
7,988
Motherboard
ASUS TUF Z390-PRO GAMING - 2606 - UEFI
CPU
i9-9900K
Graphics
Vega 64
Mac
  1. MacBook Pro
  2. Mac Pro
Classic Mac
  1. Power Mac
  2. PowerBook
Mobile Phone
  1. iOS
OS X 10.7.4 Combo Update
OpenCL Enabler for 10.7.2+
MacPro3,1

Mountain Lion hasn't been released yet so any changes in Fermi support is unknown at this time.
 
Joined
Jun 21, 2011
Messages
182
Motherboard
ASUS Z97 Deluxe
CPU
Core i7 4790K
Graphics
Sapphire RX580 8GB
Classic Mac
  1. Power Mac
Mobile Phone
  1. iOS
I had that problem and the seemed to disappear after installing the sotck nVidia drivers. It says it is only good for the GTX285 but seems to run fine with my GTX580.
 
Joined
Jun 19, 2012
Messages
79
Motherboard
Intel DZ68DB
CPU
i5 2500K
Graphics
GTX 560 SC
Mac
  1. MacBook
  2. Mac mini
Classic Mac
Mobile Phone
It wont let me install it. It says "This computer will not support GeForce or Quadro Mac OS X edition cards." I tried both IMac and Mac Pro system definitions.
 
Joined
Jun 21, 2011
Messages
182
Motherboard
ASUS Z97 Deluxe
CPU
Core i7 4790K
Graphics
Sapphire RX580 8GB
Classic Mac
  1. Power Mac
Mobile Phone
  1. iOS
Thats strange. I used the driver multiple times without issue. I had the exact same problem as you even after following the instructions Macman posted. I may not have noticed it except I had moved from a 6870 and that opened the menu much smoother. Using the nVidia driver made it work much better. I am not sure why you cannot install.
 
Joined
Jul 8, 2012
Messages
66
Motherboard
Intel DH55TC
CPU
Intel Core i7-870
Graphics
Gigabyte 550ti OC
Mac
  1. iMac
  2. MacBook Air
Mobile Phone
  1. Android
cinebonh842 said:
Hay, I am wondering if Mountain Lion will have better drivers for fermi cards. I have a GTX 560 and its lags opening launchpad but once I open it a few more times it becomes smooth again. I am also wondering this because it seems like apple is switching back to nvidia.
Add your devid to AppleGraphicsPowerManagement.kext (I have a 550ti, it fixed my lag):
viewtopic.php?f=15&t=64509&start=10
And change systemid to imac 12,1.
 
Joined
Jun 19, 2012
Messages
79
Motherboard
Intel DZ68DB
CPU
i5 2500K
Graphics
GTX 560 SC
Mac
  1. MacBook
  2. Mac mini
Classic Mac
Mobile Phone
I did add my device Id to the AGPM and it's a lot smother but its still is a bit lagy unless I have something like iPhoto or iMovie open. Then it's perfectly smooth. Tho only other thing is that the GPU stays at about 135°F witch is way to hot when I'm not doing anything. I'm hoping maybe mountain lion will fix this.
 
Joined
Jul 8, 2012
Messages
66
Motherboard
Intel DH55TC
CPU
Intel Core i7-870
Graphics
Gigabyte 550ti OC
Mac
  1. iMac
  2. MacBook Air
Mobile Phone
  1. Android
cinebonh842 said:
I did add my device Id to the AGPM and it's a lot smother but its still is a bit lagy unless I have something like iPhoto or iMovie open. Then it's perfectly smooth. Tho only other thing is that the GPU stays at about 135°F witch is way to hot when I'm not doing anything. I'm hoping maybe mountain lion will fix this.
Strange, everything works beautifully on my 550ti, absolutely nothing lags.
Also, what are you using to monitor your temps?
TempMonitor and iStat have been known to mess up Fermi temps. My 550ti idles at 40 degrees C (monitored using speccy on windows)
 
Status
Not open for further replies.
Top