Contribute
Register

Wifi not working on AR9565

Status
Not open for further replies.
Joined
Jun 30, 2016
Messages
9
So i successfully install macos 10.13 but the wifi scanning dosent work. I used all the AR9565 kext files around the web but still nothing. Can anyone help me out please?
 
Hi,

I'm facing the same situation here. I really appreciate the work and collaboration of this community, as it allowed me to successfully run a hack on a Dell Inspiron 15 3567. It has an Intel i5 7200u CPU + Intel HD Graphics 620, and is running 10.13.3, seamlessly with keyboard, trackpad, ACPIbattery, audio, etc. by using all latest versions of Rehabman's kexts, and the RTL8100 v2 for LAN.

Both the BT and WiFi cards are recognized (DW 1707 / Atheros 9565 with ID (0x168C, 0x36)). However, nothing comes up in the scans. I've seen that's expected for BT, as I would need to run a VM with Linux or Windows to load the firmware. But I'm puzzled with WiFi.

The -ath9565 flag is in the boot args, and I've tried several versions of Lilu (1.2.1, 1.2.2) and ath9fixup (chunnann, black-dragon74, and currentylt Rehabman's). Both with and without changing the "AirPortAtheros40.kext" v21 for OS 10.13, and with just ATH9KFixup or ATHFixup and Injector. I even tried the package that deploys hacked versions of corecapture.kext and CoreCaptureResponder.kext. Always into /S/L/E, not Clover kext folder.

Just in case, I was also always reverting to stock kexts / configuration & cleaning cache before and after trying the next iteration.

It seems to me that the install instructions are not clear, or it is required to make some additional modifications to DSDTs or Clover's config.list, besides deploying the

Can you please enlighten me on all the required steps to get WiFi working on 10.13.3 ? Are both ATHFixup and Injector needed, or just ATHFixup ? Is any configuration / edition needed on the Info.plist files ? Or Clover, or DSDTs? Can Lilu v1.2.2 be used safely with this, or a previous version is required (not many options with 10.13.3, though) ? Is it also required to deploy the custom "AirPortAtheros40.kext" v21 from this post or not:

http://www.insanelymac.com/forum/to...ver-os-x-101112-for-unsupported-cards/page-21

Thanks a lot in advance for your help !

Software Versions:
CoreWLAN: 13.0 (1339)
CoreWLANKit: 13.0 (1339)
Menu Extra: 13.0 (1345)
System Information: 12.0 (1300.1)
IO80211 Family: 12.0 (1200.12.2)
Diagnostics: 1.0 (805)
AirPort Utility: 6.3.8 (638.5)
Interfaces:
en1:
Card Type: AirPort Extreme (0x168C, 0x20E)
Firmware Version: Atheros 9565: 4.0.74.0-P2P
MAC Address: <hidden>
Locale: FCC
Country Code:
Supported PHY Modes: 802.11 a/b/g/n
Supported Channels: 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13
Wake On Wireless: Supported
AirDrop: Supported
Status: Not Associated

Adding Bluetooth System Info:

Apple Bluetooth Software Version: 6.0.2f2
Hardware, Features, and Settings:
Name: MacBook Pro
Address: <Hidden>
Bluetooth Low Energy Supported: Yes
Handoff Supported: No
Instant Hot Spot Supported: No
Manufacturer: Qualcomm Atheros
Transport: USB
Firmware Version: 6.12545 (6.1)
Bluetooth Power: On
Discoverable: Off
Connectable: No
Auto Seek Pointing: On
Remote wake: On
Vendor ID: 0x0CF3
Product ID: 0xE005
HCI Version: 4.0 (0x6)
HCI Revision: 0x3101
LMP Version: 4.0 (0x6)
LMP Subversion: 0x01
Device Type (Major): Computer
Device Type (Complete): Mac Portable
Composite Class Of Device: 0x38010C
Device Class (Major): 0x01
Device Class (Minor): 0x03
Service Class: 0x1C0
Auto Seek Keyboard: On
Services:
Bluetooth File Transfer:
Folder other devices can browse: ~/Public
When receiving items: Accept all without warning
State: Disabled
Bluetooth File Exchange:
Folder for accepted items: ~/Downloads
When other items are accepted: Save to location
When receiving items: Accept all without warning
State: Disabled
Bluetooth Internet Sharing:
State: Disabled
Incoming Serial Ports:
Bluetooth-Incoming-Port:
RFCOMM Channel: 3
Requires Authentication: No
 
Last edited:
Hi,

I'm facing the same situation here. I really appreciate the work and collaboration of this community, as it allowed me to successfully run a hack on a Dell Inspiron 15 3567. It has an Intel i5 7200u CPU + Intel HD Graphics 620, and is running 10.13.3, seamlessly with keyboard, trackpad, ACPIbattery, audio, etc. by using all latest versions of Rehabman's kexts, and the RTL8100 v2 for LAN.

Both the BT and WiFi cards are recognized (DW 1707 / Atheros 9565 with ID (0x168C, 0x36)). However, nothing comes up in the scans. I've seen that's expected for BT, as I would need to run a VM with Linux or Windows to load the firmware. But I'm puzzled with WiFi.

The -ath9565 flag is in the boot args, and I've tried several versions of Lilu (1.2.1, 1.2.2) and ath9fixup (chunnann, black-dragon74, and currentylt Rehabman's). Both with and without changing the "AirPortAtheros40.kext" v21 for OS 10.13, and with just ATH9KFixup or ATHFixup and Injector. I even tried the package that deploys hacked versions of corecapture.kext and CoreCaptureResponder.kext. Always into /S/L/E, not Clover kext folder.

Just in case, I was also always reverting to stock kexts / configuration & cleaning cache before and after trying the next iteration.

It seems to me that the install instructions are not clear, or it is required to make some additional modifications to DSDTs or Clover's config.list, besides deploying the

Can you please enlighten me on all the required steps to get WiFi working on 10.13.3 ? Are both ATHFixup and Injector needed, or just ATHFixup ? Is any configuration / edition needed on the Info.plist files ? Or Clover, or DSDTs? Can Lilu v1.2.2 be used safely with this, or a previous version is required (not many options with 10.13.3, though) ? Is it also required to deploy the custom "AirPortAtheros40.kext" v21 from this post or not:

http://www.insanelymac.com/forum/to...ver-os-x-101112-for-unsupported-cards/page-21

Thanks a lot in advance for your help !

Software Versions:
CoreWLAN: 13.0 (1339)
CoreWLANKit: 13.0 (1339)
Menu Extra: 13.0 (1345)
System Information: 12.0 (1300.1)
IO80211 Family: 12.0 (1200.12.2)
Diagnostics: 1.0 (805)
AirPort Utility: 6.3.8 (638.5)
Interfaces:
en1:
Card Type: AirPort Extreme (0x168C, 0x20E)
Firmware Version: Atheros 9565: 4.0.74.0-P2P
MAC Address: <hidden>
Locale: FCC
Country Code:
Supported PHY Modes: 802.11 a/b/g/n
Supported Channels: 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13
Wake On Wireless: Supported
AirDrop: Supported
Status: Not Associated

Adding Bluetooth System Info:

Apple Bluetooth Software Version: 6.0.2f2
Hardware, Features, and Settings:
Name: MacBook Pro
Address: <Hidden>
Bluetooth Low Energy Supported: Yes
Handoff Supported: No
Instant Hot Spot Supported: No
Manufacturer: Qualcomm Atheros
Transport: USB
Firmware Version: 6.12545 (6.1)
Bluetooth Power: On
Discoverable: Off
Connectable: No
Auto Seek Pointing: On
Remote wake: On
Vendor ID: 0x0CF3
Product ID: 0xE005
HCI Version: 4.0 (0x6)
HCI Revision: 0x3101
LMP Version: 4.0 (0x6)
LMP Subversion: 0x01
Device Type (Major): Computer
Device Type (Complete): Mac Portable
Composite Class Of Device: 0x38010C
Device Class (Major): 0x01
Device Class (Minor): 0x03
Service Class: 0x1C0
Auto Seek Keyboard: On
Services:
Bluetooth File Transfer:
Folder other devices can browse: ~/Public
When receiving items: Accept all without warning
State: Disabled
Bluetooth File Exchange:
Folder for accepted items: ~/Downloads
When other items are accepted: Save to location
When receiving items: Accept all without warning
State: Disabled
Bluetooth Internet Sharing:
State: Disabled
Incoming Serial Ports:
Bluetooth-Incoming-Port:
RFCOMM Channel: 3
Requires Authentication: No
As per rules, please update your hardware profile to allow others to help you easier
https://www.tonymacx86.com/account/
 
Hi,

I'm facing the same situation here. I really appreciate the work and collaboration of this community, as it allowed me to successfully run a hack on a Dell Inspiron 15 3567. It has an Intel i5 7200u CPU + Intel HD Graphics 620, and is running 10.13.3, seamlessly with keyboard, trackpad, ACPIbattery, audio, etc. by using all latest versions of Rehabman's kexts, and the RTL8100 v2 for LAN.

Both the BT and WiFi cards are recognized (DW 1707 / Atheros 9565 with ID (0x168C, 0x36)). However, nothing comes up in the scans. I've seen that's expected for BT, as I would need to run a VM with Linux or Windows to load the firmware. But I'm puzzled with WiFi.

The -ath9565 flag is in the boot args, and I've tried several versions of Lilu (1.2.1, 1.2.2) and ath9fixup (chunnann, black-dragon74, and currentylt Rehabman's). Both with and without changing the "AirPortAtheros40.kext" v21 for OS 10.13, and with just ATH9KFixup or ATHFixup and Injector. I even tried the package that deploys hacked versions of corecapture.kext and CoreCaptureResponder.kext. Always into /S/L/E, not Clover kext folder.

Just in case, I was also always reverting to stock kexts / configuration & cleaning cache before and after trying the next iteration.

It seems to me that the install instructions are not clear, or it is required to make some additional modifications to DSDTs or Clover's config.list, besides deploying the

Can you please enlighten me on all the required steps to get WiFi working on 10.13.3 ? Are both ATHFixup and Injector needed, or just ATHFixup ? Is any configuration / edition needed on the Info.plist files ? Or Clover, or DSDTs? Can Lilu v1.2.2 be used safely with this, or a previous version is required (not many options with 10.13.3, though) ? Is it also required to deploy the custom "AirPortAtheros40.kext" v21 from this post or not:

http://www.insanelymac.com/forum/to...ver-os-x-101112-for-unsupported-cards/page-21

Thanks a lot in advance for your help !

Software Versions:
CoreWLAN: 13.0 (1339)
CoreWLANKit: 13.0 (1339)
Menu Extra: 13.0 (1345)
System Information: 12.0 (1300.1)
IO80211 Family: 12.0 (1200.12.2)
Diagnostics: 1.0 (805)
AirPort Utility: 6.3.8 (638.5)
Interfaces:
en1:
Card Type: AirPort Extreme (0x168C, 0x20E)
Firmware Version: Atheros 9565: 4.0.74.0-P2P
MAC Address: <hidden>
Locale: FCC
Country Code:
Supported PHY Modes: 802.11 a/b/g/n
Supported Channels: 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13
Wake On Wireless: Supported
AirDrop: Supported
Status: Not Associated

Adding Bluetooth System Info:

Apple Bluetooth Software Version: 6.0.2f2
Hardware, Features, and Settings:
Name: MacBook Pro
Address: <Hidden>
Bluetooth Low Energy Supported: Yes
Handoff Supported: No
Instant Hot Spot Supported: No
Manufacturer: Qualcomm Atheros
Transport: USB
Firmware Version: 6.12545 (6.1)
Bluetooth Power: On
Discoverable: Off
Connectable: No
Auto Seek Pointing: On
Remote wake: On
Vendor ID: 0x0CF3
Product ID: 0xE005
HCI Version: 4.0 (0x6)
HCI Revision: 0x3101
LMP Version: 4.0 (0x6)
LMP Subversion: 0x01
Device Type (Major): Computer
Device Type (Complete): Mac Portable
Composite Class Of Device: 0x38010C
Device Class (Major): 0x01
Device Class (Minor): 0x03
Service Class: 0x1C0
Auto Seek Keyboard: On
Services:
Bluetooth File Transfer:
Folder other devices can browse: ~/Public
When receiving items: Accept all without warning
State: Disabled
Bluetooth File Exchange:
Folder for accepted items: ~/Downloads
When other items are accepted: Save to location
When receiving items: Accept all without warning
State: Disabled
Bluetooth Internet Sharing:
State: Disabled
Incoming Serial Ports:
Bluetooth-Incoming-Port:
RFCOMM Channel: 3
Requires Authentication: No

I would suggest installing supported Broadcom WiFi hardware instead:
https://www.tonymacx86.com/threads/faq-read-first-laptop-frequent-questions.164990/

Otherwise, read the documentation provided by ATH9kFixup.kext on github.
 
I would suggest installing supported Broadcom WiFi hardware instead:
https://www.tonymacx86.com/threads/faq-read-first-laptop-frequent-questions.164990/

Otherwise, read the documentation provided by ATH9kFixup.kext on github.

Hi Rehabman,

Thanks a lot for taking the time to respond. I will be ordering a supported Broadcom WiFi NGFF card, but I was first trying to make the original one that came OTB work. In relation to Broadcom: I've read Apple branded BCM94360's work OTB, without customization. Are these compatible with Dell laptops ? Just asking cause some brands set blocks on other brands' HW.

It puzzles me that others are able to make the ATH 9565 work, so wondering what is it that I may be doing wrong here with Clover configuration, or elsewhere. Will post logs soon, but it calls my attention that System Information reports:

Card Type: AirPort Extreme (0x168C, 0x20E)
Firmware Version: Atheros 9565: 4.0.74.0-P2P

when the actual PCI IDs are (0x168C, 0x36)

Over past days, I cleaned everything up, restored all original kexts, removed any leftovers, and started all over again. Following the instructions in github, I deployed just Lilu 1.2.2 + your ATH9kFixup.kext + ATH9KInjector.kext to S/L/E, but that rendered 'Wi-Fi: No hardware installed'. Adding the custom "AirPortAtheros40.kext" v21 for OS 10.13 made the kext attach and load, but still no networks in the scan. So not sure what I'm doing wrong here.

BTW, I'm using the attached config.plist, with no patched DSDTs / SSDTs so far (that tuning is coming next)

I'm also trying to make HDMI audio work, but that's for another thread ;)

Thanks again for all your hard work here.
 

Attachments

  • config.plist
    16.9 KB · Views: 531
Last edited:
Hi Rehabman,

Thanks a lot for taking the time to respond. I will be ordering a supported Broadcom WiFi NGFF card, but I was first trying to make the original one that came OTB work. In relation to Broadcom: I've read Apple branded BCM94360's work OTB, without customization. Are these compatible with Dell laptops ? Just asking cause some brands set blocks on other brands' HW.

It puzzles me that others are able to make the ATH 9565 work, so wondering what is it that I may be doing wrong here with Clover configuration, or elsewhere. Will post logs soon, but it calls my attention that System Information reports:

Card Type: AirPort Extreme (0x168C, 0x20E)
Firmware Version: Atheros 9565: 4.0.74.0-P2P

when the actual PCI IDs are (0x168C, 0x36)

Over past days, I cleaned everything up, restored all original kexts, removed any leftovers, and started all over again. Following the instructions in github, I deployed just Lilu 1.2.2 + your ATH9kFixup.kext + ATH9KInjector.kext to S/L/E, but that rendered 'Wi-Fi: No hardware installed'. Adding the custom "AirPortAtheros40.kext" v21 for OS 10.13 made the kext attach and load, but still no networks in the scan. So not sure what I'm doing wrong here.

BTW, I'm using the attached config.plist, with no patched DSDTs / SSDTs so far (that tuning is coming next)

I'm also trying to make HDMI audio work, but that's for another thread ;)

Thanks again for all your hard work here.

"Problem Reporting" files are incomplete.
Read FAQ, "Problem Reporting" again. Carefully. Attach all requested files/output.
https://www.tonymacx86.com/threads/faq-read-first-laptop-frequent-questions.164990/
Use the gen_debug.sh tool mentioned in the FAQ, that way it is less likely you'll omit something.
 
Dell-Tester did you fix your wifi problem?
i am facing same problem with AR9565 i also tried all the methods and wifi not scanning any device help please
 
Dell-Tester did you fix your wifi problem?
i am facing same problem with AR9565 i also tried all the methods and wifi not scanning any device help please

Hi zainanjum,
Unfortunately, I was never able to activate the AR9565 card that came with my Inspiron 15 under HS 10.13.2/3/4. I tried several kext versions and install methods from all hackintosh forums, but I was never able to successfully scan networks. Had to use an external USB WiFi adapter temporarily (RT2870-based, from a Raspberry Pi) to "cut the cord". I then followed Rehabman's advice, and purchased a Broadcom-based 43xx card (mine is a Dell DW 1560, but DW 1830 is also reported to work OK as NGFF option). Both WiFi and BT work fine, without issues with the DW1560.

Good luck !
 
Status
Not open for further replies.
Back
Top