Contribute
Register

Wi-Fi & Bluetooth not working on Alder Lake 12700K build.

Joined
Feb 16, 2016
Messages
25
Motherboard
MSI PRO Z690-A WIFI
CPU
i7-12700K
Graphics
UHD 770, RX 580
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
  3. Other
I have successfully installed macOS 12.5 (21G72) on my MSI PRO Z690-A WiFi DDR4 + 12700K build. I have basically grabbed OC 0.8 EFI of NorthAmTransAm Golden Build, and updated it to OC 0.8.4 with some changes. And to my surprise it is one of the most stable build, sleep, screen saver works really well.

But I have few stuff to fix and ask.

#1 of all, are there any dedicated guides for Alder Lake ( possibly with Ventura) ? I want to learn how things have changed with OpenCore on Alder Lake.

#2 => Wi-Fi & Bluetooth are not working. Even Ethernet was not working until I changed "Configure" to "Manually" with "Speed" - 100baseTX, Full Duplex, Standard (1500).
With that, I want to use AirDrop and other Apple Ecosystem features, as I am totally in it.

#2.1 In Hackintool "Peripherals" the "Device Name" is not present. (Screenshot attached, please let me know required changes). Fixed - ExtendBTFeatureFlags quirk is unticked in Kernel Section of config.plist.

#2.2 Bluetooth plist file is missing from macOS.

#3 => The serial number I am using might be blacklisted. Is there any way to get unique or at least not much used Serial Number? I have a Serial Number of real MacPro7,1 but I don't think I should be using it.

#4 => I have RTX 3070 but to run this machine I am using RX 580 of my other build, is it possible to get display with RX 580 and use RTX 3070 for GPU intense work?


I have given my 2 weekends on building Hackintosh on my two builds, I was quick to learn in Haswell build (4790K). But I want to completely shift to Alder Lake build now. Hopefully!

Attached Files - EFI, Hackintool screenshot.
Is Ioreg still required in Monterey?
 

Attachments

  • EFI.zip
    31.3 MB · Views: 39
  • Screen Shot 2022-10-03 at 9.35.33 AM.png
    Screen Shot 2022-10-03 at 9.35.33 AM.png
    669.6 KB · Views: 49
Last edited:

Feartech

Moderator
Joined
Aug 3, 2013
Messages
29,032
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
I have successfully installed macOS 12.5 (21G72) on my MSI PRO Z690-A WiFi DDR4 + 12700K build. I have basically grabbed OC 0.8 EFI of NorthAmTransAm Golden Build, and updated it to OC 0.8.4 with some changes. And to my surprise it is one of the most stable build, sleep, screen saver works really well.

But I have few stuff to fix and ask.

#1 of all, are there any dedicated guides for Alder Lake ( possibly with Ventura) ? I want to learn how things have changed with OpenCore on Alder Lake.

#2 => Wi-Fi & Bluetooth are not working. Even Ethernet was not working until I changed "Configure" to "Manually" with "Speed" - 100baseTX, Full Duplex, Standard (1500).
With that, I want to use AirDrop and other Apple Ecosystem features, as I am totally in it.

#2.1 In Hackintool "Peripherals" the "Device Name" is not present. (Screenshot attached, please let me know required changes).

#2.2 Bluetooth plist file is missing from macOS.

#3 => The serial number I am using might be blacklisted. Is there any way to get unique or at least not much used Serial Number? I have a Serial Number of real MacPro7,1 but I don't think I should be using it.

#4 => I have RTX 3070 but to run this machine I am using RX 580 of my other build, is it possible to get display with RX 580 and use RTX 3070 for GPU intense work?


I have given my 2 weekends on building Hackintosh on my two builds, I was quick to learn in Haswell build (4790K). But I want to completely shift to Alder Lake build now. Hopefully!

Attached Files - EFI, Hackintool screenshot.
Is Ioreg still required in Monterey?
nvidia is not support

use Gensmbios to generate a new serial
 
Joined
May 10, 2011
Messages
2,715
Motherboard
Gigabyte B550 Vision D
CPU
Ryzen 5900X
Graphics
RX 6800
Mac
  1. iMac
  2. MacBook
  3. MacBook Air
  4. MacBook Pro
  5. Mac mini
  6. Mac Pro
Classic Mac
  1. Power Mac
  2. PowerBook
Mobile Phone
  1. iOS
I have successfully installed macOS 12.5 (21G72) on my MSI PRO Z690-A WiFi DDR4 + 12700K build. I have basically grabbed OC 0.8 EFI of NorthAmTransAm Golden Build, and updated it to OC 0.8.4 with some changes. And to my surprise it is one of the most stable build, sleep, screen saver works really well.

But I have few stuff to fix and ask.

#1 of all, are there any dedicated guides for Alder Lake ( possibly with Ventura) ? I want to learn how things have changed with OpenCore on Alder Lake.

#2 => Wi-Fi & Bluetooth are not working. Even Ethernet was not working until I changed "Configure" to "Manually" with "Speed" - 100baseTX, Full Duplex, Standard (1500).
With that, I want to use AirDrop and other Apple Ecosystem features, as I am totally in it.

#2.1 In Hackintool "Peripherals" the "Device Name" is not present. (Screenshot attached, please let me know required changes).

#2.2 Bluetooth plist file is missing from macOS.

#3 => The serial number I am using might be blacklisted. Is there any way to get unique or at least not much used Serial Number? I have a Serial Number of real MacPro7,1 but I don't think I should be using it.

#4 => I have RTX 3070 but to run this machine I am using RX 580 of my other build, is it possible to get display with RX 580 and use RTX 3070 for GPU intense work?

I have given my 2 weekends on building Hackintosh on my two builds, I was quick to learn in Haswell build (4790K). But I want to completely shift to Alder Lake build now. Hopefully!

Attached Files - EFI, Hackintool screenshot.
Is Ioreg still required in Monterey?

Hi @Wuttodo,

1) Yes there is. This is the thread we started back in November 2021 where we got to grapple with the very first systems getting them onto macOS
> https://www.tonymacx86.com/threads/z690-chipset-and-alder-lake-cpus.316618/

This is the thread for my build, Asus Z690-P D4
> https://www.tonymacx86.com/threads/...nstall-and-support-thread.318407/post-2302841

This is the thread for CaseySJ's Asus Z690 ProArt Creator
> https://www.tonymacx86.com/threads/...hunderbolt-4-i7-12700k-amd-rx-6800-xt.318311/

The biggest change for the platform was probably the CPU being treated by the BIOS as a device instead of as a processor for the new socket - this is why it needs a SSDT-PLUG-ALT to work.

2) Check what card you are using ie. Intel or Broadcom. For Intel BT & WiFi you require the OpenIntelWireless Github files which includes Airportitlwm.kext, IntelBluetoothFirmware & IntelBTPatcher. For Broadcom BT/Wifi you require the BT files from BrcmPatchRAM Github and AirportBrcmFixup.kext. You'll need to enable BluetoolFixup.kext from BrcmPatchRAM for both brands of cards under Monterey.

3) You need to generate that using Gensmbios

4) Nvidia RTX 30 card cannot be used in macOS because Nvidia support is finished with Apple. But it can be disabled using SSDT-DGPU-Off.aml file. RX580 is fine for up to Ventura.

5) Yes IOReg can still be used in Monterey
 

Edhawk

Moderator
Joined
Aug 2, 2013
Messages
4,540
Motherboard
Asus TUF Z390 Gaming
CPU
i5-8500
Graphics
RX 580
Mac
  1. iMac
  2. MacBook Air
  3. MacBook Pro
Mobile Phone
  1. iOS
You are using an old Broadcom WiFi/BT card BCM4350, which isn't supported in the newer releases of macOS.

Either find the fix that worked for this card in Catalina/Big Sur, see if that works for Monterey.

Alternative is to purchase a Broadcom WIFI/BT card that is still natively supported, the BCM43602CS or BCM4360SC2 should be OK.
 
Top