Contribute
Register

WhateverGreen Smooths Out the Nvidia Drivers Stuttering

Status
Not open for further replies.
Joined
Feb 8, 2013
Messages
96
Motherboard
Gigabyte GA-H270N-Wifi
CPU
i7-7700K
Graphics
GTX 1070
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
In the feature description for WhateverGreen it says
  • Fixes NVIDIA GPU interface stuttering on 10.13 (official and web drivers)

Does that fix the stutter that I and lot of other users experience? Currently I am on 10.13.3 with a Gigabyte 1070 and using an old version of the NVidia Web Driver was the only way for me. With anything newer YouTube videos would stutter, games like League of Legends would stutter, VLC the same etc.

Does WhateverGreen magically solve all that and you can install 10.13.6 + the latest NVidia Web Driver version?
 
Joined
Dec 11, 2013
Messages
17
Motherboard
Gigabyte Z370M-D3H
CPU
i9-9900K
Graphics
RX 580
Mac
  1. MacBook Pro
  2. Mac mini
Does WhateverGreen magically solve all that and you can install 10.13.6 + the latest NVidia Web Driver version?

I upgraded from Sierra to High Sierra tonight. Updated to the latest web drivers and the lag made my hack unusable.

I have been reading and experimenting for the last couple of hours but only downgrading to the .25.106 drivers with the nvidia-update.sh script has seemed to make it acceptable. Command I used was:

bash <(curl -s https://raw.githubusercontent.com/Benjamin-Dobell/nvidia-update/master/nvidia-update.sh) 378.10.10.10.25.106

Tried latest WhateverGreen + Lilu in the Other folder with the latest drivers and it didn't work for me.

If anyone has any further troubleshooting ideas I am all ears! My system is still a little laggy but it's usable at this stage. Definitely not as responsive as Sierra.
 
Joined
Aug 19, 2012
Messages
225
Motherboard
Asus Prime X299- A II
CPU
i9-10980XE
Graphics
RX 5700 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac mini
  4. Mac Pro
Classic Mac
  1. Plus
  2. Power Mac
  3. Quadra
Mobile Phone
  1. iOS
I think most of us running a bit more complex setups are on 25.106 at this point. With every new version of the Nvidia drivers I keep hoping that they'll get back on track but so far there are issues, particularly with dual GPU's in High Sierra. So yeah, stick to 25.106 as long as you can.
 
Joined
Feb 8, 2013
Messages
96
Motherboard
Gigabyte GA-H270N-Wifi
CPU
i7-7700K
Graphics
GTX 1070
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
Does that fix the stutter that I and lot of other users experience?

Having just built a new hackintosh I can now answer my own question. Yes, WhateverGreen fixes all those issues. Quite amazing actually. At last on the specific setup that I used: i5-6400, ASRock H110M-DGS, KFA2 GTX 1050 Ti, 16 GB 2133 MHz RAM, fresh install of macOS 10.13.6, NVidia web driver 387.10.10.10.40.105, Clover 4630, WhateverGreen 1.2.0.

I have to say this is probably the most smooth feeling hack I ever had. Far better than my own Skylake hackintosh I have at home. The Clover and WhateverGreen devs did a great job here. All the stutter I had with earlier versions of Clover, the NVidia web driver, macOS 10.13.3 and no Whatevergreen is gone. VLC, YouTube and video games all run just fine. With ApfsDriverLoader and AptioMemoryFix also seem to help. Great job devs.

/Volumes/EFI/EFI/CLOVER/kexts/Other:

Code:
FakeSMC.kext           Lilu.kext
FakeSMC_ACPISensors.kext   RealtekRTL8111.kext
FakeSMC_CPUSensors.kext       USBInjectAll.kext
FakeSMC_GPUSensors.kext       WhateverGreen.kext
FakeSMC_LPCSensors.kext       realtekALC.kext

/Volumes/EFI/EFI/CLOVER/drivers64UEFI:

Code:
ApfsDriverLoader-64.efi       DataHubDxe-64.efi
AppleImageCodec-64.efi       FSInject-64.efi
AppleKeyAggregator-64.efi   FirmwareVolume-64.efi
AppleUITheme-64.efi       SMCHelper-64.efi
AptioMemoryFix-64.efi       VBoxHfs-64.efi
 
Last edited:
Joined
Oct 11, 2017
Messages
2
Motherboard
MSI
CPU
9700
Graphics
5700 xt
Mac
  1. Mac Pro
Mobile Phone
  1. iOS
Having just built a new hackintosh I can now answer my own question. Yes, WhateverGreen fixes all those issues. Quite amazing actually. At last on the specific setup that I used: i5-6400, ASRock H110M-DGS, KFA2 GTX 1050 Ti, 16 GB 2133 MHz RAM, fresh install of macOS 10.13.6, NVidia web driver 387.10.10.10.40.105, Clover 4630, WhateverGreen 1.2.0.

I have to say this is probably the most smooth feeling hack I ever had. Far better than my own Skylake hackintosh I have at home. The Clover and WhateverGreen devs did a great job here. All the stutter I had with earlier versions of Clover, the NVidia web driver, macOS 10.13.3 and no Whatevergreen is gone. VLC, YouTube and video games all run just fine. With ApfsDriverLoader and AptioMemoryFix also seem to help. Great job devs.

Seconding this, I've had consistent stutter / cursor freezing whenever Safari was open for awhile, I'll report back if I spoke too soon. YouTube isn't eating CPU while not playing a video like it used to, so here's to hoping whatever was causing that is fixed.
 
Joined
Oct 11, 2017
Messages
2
Motherboard
MSI
CPU
9700
Graphics
5700 xt
Mac
  1. Mac Pro
Mobile Phone
  1. iOS
Can't update my previous post, so sorry for double posting, but the stuttering is still present, maybe a bit less severe. Closing and reopening Safari does still fix this for a bit, though.
 

BreBo

Moderator
Joined
Oct 17, 2011
Messages
9,449
Motherboard
Gigabyte GA-Z87X-OC
CPU
i7-4770K
Graphics
HD 4600 / RX 580
@DrNeroCF, please update your profile (personal details) with your Motherboard, CPU and iGPU or Graphics Card(s).
If you have a prebuilt computer enter make and model instead of motherboard.
The Rules said:
Profiles are mandatory so that others can assist you.
 
Joined
Mar 11, 2010
Messages
100
Motherboard
ASUS ROG MAXIMUS IX CODE
CPU
Intel i7 7700K
Graphics
Nvidia 1080 TI
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
I migrated to WhateverGreen, however, I get a black screen when using Nvidia. I have no issue booting when I'm using Intel onboard graphics (listening to Beats One is broken, I wonder if the old Shiki flags work)

Update:
Nevermind, I upgraded lilu and everything is working...
 
Last edited:
Joined
Oct 19, 2014
Messages
30
Motherboard
ASRock Z370 Pro
CPU
i7-8700K
Graphics
2x GTX 1080 Ti
I think most of us running a bit more complex setups are on 25.106 at this point. With every new version of the Nvidia drivers I keep hoping that they'll get back on track but so far there are issues, particularly with dual GPU's in High Sierra. So yeah, stick to 25.106 as long as you can.

Hey Midphase. I havent been up on the latest for a few months, i have a asrock z370 MB, 8700k, and 2 1080 ti's . i use redshift and Houdini also, any idea the best current OSX version and Nvidia web drivers to use ? I used one of those automated Nvidia installers to update my web drivers and been having issues with chrome and AE crashed on me.
 
Status
Not open for further replies.
Top