Contribute
Register

[WARNING] Clover will break your REAL Mac, use with caution

Status
Not open for further replies.

Gigamaxx

Moderator
Joined
May 15, 2016
Messages
6,570
Motherboard
GIGABYTE X470 Arous Gaming 7 WiFi
CPU
Ryzen R9 3900X
Graphics
RX 480
Mac
  1. iMac
So I just did this to a Macbook Air (Early 2014) and I am pretty sure it is hosed. I can get to clover now with no SSD installed. Is anyone in the same boat having battery / charging and keyboard issues as well? When I boot to an OEM Mojave Installer, the Caps Lock and lowercase p willl not operate. Also, the battery is not charging. Any ideas are greatly appreciated. Thanks!

You may be able to use a USB keyboard to get past install issue. I use a Logitech K400 it works in all MacOS versions.
Where is the original drive?

Use the cursor arrows to go to Options tab and uncheck all settings especIlly ACPI, Binaries, CPU Tuning etc... before you try booting.
 
Joined
May 16, 2012
Messages
43
Motherboard
ASUS MAXIMUS V GENE
CPU
i7-3770K
Graphics
GTX 660
Mac
  1. MacBook Air
Mobile Phone
  1. Android
  2. iOS
Got installation to complete and can use it but only while using a clover boot key. The CAPS LOCK and lowercase p still don't work. Could this be due to the EFI BOOTROM issue? I know exactly where I went wrong: I used the Clover boot key and restored the boot key image to the HDD, which obviously effected the onboard EFI. I just don't want to pay for a repair service / EFI solderless chip to repair an issue that is really a keyboard issue. I am at a crossroads of whether or not to dump more money into it. Could the non-OEM EFI BOOTROM be causing the keyboard issues? The P key operates in CAPS, but not lowercase, and the CAPS LOCK is on when booted, but cannot be toggled back on after being off.

Solutions I am considering:

  1. Buy a MacUnlocks Solderless EFI chip to pop in and solve the EFI issue (~$65)
  2. Paying a repair service (eBay) to reflash the EFI Bootroom (~$65)
 
Last edited:

Gigamaxx

Moderator
Joined
May 15, 2016
Messages
6,570
Motherboard
GIGABYTE X470 Arous Gaming 7 WiFi
CPU
Ryzen R9 3900X
Graphics
RX 480
Mac
  1. iMac
Use EFI mounter found here in downloads section. Mount the EFI.

You should see a folder:
EFI open it.
It should look like this:
Apple
Boot
Clover
Clover install log.

Trash all the items EXCEPT the Apple folder.
Reboot and test.
 
Joined
Mar 22, 2019
Messages
222
Motherboard
HP Elite 8300 MT
CPU
i5-3470
Graphics
GT 710
Mac
  1. iMac
  2. MacBook
Classic Mac
  1. iMac
Mobile Phone
  1. iOS
For an experiment, I decided to install clover to my unsupported MacBook 4,1 and to my surprise, it worked. I was able to install El Capitan and use it. Only problem is that my built-in trackpad, keyboard, and USB ports don't work.
 
Last edited:
Joined
Mar 9, 2019
Messages
1
Motherboard
Asrock B250M Pro4
CPU
i5-7100
Graphics
AMD RX470
Same here.
I'll try to bring it to an apple store and ask them to flash my BIOS/EFI bootrom firmware.

This Apple will not do. They will kindly ask you what you did to the boot ROM and then send you home with your door stop.
 
Joined
Jul 21, 2011
Messages
36
Motherboard
Lenovo U410 Touch
CPU
Core I7 2.0GHz
Graphics
Intel HD4000 and Geforce 710M
Mac
  1. MacBook Pro
Classic Mac
Mobile Phone
  1. Android
  2. iOS
So I did what you said in the post. Disabled ALL of Clover's injections patches in the config.plist file using Clover configurator, then, deleted all included kexts on the bootable drive (i.e. EFI/CLOVER/drivers32UEFI & EFI/CLOVER/drivers64UEFI folders). Booted up into Clover and PRESTO! It works! Took it a step further and actually, SUCCESSFULLY too, installed El Capitan on a MacBook 3,1. I did however have to install Intel GMX3000 graphics Kexts and Realtek Audio kexts to get it at 100%

Is the graphics acceleration working 100% on macbook 3,1? Can you please make a detailed step on how you did it? Did you install clover bootloader directly on your macbook 3,1? Thanks
 
Joined
Jun 26, 2019
Messages
4
Motherboard
GA-Z87X-D3H
CPU
4670k
Graphics
radeon rx 580
Use EFI mounter found here in downloads section. Mount the EFI.

You should see a folder:
EFI open it.
It should look like this:
Apple
Boot
Clover
Clover install log.

Trash all the items EXCEPT the Apple folder.
Reboot and test.

I'm another stupid guy who just installed Clover on a macbook pro 15 retina. I still haven't rebooted, I'm saving everything on the time machine. I mounted EFI and I could try and delete "Boot", "Clover" and the "clover install log". Will it work? Or I'm going to need the chip? Thanks a lot for any help you can give me :)
 

Gigamaxx

Moderator
Joined
May 15, 2016
Messages
6,570
Motherboard
GIGABYTE X470 Arous Gaming 7 WiFi
CPU
Ryzen R9 3900X
Graphics
RX 480
Mac
  1. iMac
Delete it and if you didn’t boot hopefully it won’t effect it. Check the Apple folder to see it matches your real configuration i.e. MacBook Pro. MPBxxxxxxx

The Apple folder gets placed there after an update so in a new install it’s not there but after a security or version update it appears.
 
Joined
Jun 26, 2019
Messages
4
Motherboard
GA-Z87X-D3H
CPU
4670k
Graphics
radeon rx 580
whoa, thanks a lot - the Apple folder has two subfolders: Extensions and Firmware.
In the Extensions folder there is a firmware.scap file, while in the Firmware folders there is a MBP112.scap file (and it should be exactly my model).
Shall I delete the Apple folder as well?
 
Status
Not open for further replies.
Top