Contribute
Register

[WARNING] Clover update r4586 deletes OsxAptioFix3Drv-64.efi

Joined
Jan 4, 2017
Messages
2
Motherboard
Gigabyte GA-Z170X-Gaming 3
CPU
i5-6600K
Graphics
RX 470
Mac
iMac, MacBook Pro
Mobile Phone
iOS
How old was your last version of Clover? Do you remember when you first installed your last update? My files had the "-64" bit in them, but it was also still the same version I installed one year ago, about May 2017-ish. Perhaps yours doesn't have the "-64" bit because your last model was an older version? Just a wild guess, though.

Anyone else have any ideas?
I was using Clover 4558 on macOS 10.13.5 with apfs.efi. Before I updated to 10.13.6 I replaced apfs.efi with ApfsDriverLoader.efi (downloaded from https://github.com/acidanthera/ApfsSupportPkg/releases because of this post https://www.tonymacx86.com/threads/...pfs-efi-downloads.236103/page-10#post-1763476). Once I was on 10.13.6 I updated clover to the latest version.
 
Last edited:
Joined
Nov 26, 2012
Messages
1,602
Motherboard
Gigabyte Z490 D
CPU
i7-10700K
Graphics
RX 580
Mac
MacBook Pro
Mobile Phone
iOS
How old was your last version of Clover? Do you remember when you first installed your last update? My files had the "-64" bit in them, but it was also still the same version I installed one year ago, about May 2017-ish. Perhaps yours doesn't have the "-64" bit because your last model was an older version? Just a wild guess, though.

Anyone else have any ideas?
ibid
 
Joined
Jun 3, 2017
Messages
8
Motherboard
MSI Gaming H170 M3
CPU
I5 6500
Graphics
GTX 1050Ti
Mac
MacBook Pro
Classic Mac
iMac
Mobile Phone
Android
Hi guys I'm quite new to the hackintosh, but believe it or not I managed to get it working, finally, running high Sierra .6 . And I had the clover installed from multibeast. However I recently installed clover confugurator and updated the clover to 4586 and when I boot up it stops at the '++++...'. I've heard it removes some important stuff, to fix this could I use the original usb with clover or do I have to use a ssd caddy and edit the efi on an actual Mac . Thanks.
 
Joined
Apr 5, 2012
Messages
116
Motherboard
MSI Z270 Gaming Pro Carbon
CPU
i5-7600
Graphics
RX 570
Mobile Phone
Android
Thanks to everyone for the heads up with the issues in this thread. On my MSI Gaming Pro Carbon build, I had been using OsxAptioFix2Drv-free2000.efi that was created by some guy somewhere to fix memory errors when using OsxAptioFixDrv, OsxAptioFix2Drv or OsxAptioFix3Drv. This sketchy solution is now irrelevant with AptioMemoryFix-64.efi and ApfsDriverLoader-64.efi. Also, I was able to remove apfs.efi and EmuVariableUefi-64.efi. As an added bonus, the system now seems to boot faster.

The process:
  1. Backed up my drive with Clonezilla to make a clone just in case. This is a complete an bootable clone with the old clover boot loader and system. I also made a copy of my drivers64UEFI folder on in a folder on my desktop to simplify replacing items if something did fail.
  2. Downloaded the latest clover from Sourceforge: https://sourceforge.net/projects/cloverefiboot/
  3. Installed with custom configuration, making sure to check the two new items in Drivers64UEFI:
    AptioMemoryFix-64.efi and ApfsDriverLoader-64.efi
  4. BEFORE rebooting, I cleaned up the drivers64UEFI folder in the EFI partition on my disk to remove deprecated files so that it looked like the final one below. Note: path EFI-->EFI-->CLOVER-->drivers64UEFI
  5. Rebooted and everything just worked.

Clover r4586 rules! Congratulations to the development team for outstanding work.

Now I will try to update OSX from 10.13.5 to 10.13.6.

Edit: Update went well, detailed in the post here: https://www.tonymacx86.com/threads/macos-10-13-6-update.255911/page-31#post-1779278

Take a look at the changes to my drivers64UEFI folder:

Old folder:

Old drivers64UEFI.png


New Folder:

New drivers64UEFI.png
 
Last edited:
Joined
Aug 23, 2016
Messages
4
Motherboard
Gigabyte Z370Xp SLI
CPU
i7 8700 3.2GH
Graphics
GIGABYTE GV-N1060G1 GAMING-6GD
Mac
iMac
Anachronaut. thank you!
 
Last edited:
Joined
Jul 21, 2011
Messages
5
Mac
Classic Mac
Mobile Phone
I just wanted to say thank you so much for helping me fix the black screen after this mess!!!! I had given up hope and you helped bring my machine back from the dead!
 
Joined
Jul 18, 2016
Messages
83
Motherboard
Asus Z-170 Deluxe
CPU
i7-6700K
Graphics
RX 580
Mobile Phone
iOS
I upgraded Clover to build r4617 from r4589 right before installing macOS 10.13.6 update, and it causes kernel panic every time I boot the computer now. I couldn’t even boot from my macOS install flash drive since it gives me similar issue. I attach a picture of the boot log, appreciate if any of you can advise if this issue is caused by the missing OsxAptioFix3Drv-64.efi. Thanks.
 

Attachments

P1LGRIM

Moderator
Joined
Mar 2, 2012
Messages
23,674
Motherboard
Lenovo ThinkStation p300 ⌘
CPU
i7-4790K
Graphics
HD 4600
Mac
MacBook Pro, Mac mini
Classic Mac
Power Mac
Mobile Phone
iOS
appreciate if any of you can advise if this issue is caused by the missing OsxAptioFix3Drv-64.efi.
No, yours seems to be caused by an Ethernet kext - Off topic in this thread.

Network.png
 
Top