Contribute
Register

VoodooI2C Help and Support

Joined
Sep 1, 2016
Messages
33
Motherboard
MSI Z270 Krait Gaming
CPU
Intel i7 7700
Graphics
Intel HD630
Mac
  1. iMac
  2. MacBook Pro
Classic Mac
  1. Apple
  2. iMac
  3. Workgroup Server
Mobile Phone
  1. Android
  2. iOS
SSDT-XOSI is useless with the _OSI -> XOSI patch disabled. You should enable it.

You also need the 2 KextsToPatch entries by CoolStar to allow VoodooI2C to load.

SSDT-PluginType1 unnecessary (You have config.plist/ACPI/SSDT/Generate/PluginType=true).

Thanks for reply.
I did the three steps as you mentioned, but after the restart both the keyboard and the touchpad are not working anymore. Is there anything I missed?
 

Attachments

  • debug_30951.zip
    2.8 MB · Views: 58
Last edited:
Joined
Apr 21, 2016
Messages
1,008
Motherboard
ASUS X556UA-Clover
CPU
i5-6200U
Graphics
HD 520,1366x768
Mobile Phone
  1. iOS
Thanks for reply.
I did the three steps as you mentioned, but after the restart both the keyboard and the touchpad are not working anymore. Is there anything I missed?
You should attach new problem reporting files, I can't guess what's wrong.

It's possible, though very rare, that your keyboard is connected via I2C as well, and emulating Windows 10 enabled I2C connection for it too. But again, impossible to verify/give a suggestion without new files.
 
Joined
Sep 1, 2016
Messages
33
Motherboard
MSI Z270 Krait Gaming
CPU
Intel i7 7700
Graphics
Intel HD630
Mac
  1. iMac
  2. MacBook Pro
Classic Mac
  1. Apple
  2. iMac
  3. Workgroup Server
Mobile Phone
  1. Android
  2. iOS
You should attach new problem reporting files, I can't guess what's wrong.

It's possible, though very rare, that your keyboard is connected via I2C as well, and emulating Windows 10 enabled I2C connection for it too. But again, impossible to verify/give a suggestion without new files.

Sorry for that. Just updated files on the post #505.
 
Joined
Apr 21, 2016
Messages
1,008
Motherboard
ASUS X556UA-Clover
CPU
i5-6200U
Graphics
HD 520,1366x768
Mobile Phone
  1. iOS
Sorry for that. Just updated files on the post #505.
Your config.plist is corrupt, you should fix it. Re-add what you've changed in it carefully, one patch/change every time, see which one is causing problems. Not sure if that Chinese text in there is helpful...
 
Joined
Sep 1, 2016
Messages
33
Motherboard
MSI Z270 Krait Gaming
CPU
Intel i7 7700
Graphics
Intel HD630
Mac
  1. iMac
  2. MacBook Pro
Classic Mac
  1. Apple
  2. iMac
  3. Workgroup Server
Mobile Phone
  1. Android
  2. iOS
Your config.plist is corrupt, you should fix it. Re-add what you've changed in it carefully, one patch/change every time, see which one is causing problems. Not sure if that Chinese text in there is helpful...

I see. It was not working the keyboard as I have to boot in WIN10 to change the config.pilsit file, then it seems changed the file in a different way.

I have regenerated the files without the Chinese texts. As the keyboard won't work with the _OSI -> XOSI patch enabled then I cannot do the file generation, so I have to disabled it for the files.
 

Attachments

  • debug_5288.zip
    2.8 MB · Views: 185
Joined
Apr 21, 2016
Messages
1,008
Motherboard
ASUS X556UA-Clover
CPU
i5-6200U
Graphics
HD 520,1366x768
Mobile Phone
  1. iOS
I see. It was not working the keyboard as I have to boot in WIN10 to change the config.pilsit file, then it seems changed the file in a different way.

I have regenerated the files without the Chinese texts. As the keyboard won't work with the _OSI -> XOSI patch enabled then I cannot do the file generation, so I have to disabled it for the files.
config.plist is OK now.

I can't really help you when Windows emulation isn't working, as I can't tell what's wrong when you're using it.
You should get external keyboard and mouse until get internal ones working.

BTW, macOS has a built-in on-screen keyboard, if you need it.
 
Joined
Aug 6, 2017
Messages
9
I use Gl553VD. It using ELAN 1200. I was installed this kext (voodooI2C and Voodoo2CHID). My touchpad is working and not recognize Multitouch 3 finger. So when I reboot. Touchpad has stop working. I reinstall kext. It still not working :( How to fix it ?
 
Last edited:
Joined
Apr 21, 2016
Messages
1,008
Motherboard
ASUS X556UA-Clover
CPU
i5-6200U
Graphics
HD 520,1366x768
Mobile Phone
  1. iOS
Joined
Jun 29, 2018
Messages
7
Motherboard
Asus X556UA (Clover)
CPU
i7-6500U
Graphics
HD520, 1920x1080
My trackpad uses FTE1001 and works for single taps and double tap to drag, however I can't get any two/three/four finger gestures to work and my system prefs just says "No trackpad found". Any help would be much appreciated.
 

Attachments

  • Archive.zip
    768.7 KB · Views: 166
Joined
Jul 18, 2018
Messages
5
Motherboard
Asus UX430UNR
CPU
i5 - 8250U
Graphics
MX150
Mobile Phone
  1. iOS
Hi, my Elan 1300 Touchpad from my Asus Zenbook UX430UNR isn't working. I've GPIO pinned it with my hex code 0x55 (I'm using the clover Folder of the Guide for the UX430 from starcentral, which is working for me). Do you have any idea why it's not working ?
 

Attachments

  • 8959.zip
    1.2 MB · Views: 171
Top