Contribute
Register

VGA working, HDMI/DVI not Asus GTX 750 Ti

Status
Not open for further replies.
Joined
Feb 28, 2017
Messages
42
Motherboard
GA-Z170x Ultra Gaming
CPU
I7-6700K
Graphics
GTX 750 Ti + HD 530
Hello,

I can't solve this. I just got another monitor, but only VGA is working and I have one port.
- When I use VGA : osx boots, the apple logo shows up, the bar loads halfway through, then a black screen appears for 1 second. After that the bar finishes loading and boom I'm in and it works.
- When I use any other type of connection (hdmi, dvi), the screen won't go back to the bar after the black screen.

I tried on Win10 and the dual screen works.
When I plug the second screen via HDMI or DVI while I'm in osx (VGA) , the working screen fades to black for a second, just like my macbook pro does when I plug it to the TV for example (so I guess it is detected), but the monitor displays "no signal".
The monitors I use are the LG 21.5'' LED 22EA53VQ, resolution 1920x1080
I use nvda_drv=1, running 10.11.6 and using the Mac Pro 3,1 configuration

It has to be about the drivers, when I boot with nv_disable=1 DVI works.
 
Last edited:

slim.jim

Moderator
Joined
Dec 17, 2014
Messages
4,220
Motherboard
MSI Z97 Gaming 9 AC
CPU
i7-4790K
Graphics
RX 5700 XT
Mac
  1. MacBook Pro
Classic Mac
  1. PowerBook
Mobile Phone
  1. iOS
HDMI does not work on an Asus GTX 750/750 ti without flashing the VBIOS from another brand card. You might also be able to use Clover's ability to load a different VBIOS without the need to flash the card. Also make sure you are not injecting Nvidia.
 
Joined
Feb 28, 2017
Messages
42
Motherboard
GA-Z170x Ultra Gaming
CPU
I7-6700K
Graphics
GTX 750 Ti + HD 530
Thank you for your response
I'm not injecting Nvidia, forgot to mention that !
Alright, how can do it with clover ? I can't find a thread about this
 
Joined
Feb 28, 2017
Messages
42
Motherboard
GA-Z170x Ultra Gaming
CPU
I7-6700K
Graphics
GTX 750 Ti + HD 530
do i have to get a more compatible gpu ?
 

slim.jim

Moderator
Joined
Dec 17, 2014
Messages
4,220
Motherboard
MSI Z97 Gaming 9 AC
CPU
i7-4790K
Graphics
RX 5700 XT
Mac
  1. MacBook Pro
Classic Mac
  1. PowerBook
Mobile Phone
  1. iOS
do i have to get a more compatible gpu ?

I'm not an expert when it comes to flashing but you need to flash the card. You run the risk off bricking the card if done wrong. Asus 750/750ti were the only ones with this problem though.
 
Joined
Feb 28, 2017
Messages
42
Motherboard
GA-Z170x Ultra Gaming
CPU
I7-6700K
Graphics
GTX 750 Ti + HD 530
yup, card is bricked. F#*@ you Asus. I'll just change it, which one would you recommend for my setup ?
 

slim.jim

Moderator
Joined
Dec 17, 2014
Messages
4,220
Motherboard
MSI Z97 Gaming 9 AC
CPU
i7-4790K
Graphics
RX 5700 XT
Mac
  1. MacBook Pro
Classic Mac
  1. PowerBook
Mobile Phone
  1. iOS
yup, card is bricked. F#*@ you Asus. I'll just change it, which one would you recommend for my setup ?

A 750 is fine. Just the Asus cards had the HDMI problem. Any 9xx cards is a good choice too.
 
Joined
Feb 28, 2017
Messages
42
Motherboard
GA-Z170x Ultra Gaming
CPU
I7-6700K
Graphics
GTX 750 Ti + HD 530
okay, thank you for your time it helped a lot.
I bought a gigabyte 750 ti, dvi/hdmi work great. Only problem now is the slow boot, i'll try to reinstall the drivers see if it changes
 
Status
Not open for further replies.
Top