Contribute
Register

Vega Frontier Edition on High Sierra

Status
Not open for further replies.
Joined
Sep 20, 2015
Messages
126
Motherboard
Dell PowerEdge T30
CPU
E3-1225 v5
Graphics
RX 580
Things just keep getting better :clap:

I have installed 2 x GC-Alpine Ridge. They are both connected to a single AMD VEGA. One of them has 2 DP inputs and the other only 1. I have 2 LG Ultrafine 5k displays running. One is at full 5k, and the other is scaled. Both are running off a single thunderbolt cable. Given that my MB only has one TB header, only one has audio, video, and controls. I'll be picking up a second AMD VEGA with the hopes of having both displays running at 5k.

View attachment 267059

Thanks! After reading this thread I bought the Vega Frontier Edition today. It works great.

I also noticed AirPlay works OOTB with iGPU disabled in the BIOS. Is that due to Vega, or some other reason?

Edit: Also sound works over DisplayPort. Is that surprising?
 
Last edited:
Joined
Jul 6, 2016
Messages
10
Motherboard
ASUS Z170 ROG MAXIMUS VIII HERO
CPU
i7-6700K
Graphics
Vega 56
Mac
  1. MacBook Pro
  2. Mac mini
Classic Mac
  1. LC
Mobile Phone
  1. iOS
https://videocardz.com/71430/amd-announces-radeon-rx-vega-64-series

RX Vega announced. Looks decent price-wise, though power consumption is rather high.

RX Vega 64 Liquid - 13.7 TFLOPS, 345W - $699
RX Vega 64 Ref - 12.6 TFLOPS, 295W - $499
RX Vega 56 - 10.5 TFLOPS, 210W - $399

For me the RX Vega 56 looks the most promising. Fingers crossed it's problem free in High Sierra. If so I'll seriously consider replacing my RX480.
 
Joined
Jan 25, 2011
Messages
732
Motherboard
GA-X58A-UD3R
CPU
X5650
Graphics
R9 290
Mac
  1. MacBook
Mobile Phone
  1. Android
  2. iOS
https://videocardz.com/71430/amd-announces-radeon-rx-vega-64-series

RX Vega announced. Looks decent price-wise, though power consumption is rather high.

RX Vega 64 Liquid - 13.7 TFLOPS, 345W - $699
RX Vega 64 Ref - 12.6 TFLOPS, 295W - $499
RX Vega 56 - 10.5 TFLOPS, 210W - $399

For me the RX Vega 56 looks the most promising. Fingers crossed it's problem free in High Sierra. If so I'll seriously consider replacing my RX480.

Agreed. Assuming RX Vega 56 gets the AIB-makeover (no blowers for me), and full High Sierra support without the need for a helper card-- both of which seem likely given recent developments and the announcement of the iMac Pro-- it's my next card. I'd consider the full Vega 64, but not sure the power consumption is worth the extra shaders... whereas an under-volted Vega 56 might even squeeze out higher computer with a small to moderate overclock.
 
Joined
Mar 23, 2017
Messages
9
Motherboard
ASUS x299 prime Deluxe
CPU
i9 7960x
Graphics
Vega Frontier Edition
Mac
  1. iMac
  2. MacBook
  3. Mac mini
Classic Mac
  1. Classic
  2. SE
Mobile Phone
  1. iOS
I too only have one port working on my VEGA Frontier card running on X99 motherboard.

Just wondering what you did to resolve this issue.
 
Joined
May 29, 2012
Messages
58
Motherboard
X99 > Need manufacturer & full model # > See Rules!
CPU
i9 > need model # > See Rules!
Graphics
RX 5700
Update. RX Vega 64 working OOB on Beta 8. I'm trying to get both cards working at the same time, but no luck.
 
  • Like
Reactions: dez
Joined
Apr 7, 2012
Messages
141
Motherboard
Asus Maximus X Formula
CPU
i7 8700K
Graphics
VEGA
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
One more confirmation: Vega 64 works on Beta 8, two cards work, but not video outs - only one card outputs to the monitors connected. Tried dual Dell 5K, one on each card. No luck.
 
Joined
May 29, 2012
Messages
58
Motherboard
X99 > Need manufacturer & full model # > See Rules!
CPU
i9 > need model # > See Rules!
Graphics
RX 5700
Getting the following error when I enable 2 Vega cards, and then black screen.
kernel[0]: X86PlatformPlugin:: cgRegisterCallbackHandler - gpu internal PLimit notification already registered

Anyone having similar issues?
 
Joined
Jun 19, 2017
Messages
36
Motherboard
Gigabyte Z170X-Ultra Gaming
CPU
Intel I76700K
Graphics
RX Vega 64
Just want to share I was able to get VEGA working 100% on X99 as well. I grabbed the EFI folder from another user, and it worked without any issues on all ports. Must have been something in my configuration! All ports working. No IGPU needed. Full acceleration.

Here are the results with LG Ultrafine 5k Display, AMD Radeon VEGA Frontier Edition and GC-Alpine Ridge. Definitely well worth it!

View attachment 267047

View attachment 267048
Can you post your EFI folder? I just got my Vega and I am wondering if this might help me with a few issues, I am not able to get hardware acceleration working properly for some reason. Thanks for the help!
 
Joined
Aug 21, 2010
Messages
184
Motherboard
Gigabyte Z370 Gaming 7
CPU
i7-8700K
Graphics
Radeon VII
One more confirmation: Vega 64 works on Beta 8, two cards work, but not video outs - only one card outputs to the monitors connected. Tried dual Dell 5K, one on each card. No luck.

Did you try 2 x 5K Dell Monitors or just 1 between 2 cards? I just need to power a single Dell 5K, so I hope that works?

Is there any "major" issues with Dell 5K (needs 2 x DP1.2 signals to work in 5K), with Vega 64/56 on latest GM High Sierra? I really really need a speed boost in FCP X - compared to say 1080TI. Hopefully you have some insights into how much gain there is in FCP X?
 
Joined
Jun 19, 2017
Messages
36
Motherboard
Gigabyte Z170X-Ultra Gaming
CPU
Intel I76700K
Graphics
RX Vega 64
Here are some OpenCL numbers.

View attachment 266776

I am seeing similar OpenCL scores on my Vega 64:

Screen Shot 2017-09-26 at 9.40.43 AM.png


But I am not getting full GPU acceleration, when I run the Valley benchmark I am seeing this:

Screen Shot 2017-09-24 at 3.25.13 PM.png


Any idea what I am doing wrong? Thanks for the help, I know I'm super close.
 
Status
Not open for further replies.
Top