Contribute
Register

Vega Frontier Edition on High Sierra

Joined
Feb 24, 2013
Messages
2,240
Motherboard
ASUS WS X299 SAGE/10G
CPU
i9-9980XE
Graphics
Radeon VII
Mac
MacBook Pro
Mobile Phone
iOS
Hey guys finally got a Vega Frontier Edition 16GB VRAM and wow does it make a difference. Everything is SO SMOOTH in High Sierra.

I'm coming from always using nVidia on Hackintoshes because I always needed CUDA, but now this feels like a totally different experience!

Previously (temporarily) I put in a RX560 just to get some work done, but finally was able to grab one of these cards (and it wasn't easy to find locally either).

So anyway, just wanted to let people know.

Really awesome card and I will do more benchmarks soon. For now here's a Unigine Valley test.

This is running on an "iMac Pro clone" .
 

Attachments

Last edited:
Joined
Jul 22, 2011
Messages
162
Motherboard
Gigabyte Z370 Aorus Gaming 5
CPU
Intel Core i7 8700K
Graphics
AMD Vega64
Mac
iMac, MacBook, MacBook Pro, Mac mini, Mac Pro
Classic Mac
eMac, iMac, Performa, Power Mac
Mobile Phone
Android, iOS
Hey guys finally got a Vega Frontier Edition 16GB VRAM and wow does it make a difference. Everything is SO SMOOTH in High Sierra.

I'm coming from always using nVidia on Hackintoshes because I always needed CUDA, but now this feels like a totally different experience!

Previously (temporarily) I put in a RX560 just to get some work done, but finally was able to grab one of these cards (and it wasn't easy to find locally either).

So anyway, just wanted to let people know.

Really awesome card and I will do more benchmarks soon. For now here's a Unigine Valley test.

This is running on an "iMac Pro clone" .

Finally got the new build completed and gotta say Im quite pleased. The Gaming 7 without the built in wifi and Bluetooth is working flawlessly.. I waited a full week before posting this to make sure the Bluetooth issue didn't arise and to my delight it is GONE.. None the less the Vega64 card is cranking on this system 8700K /32 gig 2666mhz. I really hope Tony starts recommending this card it is a beast..
 

Attachments

Joined
Aug 21, 2010
Messages
193
Motherboard
Z370 Gigabyte Gaming 7
CPU
i7-8700K
Graphics
Vega 56 + VII
Finally got the new build completed and gotta say Im quite pleased. The Gaming 7 without the built in wifi and Bluetooth is working flawlessly.. I waited a full week before posting this to make sure the Bluetooth issue didn't arise and to my delight it is GONE.. None the less the Vega64 card is cranking on this system 8700K /32 gig 2666mhz. I really hope Tony starts recommending this card it is a beast..
Congrats om a stable build :) Did you do anything out of the ordinary to get to be this way?

My hardware arrives hopefully this weekend, with the Gaming 7 + 8700k + 32GB (2x16) + Vega 64.

Anything I should be aware of?

Thanks in advance!
 
Joined
Nov 7, 2017
Messages
30
Motherboard
Asus Prime x299 Deluxe
CPU
i9-7900x
Graphics
Radeon Vega Frontier Edition
I've got my x299 build up and running with a Vega Frontier Edition and 3 4k displays. I have 2 displays connected via DisplayPort and 1 via hdmi. Is there any trick to getting all three display to work via DisplayPort? My problem with the one display on hdmi is that it runs at 30 hertz instead of 60 hertz.
 
Joined
Feb 24, 2013
Messages
2,240
Motherboard
ASUS WS X299 SAGE/10G
CPU
i9-9980XE
Graphics
Radeon VII
Mac
MacBook Pro
Mobile Phone
iOS
I've got my x299 build up and running with a Vega Frontier Edition and 3 4k displays. I have 2 displays connected via DisplayPort and 1 via hdmi. Is there any trick to getting all three display to work via DisplayPort? My problem with the one display on hdmi is that it runs at 30 hertz instead of 60 hertz.
Try putting the nvidiagraphicfixup kext in your efi(it does important things so it’s not only for nvidia). Don’t quote me but it may work. You can take it out if it doesn’t.

I used this kext previously for the rx560 and it helped.
 
Joined
Nov 7, 2017
Messages
30
Motherboard
Asus Prime x299 Deluxe
CPU
i9-7900x
Graphics
Radeon Vega Frontier Edition
Try putting the nvidiagraphicfixup kext in your efi(it does important things so it’s not only for nvidia). Don’t quote me but it may work. You can take it out if it doesn’t.

I used this kext previously for the rx560 and it helped.
Thank you, that worked!
 
Joined
Feb 24, 2013
Messages
2,240
Motherboard
ASUS WS X299 SAGE/10G
CPU
i9-9980XE
Graphics
Radeon VII
Mac
MacBook Pro
Mobile Phone
iOS
Thank you, that worked!
Great to know. There is also the AGDPfix route and some other ways but the kext is the easiest/non intrusive.
 
Joined
Jul 22, 2011
Messages
162
Motherboard
Gigabyte Z370 Aorus Gaming 5
CPU
Intel Core i7 8700K
Graphics
AMD Vega64
Mac
iMac, MacBook, MacBook Pro, Mac mini, Mac Pro
Classic Mac
eMac, iMac, Performa, Power Mac
Mobile Phone
Android, iOS
Congrats om a stable build :) Did you do anything out of the ordinary to get to be this way?

My hardware arrives hopefully this weekend, with the Gaming 7 + 8700k + 32GB (2x16) + Vega 64.

Anything I should be aware of?

Thanks in advance!
Install goes really easy IMO, I used the new APFS, so but everything works following the guide that I posted previously ( http://climbjoe.com/macos-high-sierra-version-10-13-2-coffee-lake-system-build-intro/)

I have had a couple crashes where the screen has gone black and then the fans on the Vega spins to max? not sure only happened twice but both times after playing Mafia III over steam and after I stop playing never while playing? Still trying to track it down let me know if you need any help..
 
Joined
Jan 31, 2012
Messages
38
Motherboard
Gigabyte Z370 Aorus Gaming 3
CPU
i7 8700
Graphics
Gigabyte Aorus RX580
Mac
MacBook Air
Mobile Phone
iOS
Install goes really easy IMO, I used the new APFS, so but everything works following the guide that I posted previously ( http://climbjoe.com/macos-high-sierra-version-10-13-2-coffee-lake-system-build-intro/)

I have had a couple crashes where the screen has gone black and then the fans on the Vega spins to max? not sure only happened twice but both times after playing Mafia III over steam and after I stop playing never while playing? Still trying to track it down let me know if you need any help..
Just curious, but what system definition are you using?
 
Joined
Feb 24, 2013
Messages
2,240
Motherboard
ASUS WS X299 SAGE/10G
CPU
i9-9980XE
Graphics
Radeon VII
Mac
MacBook Pro
Mobile Phone
iOS
Just an update with Vega FE 16GB (With iMac Pro SMBIOS) after few weeks of use.

Really good board, although it runs really hot (which makes sense, all reviews said this). I have a well ventilated case. I might just put back my noctua fans to help with that.

I also dual boot to Windows for gaming and I underclock the memory a little bit and push the fans a bit to make it run cooler and I easily get 60+fps at 1440p60. It sits somewhere between the 1080 and 1080Ti in terms of gaming performance.

Under macOS it runs perfect and works fluid in ALL Adobe apps and Davinci Resolve. I can't say the same for nVidia cards as I had issues with them in High Sierra.

Overall very happy. I just wish it ran cooler on stock speeds. You can barely touch the thing when it's at 80% load.
 
Last edited:
Top