Contribute
Register

Vega 56 fan control on 10.14.5

Joined
Mar 19, 2019
Messages
73
Motherboard
Maximus XI Hero
CPU
I9-9900K
Graphics
Vega 56
Mobile Phone
Android, iOS
So with the recent update to 10.14.5, supposedly apple has fixed the vega fan curves. Well, even running a custom game on league I'm hitting 70c on my GPU. Which isn't terrible I know, but on windows I'm hitting 43c max. The fans barely kick in at all and at high temps, running around 10-15%, which is ridiculously low. Does anyone have an idea how I can control the fan curve on my vega 56? (btw i tried 3 guides on VGtab and that **** is garbage all around), I tried all the settings and even when the fans were working properly under load, they don't go back to low fan speeds after the load reduces. Macs fan control doesn't recognize any fans on my system even with the required kexts. I refuse to use this install until I have control over the temps on my hardware.

Edit: just ran unigine heaven stress test and temps reached 76c and fans are barely running. this is BS imo.
 
Last edited:
Joined
Aug 11, 2015
Messages
2
Motherboard
Gigabyte Z390 AORUS PRO WIFI
CPU
i7-8700K
Graphics
Vega 64
Mac
MacBook Pro
Mobile Phone
iOS
I have a similar problem, my Sapphire Radeon RX Vega 64 Nitro+ produces with 10.14.5 so much more heat, I reach 91C° (hwmonitor). with ioreg the temperature is only at 67C° with 2200RPM, i think macos use the wrong "sensor" for the fancontrol because after 91C°(hwmonitor) my PC freezes. with vgtab i can get the temperature under control but only with a lot of noise.
 
Joined
Mar 19, 2019
Messages
73
Motherboard
Maximus XI Hero
CPU
I9-9900K
Graphics
Vega 56
Mobile Phone
Android, iOS
I have a similar problem, my Sapphire Radeon RX Vega 64 Nitro+ produces with 10.14.5 so much more heat, I reach 91C° (hwmonitor). with ioreg the temperature is only at 67C° with 2200RPM, i think macos use the wrong "sensor" for the fancontrol because after 91C°(hwmonitor) my PC freezes. with vgtab i can get the temperature under control but only with a lot of noise.
Strange, How did you manage to get GPU die temp in hwmonitor? I'm using istats menu because hwmonitor doesn't have GPU for me, even with the newest smc kexts.
 
Joined
Sep 6, 2018
Messages
6
Motherboard
MSI Z370 Gaming Carbon Pro
CPU
8700K
Graphics
Vega 56
I'm having the same problems with a Sapphire Pulse Vega 56.
When idling, the temperature reads out as 50-52 degrees, with the fans at 1400 rpm. When the temp goes above 52, the fans will ramp up for a short while, until the temp is down to 50 again.
In windows the idle temp is around 35 degrees with the fans off and 28-30 with the fans at 1400 rpm.
Definitely seems like the sensor readout is wrong, and the fan curve is too aggressive because of this.
 
Joined
Sep 20, 2012
Messages
39
Motherboard
Gigabyte GA-Z77X-UP5 TH
CPU
E3-1245v2
Graphics
RX Vega 56
Mac
iMac, MacBook Air
Mobile Phone
iOS
EDIT:
I forgot to remove the manual Injection of Device Properties for Power and Fan control
https://www.tonymacx86.com/threads/guide-injection-of-amd-vega-power-and-fan-control-properties.267519/

After removal from my Clover config.plist, the new behavior is:
Fan standing still until about 70 degrees celcius, than the fan kicks in at about 2000rpms. Stops when below 65 degrees.

This means, the display port cable inside my Vega is untouchable hot! Same goes for the card in the slot. Really hot.


I just want to copy that. I have the exact same problem with my Vega56. just letting 10.14.5. sit there completely idle, the fan will go steadily faster until it is really loud after about 5 minutes.
 
Last edited:
Top