Contribute
Register

Using Triple Monitors on 7970 Crashes MAC OS X 10.9

Joined
Mar 11, 2014
Messages
7
Mac
Classic Mac
Mobile Phone
So Currently I've had an issue that whenever I have more than 2 monitors connected Maverick will hang and crash immediately. Here some some details about my Computer's Spec.

•Motherboard: ASUS Maximus Hero VI Z87
•CPU: Intel Core i7 4770k @ 4.5Ghz
•GPU: AMD Gigabyte HD Radeon 7970
•Ram: 16GB 1600Mhz G.Skill DDR3
•HDD: Western Digital Black 650GB 7200 RPM
•PSU: 850 Watt

After some troubleshooting I noticed that I can have 2 monitors if connect in these port on my GPU:
•DVI
•HDMI

However If I try to use any of the two Mini-Displayports the OS will crash. In order to use three monitors with this GPU one of the Two Mini-DP has to be used for example:
•DVI
•HDMI
•Mini-DP

or

•DVI
•Mini-DP
•Mini-DP

etc etc.

I'm not sure how to troubleshoot and fix this any further, If anyone has any ideas or similiar issue please let me know.

On as side note if it matters, While i'm on Windows HDD i can use the Three Monitors Perfectly while Gaming, Multitasking, and even using Eyefinity.
 
Joined
Jul 7, 2014
Messages
3
Motherboard
ASUS Maximus VII Impact (Mini-ITX Z97)
CPU
i7 4790K
Graphics
Gigagbyte GTX 970 G1 Gaming
Mac
MacBook Air
Classic Mac
Mobile Phone
iOS
I'm concerned that you never got any support with this issue as I have the same or similar issue.

- Did you solve this issue?
- Are you still looking to solve it?

I have an MSI HD7970 and 3 x AOC E2461Fwh LCD LED 23.6" HDMI Monitors which work fine in Windows 7 with Eyefinity.

The card has 2 x DP, HDMI & DVI. I don't believe the lower DP works if using the HDMI port.

My windows setup is DP -> Display 1 (left), HDMI -> Display 2 (middle), DVI -> Display 3 (right).

In OS X Mavericks 10.9.4 I can only use 2 of the screens (I usually unplug the DP) but I can use any 2.

When I plug in the DP to add Display 1 (my left display), display 3 (right) goes blank and I have 1 and 2 working. However only the mouse works. If I click anywhere I get the Beach Ball. If I unplug any screen full function is returned. The OS can 'see' the 3rd display because when I move from display 1 to display 2 the mouse disappears for the width of one display before it returns on display 2.

I'm sorry I have no clue where to start with fixing this problem but I'm sure someone does. I'm willing to accept that the simplest solution may be to buy a different graphics card. I have a few 6850's and 6870's but bought the 7970 specifically for my first Hackintosh as it has native support and I didn't find any evidence that people had 6000 series cards working which I have since. I'm reliably informed that the equivalent nVidia cards aren't worth the extra money compared to a relatively cheap 7970. Once the R290 is working I'd be happy to buy one of those.

 
Top