Contribute
Register

Using NVME SSD with PCI-E adapter

Joined
Apr 9, 2017
Messages
70
Motherboard
ASUS ROG MAXIMUS VI HERO
CPU
i5-4670K OC 4.5 GHz
Graphics
GTX 780, HD 530
Maximus VI HERO Z87 motherboard here.

Interested in getting a NVME SSD for hackintosh and the motherboard doesn't have native m.2 slot.

So if i use a NVME SSD with a PCI-E adapter, would i run into any sort of problems?

Also, according to the manual, if i install the adapter on the second PCI E 3.0 X16 slot, both the first(which the GPU sits in) and the second PCI E 3.0 X16 slot becomes X8.

Should i be concerned about this? Should i instead put the adapter in the PCI E 2.0 X4 slot?
 
Joined
Nov 25, 2015
Messages
528
Motherboard
Gigabyte Z170N-Gaming 5
CPU
i5-6500
Graphics
RX 560 4GB
You should have no problem using the NVMe with a PCIe adapter. I did this before myself and I used it on the 1st slot and used my GPU in the 3rd slot because my 2nd slot was PCIe x1 and I hooked up my wifi/bt adapter in that one. I had no problems with the GPU either. I was using a z97 board at the time.
 
Joined
Apr 9, 2017
Messages
70
Motherboard
ASUS ROG MAXIMUS VI HERO
CPU
i5-4670K OC 4.5 GHz
Graphics
GTX 780, HD 530
i am assuming your 1st and 3rd slots are PCI E 3.0 x16 ?
 

Gigamaxx

Moderator
Joined
May 15, 2016
Messages
5,677
Motherboard
GIGABYTE Z170M D3H
CPU
i5-6500
Graphics
RX 480
Mac
iMac
i am assuming your 1st and 3rd slots are PCI E 3.0 x16 ?
Check to see if you need to update your motherboard bios for NVME compatibility. I used a 970 evo in the X4 slot and still had 16 lanes for graphics. The evo only ran at 1500 and 750 but it is still faster than a 500 500 speed ssd.
 
Joined
Apr 9, 2017
Messages
70
Motherboard
ASUS ROG MAXIMUS VI HERO
CPU
i5-4670K OC 4.5 GHz
Graphics
GTX 780, HD 530
It looks z87 motherboard cannot boot from NVME drives.

Is this a windows issue or is this also true for hackintosh? Does Clover solve this issue?
 

Gigamaxx

Moderator
Joined
May 15, 2016
Messages
5,677
Motherboard
GIGABYTE Z170M D3H
CPU
i5-6500
Graphics
RX 480
Mac
iMac
It looks z87 motherboard cannot boot from NVME drives.

Is this a windows issue or is this also true for hackintosh? Does Clover solve this issue?
@Stork may have some input on this issue. There may be some clover NVME drivers but I’m not sure. It may be dependent on mobo model and bios availability.
 

Stork

Admin
Staff member
Joined
Sep 21, 2010
Messages
13,275
Motherboard
ASUS ROG MAXIMUS X HERO Z370
CPU
i7-8700K
Graphics
RX 580
Mac
MacBook Pro, Mac mini, Mac Pro
Classic Mac
Power Mac, PowerBook
Mobile Phone
iOS
It looks z87 motherboard cannot boot from NVME drives.

Is this a windows issue or is this also true for hackintosh? Does Clover solve this issue?
The Z87 motherboards did not have the BIOS to support booting from NVMe drives. I had to use a modified BIOS for my Z77X to boot into a NVMe drive.

I got my BIOS from this post which also gives the reference for modifying a BIOS for NVMe support.

 
Top