Contribute
Register

Using a Presonus Quantum Thunderbolt 2 Audio Interface...HELP

BreBo

Moderator
Joined
Oct 17, 2011
Messages
9,643
Motherboard
Gigabyte GA-Z87X-OC
CPU
i7-4770K
Graphics
GTX 970
@Slaughter, please update your profile (account details) with your Motherboard, CPU and iGPU or Graphics Card(s).
If you have a prebuilt computer enter make and model instead of motherboard.
The Rules said:
Profiles are mandatory so that others can assist you.
 
Joined
Aug 22, 2017
Messages
337
Motherboard
Z390 Designare
CPU
i9-9900k
Graphics
RX 580
Mac
iMac
Mobile Phone
iOS
There you go. :) I now have a working VRS8 and it didn't seem to break anything. Though that remains to be seen. No USB problems, but I already had a custom USBMap.kext.

I'm so happy! Thank you @joevt !!! And thanks @luckyal

I somehow missed the not dropping DMAR step...

No need to modify VRS8AudioDriver.kext.

I'm beyond elated!
I'm getting ready to build a hack for a friend based on z390 so this is welcome news! I had a feeling you guys were missing a step.
 
Joined
Feb 15, 2019
Messages
21
Mac
iMac
@joevt I am only in research mode.... no hackintosh... so can't help unfortunately. Surely the OP has that info? "PreSonus" is in the title... Will have to scroll back... I might tag or quote them to get their attention...
 
Joined
Feb 15, 2019
Messages
21
Mac
iMac
@BreBo, I don't have a Hackintosh yet, so I am not here for help with my build. I am here to research before I build. Hence my profile has no Hackintosh machine details. I don't have one yet!
 
Joined
Feb 15, 2019
Messages
21
Mac
iMac
Ok so are any of the PreSonus users who started this thread back in 1957 even still here since it became a thread about Slate? If so - consider this a shoutout to you to try a few things which have been documented over the last page or so.... @chicago_mike, @jdlux, @CDT
 
Joined
May 6, 2016
Messages
29
Motherboard
Gigabyte X299 Designare
CPU
i9-7940X
Graphics
GTX 1060
Mac
iMac
Maybe the "same leap" works with the PreSonus - did you try those instructions?

No one has posted the information for the PreSonus setup yet or found the log messages that point to an error. Maybe logging uses a special method, so maybe you need to ask them how to enable logging to discover what the problem is with the driver.
Apologies for my errors. Will use the code you provided and re up some info tomorrow for you. Thanks again for your continued support on this...
 
Joined
Jan 13, 2011
Messages
18
Motherboard
X299 Prime Deluxe
CPU
i9-7900K
Graphics
2x Vega 64
Thanks again to all guys involved for contributing in here. Im glad that MyTosh have now approved the fix and we see a second vrs8 working. We need a different approach on the x299 Boards, no news so far. Same problem with the memory mapping. We need to drop DMAR tables, if not the machine is simply not booting anymore. We are still on it....

The driver for the cheesegrater macpro´s is probably affected with the same issues, i can smell it ;-) Its still not released yet...maybe if the developers are fixing it in a newer driver release, we all get it to work...who knows?!

Fact is, its connected on hardware that is over 10 Years old (pcie card) an the whole world knows the issues with the sound cards containing these via chipsets, so we are basically slab a dead horse here!!!!
 
Last edited:
Joined
May 6, 2016
Messages
29
Motherboard
Gigabyte X299 Designare
CPU
i9-7940X
Graphics
GTX 1060
Mac
iMac
Your IOREG.txt and Kextstats.txt files appear to be .rtf files. If you use TextEdit.app, remember to use the "Make Plain Text" command in the Format menu.

For ioreg, please use the command described in #47 (so all the properties are extracted and the width is not truncated - because I can't see the id of the device that is connected to Thunderbolt)
Code:
ioreg -lw0 > ioreg.txt
For kextstat, include everything so we can see the status of the entire set of loaded kernel extensions
Code:
kextstat > kextstat.txt
Like so?
 

Attachments

Joined
Apr 5, 2016
Messages
737
Motherboard
GIGABYTE Z170X-Gaming 7
CPU
i7-6700K
Graphics
GTX TITAN X
Mac
iMac, MacBook, MacBook Air, MacBook Pro, Mac mini, Mac Pro
Classic Mac
Apple, LC, Power Mac
Mobile Phone
iOS
Better.

kextstat shows the com.presonus.pae-quantum driver is loaded.

ioreg shows the Quantum device "pci1c67,101" connected to Thunderbolt. This matches the first personality "Quantum1" of the quantum_driver.kext.

But we don't have a log message showing an error for why the driver doesn't attach to the device.

Check console app for related log files?

Is the device turned on and connected before boot?

I think there should be a "InitLogging" message in the boot log.

Can you "sudo kextunload /System/Library/Extensions/quantum_driver.kext"? Note the time, then "sudo kextutil" to load the extension. Then get a log (set the start time and end time) or check console.app.
 
Joined
May 6, 2016
Messages
29
Motherboard
Gigabyte X299 Designare
CPU
i9-7940X
Graphics
GTX 1060
Mac
iMac
Great, I will pull up console today and have a look. Am I looking for files that contain the pci id and/or than contain the word quantum?

Device is plugged in and switched on before machine is powered up yes.

Shall I run another boot log?
 
Top