Contribute
Register

USBMSC Identifier (non-unique)

Joined
Oct 29, 2012
Messages
150
Motherboard
ASUS H61M-K
CPU
i5-2500
Graphics
GT 610
Mac
iMac
Mobile Phone
Android
After weeks of error-free use my hack won't boot anymore and it's getting stuck on "USBMSC Identifier (non-unique)", i've tried Graphics enabler boot flags, -x -s -f, nothing seems to work, i'm booting from USB using clover bootloader, i removed all my USBs and left barely anything connected, i can't pin this down, the error also happens when i restore my time machine back up so all of my data is useless until i find a way to bypass this. Any help?
 
Joined
Oct 29, 2012
Messages
150
Motherboard
ASUS H61M-K
CPU
i5-2500
Graphics
GT 610
Mac
iMac
Mobile Phone
Android
Just a follow up if people go through same issue, apparently enabling trim is the reason, i'll have to live without it, something about disabling the new kext signing security that messes everything up.
 

P1LGRIM

Moderator
Joined
Mar 2, 2012
Messages
20,580
Motherboard
Lenovo ThinkStation p300 ⌘
CPU
i7-4790K
Graphics
HD 4600
Mac
MacBook Pro, Mac mini
Classic Mac
Power Mac
Mobile Phone
iOS
Just a follow up if people go through same issue, apparently enabling trim is the reason, i'll have to live without it, something about disabling the new kext signing security that messes everything up.
I use Chameleon SSD Optimizer, it's free and it works fine with Yosemite and Clover - Link.

make sure you have selected kext-dev-mode=1 in Clover Boot options.

Good Luck
 
Joined
Oct 29, 2012
Messages
150
Motherboard
ASUS H61M-K
CPU
i5-2500
Graphics
GT 610
Mac
iMac
Mobile Phone
Android
I use Chameleon SSD Optimizer, it's free and it works fine with Yosemite and Clover - Link.

make sure you have selected kext-dev-mode=1 in Clover Boot options.

Good Luck
Thanks for the reply.
I did try Chameleon SSD Optomizer but it asks for disabling kext signing, i select yes, reboot try to enable trim and it asks for disabling kext signing again and again.
 

P1LGRIM

Moderator
Joined
Mar 2, 2012
Messages
20,580
Motherboard
Lenovo ThinkStation p300 ⌘
CPU
i7-4790K
Graphics
HD 4600
Mac
MacBook Pro, Mac mini
Classic Mac
Power Mac
Mobile Phone
iOS
Thanks for the reply.
I did try Chameleon SSD Optomizer but it asks for disabling kext signing, i select yes, reboot try to enable trim and it asks for disabling kext signing again and again.
That's why you have to use kext-dev-mode=1

Good Luck
 
Joined
Oct 29, 2012
Messages
150
Motherboard
ASUS H61M-K
CPU
i5-2500
Graphics
GT 610
Mac
iMac
Mobile Phone
Android
That's why you have to use kext-dev-mode=1

Good Luck
I booted with kext-dev-mode=1, enabled Trim successfully then i rebooted and my VoodooHDA started making static/white noise so i reinstalled the audio driver and modified the iGain to 0 inside voodooHDA kext (This is what i usually do to make the white noise disappear) and the computer got stuck again after rreboot on USBMSC Identifier, i guess its not gonna work for me, at least now i know what initiates the error so that's something good out of trying. Luckily i had a time machine backup prior making system wide changes. Thanks for the help! :angel:
 

P1LGRIM

Moderator
Joined
Mar 2, 2012
Messages
20,580
Motherboard
Lenovo ThinkStation p300 ⌘
CPU
i7-4790K
Graphics
HD 4600
Mac
MacBook Pro, Mac mini
Classic Mac
Power Mac
Mobile Phone
iOS
I booted with kext-dev-mode=1, enabled Trim successfully then i rebooted and my VoodooHDA started making static/white noise so i reinstalled the audio driver and modified the iGain to 0 inside voodooHDA kext (This is what i usually do to make the white noise disappear) and the computer got stuck again after rreboot on USBMSC Identifier, i guess its not gonna work for me, at least now i know what initiates the error so that's something good out of trying. Luckily i had a time machine backup prior making system wide changes. Thanks for the help! :angel:
Sorry to 'hear' that.

Good Luck
 
Joined
Oct 29, 2012
Messages
150
Motherboard
ASUS H61M-K
CPU
i5-2500
Graphics
GT 610
Mac
iMac
Mobile Phone
Android
Sorry to 'hear' that.

Good Luck
Is it possible to keep a backup of non-patched IOAHCIFamily.kext on my Clover bootable USB and use it on boot incase something else triggers this error since everything i do that has to deal with this kext is causing the same error and now im hesitant to install any driver except Audio and Network.
 
Joined
Oct 28, 2010
Messages
4
Motherboard
Mac
CPU
i7
Graphics
Can't remember
Mac
Classic Mac
Mobile Phone
I encountered this issue while upgrading to Yosemite, on a "Customac 2010" Gigabyte X58A-UD3R build.

On verbose boot I would hang at "USBMSC Identifier (non-unique)", pause for around 15 seconds, then have "Still waiting for root device" repeatedly shown.

Removing "Trim Enabler > 10.10.x TRIM Patch" from Multibeast allowed me to boot successfully. I then re-enabled TRIM using Chameleon SSD Optimizer, and everything seems to be fine.

For Trim enabler to work I had to use their "Yosemite and kext sign control" instructions here: http://chameleon.alessandroboschini.com/faq.php
 
Joined
Dec 23, 2015
Messages
2
Motherboard
DELL Vostro 3350
CPU
Intel Core i5-2450M
Graphics
AMD Radeon HD 6490M
Mac
Classic Mac
Mobile Phone
I'm facing same problem..i can't boot to my yosemite usb on my vostro 3350 and getting same error message. How do you remove the trim setting in multibeast? I've no other working system. Do I need to creat other yosemite boot usb drive? Pls help me. Tq.
 
Top