Contribute
Register

USB SSD install not working when moved to SATA port

Status
Not open for further replies.
Joined
Jan 7, 2014
Messages
21
Motherboard
HP Pavilion 14-bk1xx-OC0.6.3
CPU
i5-8250U
Graphics
UHD 620
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. Android
Hi I managed to install a working High Sierra install using an SSD drive connected by USB.

When I moved the SSD to the SATA port to run the system faster, the drive is visible in the BIOS and even loads the clover boot loader, however once loading after a while the apple boot logo changes to a no-entry sign and stops there.
I have tried loading with Verbose on and nothing details the problem. I will upload to YouTube and link here if it helps?

I have another external USB HDD with a working High Sierra install and hen I load this I can not see the High Sierra SSD drive (the one connected to internal SATA).

Any ideas? Maybe install a working SATA Kext or something?
I am using an old intel P55 motherboard from a Dell XPS 8000.

Thanks for any help.
 

BreBo

Moderator
Joined
Oct 17, 2011
Messages
9,489
Motherboard
Gigabyte GA-Z87X-OC
CPU
i7-4770K
Graphics
HD 4600 / RX 580
Any ideas? Maybe install a working SATA Kext or something?
I am using an old intel P55 motherboard from a Dell XPS 8000.
Certain SATA controllers have issues with AppleAHCIPort v329 (eg ICH10, 5 series, 7 series, ASMedia 1061)
Disks may fail to initialize, not readable or hot plug may fail.

See [Solved] ICH10R and High Sierra and try Fix for ICH10.
Or see [Solved] Problem: HDD not supported and try new ICH patch.

Or see [Solved] Drives not showing up in installer "Disk I/O error" and try Apple AHCIPort.kext v328.
Note: AppleAHCIPort.kext v328 will only work if installed in /Library/Extensions and using a kext installer like KextBeast.
 
Joined
Jan 7, 2014
Messages
21
Motherboard
HP Pavilion 14-bk1xx-OC0.6.3
CPU
i5-8250U
Graphics
UHD 620
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. Android
Wow thank you. Will read through and try some out. Thank you.
 
Joined
Jan 7, 2014
Messages
21
Motherboard
HP Pavilion 14-bk1xx-OC0.6.3
CPU
i5-8250U
Graphics
UHD 620
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. Android
Ive given these a go and none work when the SSD is plugged internally connected to the SATA port on the motherboard.
However, when I use a USB to SSD caddy, it all works fine.
I thought maybe it was a TRIM problem as my motherboard is legacy (intel P55-WB) but this did not get me anywhere when researching this side of things.

I'd like to have the SSD as a SATA drive and not plugged in as USB if possible. Any other thoughts?

Thanks again.
 
Status
Not open for further replies.
Top