Contribute
Register

USB ports working except when connecting an external hard drive

Joined
Aug 24, 2018
Messages
29
CPU
i7
Graphics
RX 580
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. iMac
  2. Power Mac
  3. PowerBook
Or:

Install USB Inject All kext
Then, the following patch in config file with clover configurator under the kext patches tab:

New USB port limit patch


Comment: USB Port limit patch 10.14 (credits FredWst)
Name: com.apple.driver.usb.AppleUSBXHCI
Find: 83 FB 0F 0F 83 03 05 00 00
Replace: 83 FB 0F 90 90 90 90 90 90
Sorry to reply to an existing post, but I thought this was the most logical place to..well, rely to. :)
I've attached my current KextsToPatch list for you to see.
There is an AppleUSBXHCI kext in there, however it doesn't get the external drives to work. Do you think I should I toss it and build the one you suggested?
 

Attachments

  • Screen Shot 2018-10-12 at 11.25.48 PM.png
    Screen Shot 2018-10-12 at 11.25.48 PM.png
    38 KB · Views: 27
Joined
Dec 11, 2013
Messages
90
Motherboard
Asus Maximus VI Extreme
CPU
i7-4770K
Graphics
GTX 780
Mac
  1. iMac
Classic Mac
  1. iMac
Mobile Phone
  1. iOS
I will tell you a stupid idea that worked for me, my front USB ports 2.0 on the case wasn't working

I did uninstall all kexts related to usb I was installing them using Multibeast version 10.4.0

uninstall:
AHCI_3rdParty_eSATA.kext from /Library/Extensions.
AHCI_3rdParty_SATA.kext from /Library/Extensions
GenericUSBXHCI.kext from /Library/Extensions.
FakePCIID_XHCIMux.kext from /Library/Extensions

then verify your HDD from disk utility and repair permission and rebuild cache using kext wizard and restart

remember those kexts you're uninstalling if anything went wrong then reinstall them

good luck
 
Joined
Aug 24, 2018
Messages
29
CPU
i7
Graphics
RX 580
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. iMac
  2. Power Mac
  3. PowerBook
I will tell you a stupid idea that worked for me, my front USB ports 2.0 on the case wasn't working

I did uninstall all kexts related to usb I was installing them using Multibeast version 10.4.0

uninstall:
AHCI_3rdParty_eSATA.kext from /Library/Extensions.
AHCI_3rdParty_SATA.kext from /Library/Extensions
GenericUSBXHCI.kext from /Library/Extensions.
FakePCIID_XHCIMux.kext from /Library/Extensions

then verify your HDD from disk utility and repair permission and rebuild cache using kext wizard and restart

remember those kexts you're uninstalling if anything went wrong then reinstall them

good luck
I never had any of those extensions to begin with. I'm toying with past suggestions on the board now that I'm backing the office and post an update once I get a result. :) Thank you for the help!
 
Joined
Aug 24, 2018
Messages
29
CPU
i7
Graphics
RX 580
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. iMac
  2. Power Mac
  3. PowerBook
Ok, great update here!

1- I just downloaded Multibeast for High Sierra onto my desktop.

2- Then I loaded in..
•3rd Party 3.0
•Remove XHCI USB Port Limit
&
•USBInjectAll (again)

3- Hit 'Build' and restarted.

4- Plugged my two external hard drives into the back of the rig via a USB hub I use for my MacBook Pro
(because it only has two USB dots after all)
and BAM!
My externals appeared on my desktop!

I now have a fully functioning HackPro!
Thank you guy so much for your help with this puzzle!
 

Attachments

  • iur.jpeg
    iur.jpeg
    59.3 KB · Views: 20
Top