Contribute
Register

USB mouse not working after upgrade to Yosemite

Status
Not open for further replies.
Joined
Dec 30, 2013
Messages
10
Motherboard
Gigabit << need model # >> See Forum Rules !!
CPU
i5 << need model # >> See Forum Rules !!
Graphics
<< need model # >> See Forum Rules !!
Mac
  1. MacBook
Mobile Phone
  1. Android
My Wireless mouse stopped working after upgrading to Yosemite. It works fine under windows. Any ideas?

I also have a logitech wireless desktop that doesn't work properly after the upgrade but i can get that to work by unplugging and replugging it after booting.

My usb bluetooth dongle works fine so it doesn't seem to be USB in itself that stops working.
 
Joined
Jun 22, 2014
Messages
60
Motherboard
Asus Maximus VII Formula
CPU
Core i7 - 4790k 4.0 GHz
Graphics
Gigabyte GTX 770 4GB
Mac
  1. iMac
Classic Mac
Mobile Phone
  1. iOS
My Wireless mouse stopped working after upgrading to Yosemite. It works fine under windows. Any ideas?

I also have a logitech wireless desktop that doesn't work properly after the upgrade but i can get that to work by unplugging and replugging it after booting.

My usb bluetooth dongle works fine so it doesn't seem to be USB in itself that stops working.

After I upgraded to Yosemite half of my 3.0 and 2.0 ports do not work, but they do work in Windows. I have about 4 working USB ports that work and I also have to unplug and plug them back in for them to work.
 
Joined
Oct 4, 2014
Messages
48
Motherboard
GA-Z97X-Gaming 5
CPU
i7-4790k
Graphics
GTX 970
Mac
Classic Mac
Mobile Phone
Try other usb ports. Mine seems to cycle between different ports. After a reboot, the ports that were working, no longer work, and i have to switch my usb's. Its very strange.
 
Joined
Jun 22, 2014
Messages
60
Motherboard
Asus Maximus VII Formula
CPU
Core i7 - 4790k 4.0 GHz
Graphics
Gigabyte GTX 770 4GB
Mac
  1. iMac
Classic Mac
Mobile Phone
  1. iOS
Try other usb ports. Mine seems to cycle between different ports. After a reboot, the ports that were working, no longer work, and i have to switch my usb's. Its very strange.

Yep this is what happens with me.
 
Joined
Aug 19, 2014
Messages
51
Motherboard
Lenovo M920s
CPU
i5-9500
Graphics
Intel UHD 630
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Joined
Jan 4, 2011
Messages
10
Motherboard
H55M-USB3 Mavericks
CPU
Intel Core i5
Graphics
Asus Nvidia GeForce GT 640
Mac
  1. MacBook Pro
Classic Mac
Mobile Phone
  1. iOS
I have this problem too. I can't use my trackpad+keyboard now.
 
Joined
Oct 25, 2013
Messages
8
Motherboard
Still unnamed
CPU
4670K @ only 4.0 GHz
Graphics
Gigabyte GTX 770 Windforce
Mac
  1. MacBook Air
  2. MacBook Pro
Classic Mac
Mobile Phone
  1. iOS
I have the same issue, half of my USB 3.0 and all of my USB 2.0 ports are broken. And the ones that work change upon each reboot depending (or so it seems) on which has stuff plugged in...
I'd really appreciate any help to resolve this.
 
Joined
Sep 10, 2014
Messages
291
Motherboard
Asus Z97-A/USB3.1
CPU
i7-4790
Graphics
RX 580
Mac
  1. iMac
Classic Mac
  1. iBook
  2. iMac
Mobile Phone
  1. iOS
Joined
Oct 4, 2014
Messages
48
Motherboard
GA-Z97X-Gaming 5
CPU
i7-4790k
Graphics
GTX 970
Mac
Classic Mac
Mobile Phone
Yes I figured it out. Stork mentioned this in a yosemite guide and other people in some threads been mentioning it. When you do the very first multibeast run, DO NOT select USB 3.0 Universal. that is only for series 5&6 boards, I believe. 7, 8, and 9 series do not need that usb kext.

Personally, I just reinstalled Yosemite, but some of you might want to just revert the USB 3.0 kext. I will link you to post #10 by Stork, who explains how to remove that:
http://www.tonymacx86.com/yosemite-...l-gigabyte-h97n-wifi-intel-i3.html#post889835



Hope this helps. And thank you Stork for always coming through :)
 
Status
Not open for further replies.
Top